Ludeon Forums

RimWorld => Support => Topic started by: Darkshire on October 04, 2019, 10:43:38 PM

Title: Rimworld doesn’t start after Catalina Update
Post by: Darkshire on October 04, 2019, 10:43:38 PM
I'm using the most recent Rimworld update on macOS 10.13.6.

Rimworld seems to crash every time I try to open it using Steam. When I start-up Rimworld, it says "Last time you opened Rimworld, it unexpectedly quit while reopening windows. Would you like to reopen those windows? [Don't Reopen, Reopen]".

Clicking either of these options crashes the game, and not clicking either option crashes the game too.
Attached is the .txt file for the crash log.
I tried rebooting my computer, and that didn't seem to help.

Edit: I uninstalled and reinstalled Rimworld, which didn't solve anything. I also updated macOS to 10.14.4, which also didn't solve anything. The only difference is that now it no longer throws the crash log.
Title: Re: [1.0] Rimworld Crashes on Startup
Post by: Canute on October 06, 2019, 06:22:17 AM
Hi,
sorry the mac log don't look familar for me.
But many problem happen from old video driver. Not sure if you need to update them self or this happen with the macOS update too.

Title: Re: [1.0] Rimworld Crashes on Startup
Post by: Darkshire on October 08, 2019, 12:07:12 PM
Hmmm, I don't think macOS even has video driver updates. The mac's video driver is usually built into the OS itself I think.

Title: Rimworld doesn’t start after Catalina Update
Post by: klhsn on October 11, 2019, 03:27:01 PM
After the Update on my 2013 MacBook Air Steam works just fine. But when I try to start Rimworld it starts also but stops at ‚Initialising‘ on the start screen and throws the beachball up.
Uninstalling Steam and Rimworld didn’t help.
Any ideas?
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Tynan on October 12, 2019, 02:40:19 PM
I'm trying to figure out if RimWorld is actually systemically broken after a MacOS update or if these are machine-specific issues.

Any other MacOS users with Catalina can comment? Does your game work?
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Darkshire on October 12, 2019, 09:29:16 PM
This originally happened to me in High Sierra, but the problem remains even after the Catalina update.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: vnihoul77 on October 14, 2019, 06:43:50 AM
Yes,
I post this log : https://ludeon.com/forums/index.php?topic=49619.0

And then I update to catalina, now, everything is fine ..
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Anarcraft on October 14, 2019, 08:23:22 AM
Some mod, or a combination thereof, causes a crash once you update to macOS 10.15, but I'm not sure which one(s).  Vanilla appears to run fine.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: mindlar on October 14, 2019, 01:13:56 PM
I updated to Catalina on my mac laptop (mid-2015 macbook pro) on Friday. Everything has been working fine for me.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Darkshire on October 14, 2019, 03:07:29 PM
I think this may have been caused by a corrupted save file or cache.

The crash log says
Exception Type:        EXC_BAD_ACCESS (SIGSEGV)


So it's probably some error caused by my game not saving or quitting correctly.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Tynan on October 14, 2019, 07:34:23 PM
I think this may have been caused by a corrupted save file or cache.

The crash log says
Exception Type:        EXC_BAD_ACCESS (SIGSEGV)


So it's probably some error caused by my game not saving or quitting correctly.

That looks more like bad memory, bad CPU, or some deep hardware driver screwing up. You can get software to test your memory.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Tynan on October 19, 2019, 02:12:10 PM
I have moved this thread to Support.

Quote from: klhsn
When I unsubscribe from all mods at the workshop and also delete the folders in the mod folder manually, is there any chance that after a reinstallation mods affect the game? Where can I find the log file? The path at the forum doesn’t help me to find it somehow. Thanks! :)

You need to make sure you're deleting the right 'mod folder'. If you delete the "Mods" folder in the base game you'll delete all the core game content and it will probably not load.

This thread (https://ludeon.com/forums/index.php?topic=4805.0) has a list of steps you should follow to reset the game to a working state. Please follow those steps now.

If you still have trouble after that, please post your log file. Your log file should be here:
Users/<UserName>/Library/Logs/Unity/Player.log

And if it's not there, please let us know!
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: klhsn on October 19, 2019, 04:22:13 PM
Thank you for your help Tynan - unfortunately it didn't help. But here is the log, maybe this could solve this issue.

Nevertheless - Thanks again for your effort!

Initialize engine version: 5.6.5f1 (2cac56bf7bb6)
GfxDevice: creating device client; threaded=1
2019-10-19 22:17:07.253 RimWorldMac[1529:17333] Metal devices available: 1
2019-10-19 22:17:07.254 RimWorldMac[1529:17333] 0: Intel HD Graphics 5000 (low power)
Initializing Metal device caps: Intel HD Graphics 5000
Begin MonoManager ReloadAssembly
Platform assembly: /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.dll (this message is harmless)
Loading /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.dll into Unity Child Domain
Platform assembly: /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp-firstpass.dll (this message is harmless)
Loading /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp.dll (this message is harmless)
Loading /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp.dll into Unity Child Domain
Platform assembly: /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.UI.dll (this message is harmless)
Loading /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.UI.dll into Unity Child Domain
Platform assembly: /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.Networking.dll (this message is harmless)
Loading /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.Networking.dll into Unity Child Domain
Platform assembly: /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/TextMeshPro-1.0.55.56.0b11.dll (this message is harmless)
Loading /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/TextMeshPro-1.0.55.56.0b11.dll into Unity Child Domain
Platform assembly: /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Core.dll (this message is harmless)
- Completed reload, in  0.067 seconds
Platform assembly: /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.dll (this message is harmless)
Platform assembly: /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Xml.dll (this message is harmless)
UnloadTime: 2.507368 ms
Setting breakpad minidump AppID = 294100
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198201051323 [API loaded no]
RimWorld 1.0.2408 rev749
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Metal RecreateSurface[0x108f4e860]: surface size 1440x900
Platform assembly: /Users/Felix/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Xml.Linq.dll (this message is harmless)
Receiving unhandled NULL exception
Obtained 12 stack frames.

Title: Re: Rimworld doesn’t start after Catalina Update
Post by: rave1976 on October 19, 2019, 05:17:06 PM
Hello!

Same issue here. Already unsubscribed from Mods, deleted folders, deinstalled Rimworld, restarted Mac and Steam... installed Rimworld... but still no chance to play. Game still freezes at message "initializing...".

Here`s our log:

Initialize engine version: 5.6.5f1 (2cac56bf7bb6)
GfxDevice: creating device client; threaded=1
2019-10-19 22:59:58.797 RimWorldMac[539:5695] Metal devices available: 1
2019-10-19 22:59:58.797 RimWorldMac[539:5695] 0: Intel Iris Pro Graphics (low power)
Initializing Metal device caps: Intel Iris Pro Graphics
Begin MonoManager ReloadAssembly
Platform assembly: /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.dll (this message is harmless)
Loading /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.dll into Unity Child Domain
Platform assembly: /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp-firstpass.dll (this message is harmless)
Loading /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp.dll (this message is harmless)
Loading /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp.dll into Unity Child Domain
Platform assembly: /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.UI.dll (this message is harmless)
Loading /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.UI.dll into Unity Child Domain
Platform assembly: /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.Networking.dll (this message is harmless)
Loading /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.Networking.dll into Unity Child Domain
Platform assembly: /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/TextMeshPro-1.0.55.56.0b11.dll (this message is harmless)
Loading /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/TextMeshPro-1.0.55.56.0b11.dll into Unity Child Domain
Platform assembly: /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Core.dll (this message is harmless)
- Completed reload, in  0.022 seconds
Platform assembly: /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.dll (this message is harmless)
Platform assembly: /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Xml.dll (this message is harmless)
UnloadTime: 1.160597 ms
Setting breakpad minidump AppID = 294100
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561197970715737 [API loaded no]
RimWorld 1.0.2408 rev749
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Metal RecreateSurface[0x108d5df80]: surface size 1920x1080
Platform assembly: /Users/stefanie/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Xml.Linq.dll (this message is harmless)
Receiving unhandled NULL exception
Obtained 12 stack frames.

Please help. Thank you!
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Tynan on October 19, 2019, 07:38:17 PM
The last informative entry is

Metal RecreateSurface[0x108f4e860]: surface size 1440x900

This is the Apple video driver initializing. So it's apparently hanging at some point during video driver initialization.

Can you look at your video drivers? Is there a driver update you can try?
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: klhsn on October 20, 2019, 04:16:13 AM
Apparently you can't manually update graphic drivers on a mac. They are automatically installed and updated via OS-Updates.
Other games like Faster Than Light start without problems.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: rave1976 on October 20, 2019, 05:31:57 AM
Agreed. Right now no more Updates for Mac OS. Others games start without Problems on iMac Mid 2014.

Tried it also on my MacPro 2013. There the Game starts and run smoothly. So only the Mac from my Girlfriend (iMac Mid 2014 with Intel Iris Pro 5000) has the mentioned problems...
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Tynan on October 20, 2019, 02:05:26 PM
I have to admit I'm kind of stumped and frustrated that apparently Apple is now breaking working software.

I hope a future RimWorld update will fix these issues; we'll probably update the Unity version at some point and that might help. But it's not something that'll be released super soon. I'm sorry I can't fix this now, I just have no insight into the problem and can't reproduce it at all.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: klhsn on October 21, 2019, 04:55:22 AM
I totally understand your frustration. At the moment my solution will be a new partition with an older macOS version to boot from to play RimWorld. Not the most convenient solution, but workable. Luckily RimWorld doesn't take up much space!
I still hope that one day an update will fix it and that apple doesn't ruin it right away :D
If i could help you in the future with more logs or so just hit me up, it's also in my interest.
However thanks again for the support, I'm now partitioning!
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: rave1976 on October 21, 2019, 01:12:21 PM
I also understand your frustration. Sad... but it seems we/you can`t change the situation right now.

Let`s hope maybe the next update of Rimworld or Catalina fix this problem, so we can enjoy Rimwold again.

For the moment thank you for your effort and greetings from a German Rimworld-Fan!
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Canute on October 21, 2019, 01:58:07 PM
Maybe i found the issue/solution.
Unity use some 32 bit wav importer and Catalina don't support 32 bit anymore.
https://forum.unity.com/threads/installing-unity-on-macos-catalina.689089/

Not sure if there is a solution, maybe take a look self.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: mindlar on October 23, 2019, 02:24:06 PM
I had problems launching the game from Steam after reinstalling on my mac laptop (mid-2015) after upgrading to Catalina. Had tried nuking everything mentioned in the threads on how to do a clean install.

Steam was tossing up an error: Failure to update and not even making it to Rimworld to launch.

What fixed things for me was navigating to the executable and launching from Finder. Game launched with errors saying that it couldn't talk to Steam overlay. Closed the game, and then launched from Steam and so far everything is good.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Tynan on October 25, 2019, 02:12:00 AM
Thanks mindlar!
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: rave1976 on October 31, 2019, 08:40:47 AM
A little Feedback: newest Update of Catalina (10.15.1) didn't change the problem. Game still freezes at "Initializing.." on iMac 2014.

So... hopefully waiting for an update...
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: ItchyFlea on November 08, 2019, 03:32:44 PM
Log received via email support. Username stripped from report.

Initialize engine version: 5.6.5f1 (2cac56bf7bb6)
GfxDevice: creating device client; threaded=1
2019-11-03 17:16:35.383 RimWorldMac[848:14210] Metal devices available: 1
2019-11-03 17:16:35.383 RimWorldMac[848:14210] 0: Intel Iris Pro Graphics (low power)
Initializing Metal device caps: Intel Iris Pro Graphics
Begin MonoManager ReloadAssembly
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp-firstpass.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.UI.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.UI.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.Networking.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.Networking.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/TextMeshPro-1.0.55.56.0b11.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/TextMeshPro-1.0.55.56.0b11.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Core.dll (this message is harmless)
- Completed reload, in  0.035 seconds
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.dll (this message is harmless)
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Xml.dll (this message is harmless)
UnloadTime: 1.499783 ms
Setting breakpad minidump AppID = 294100
Steam_SetMinidumpSteamID:  Caching Steam ID:  [Stripped Numbers] [API loaded no]
RimWorld 1.0.2408 rev749
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Metal RecreateSurface[0x1090b0f00]: surface size 1920x1080
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Xml.Linq.dll (this message is harmless)
Receiving unhandled NULL exception
Obtained 12 stack frames.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Tynan on November 09, 2019, 03:11:27 AM
Thanks Michael!

This does seem to be related to an interaction between Catalina, Metal drivers, older integrated video cards, and RimWorld's version of Unity. It's crashing as it tries to initialize a rendering surface for the whole screen, which is a low-level graphics init function.

While I'm annoying that Apple released an update that broke the game, I can understand players are more annoyed at not being able to play it.

We can't quick-fix this because it doesn't relate to code we wrote; it comes from code in the Unity engine/MacOS/Metal driver. The only real option seems to be to update Unity wholesale to a new version several years ahead of the old one, but that is a major overhaul that would break everyone's games. I do intend to address this, but I can't promise a quick immediate fix to it.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Tynan on November 13, 2019, 11:36:08 PM
I've posted an older version of RimWorld 1.0 to Steam under the beta branch catalina_test.

Some users reported this version works with Catalina.

Anyone having trouble on the latest version - can you give this one a shot and tell me if there's a difference? Thanks!
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: rave1976 on November 24, 2019, 02:05:35 PM
Hello Tynan,

thank you for your effort. Just testet the new version "Catalina_test"... but it still doesn't work for me. Still freezes at "initializing".

Is a clean installation needed? Just installed it over the latest version.

Greetings
rave1976
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Tynan on November 25, 2019, 11:43:39 PM
Hello Tynan,

thank you for your effort. Just testet the new version "Catalina_test"... but it still doesn't work for me. Still freezes at "initializing".

Is a clean installation needed? Just installed it over the latest version.

Greetings
rave1976

Steam should have synced properly. Okay, well I got another report that it worked, perhaps it was spurious.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: ItchyFlea on December 05, 2019, 11:59:59 PM
Had a report via email that a Catalina user was able to get the game running by running this command: chmod +x /path-to-game-executable
However their issue was that the game would simply come up saying that it couldn't run.

This command may not work for those who are affected by the stuck at initialising issue, but it probably wouldn't hurt to give it a try.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: chorizo on December 14, 2019, 01:23:33 PM
Had a report via email that a Catalina user was able to get the game running by running this command: chmod +x /path-to-game-executable
However their issue was that the game would simply come up saying that it couldn't run.

This command may not work for those who are affected by the stuck at initialising issue, but it probably wouldn't hurt to give it a try.

I had similar problem (probably exact same) as your user. When you attempt to open the game after a fresh installation (from zip file) you get an error:

"The application 'RimWorldMac' cannot be opened"

OS: MacOS Catalina 10.15.2
Version: RimWorld1-0-2408Mac (DRM Free)


This is how I resolved:

- Open terminal

Code: [Select]
cd /path/to/rimworld/folder/with/app//RimWorldMac.app/Contents/MacOS
Code: [Select]
ls -lah
[email protected] 1 user  staff    60M Dec 13  2017 RimWorldMac

Code: [Select]
chmod 777 RimWorldMac
Code: [Select]
ls -lah
[email protected] 1 user  staff    60M Dec 13  2017 RimWorldMac

Now you should be able to right click and open as you normally would. It appears the extractor doesn't add the necessary execute permissions to the binary executable which causes this issue.

I tried chmod -x but it didn't end up adding the executable permissions, but chmod 777 worked.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Brrainz on January 07, 2020, 04:42:33 AM
I was asked to repost this here. I had problems installing RimWorld on my Mac for development and testing and got it working:

Just a quick update from me. Latest Catalina (10.15.2) on a 2015 iMac and at first I could not get standalone RimWorld running, but after running

Quote
chmod +x /Applications/RimWorldMac.app/Contents/MacOS/RimWorldMac

and then holding the ctrl-key while right-clicking RimWorld and choosing "Open", Catalina asks if I want to allow it to run. After choosing "Open" in that dialog too, it whitelists the app and starts just fine.

/Andreas Pardeike aka Brrainz
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: slammato on January 30, 2020, 02:06:45 AM
catalina 10.15, 2018 MacBook Pro
I've had a few conversations with support, and am unable to get the game to open. (also, what are people doing with the "chmod" stuff? any hand holding on that process?)

however, I have been able to play v.2059 locally, but the game gets pretty limiting when trying to put mods into it.

i've also been playing on Steam with the (unstable) beta, but again, i'm left wondering if something isn't right with the mods i'm trying to run (mainly, Save our Ship 2 being of issue).

Has there been any progress on this issue?

Thanks
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Tynan on January 30, 2020, 03:23:29 AM
We are working on it and I hope to have an update out that should help with the issue during February.

I remain sorry that this is occurring.
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: slammato on January 30, 2020, 10:09:47 AM
We are working on it and I hope to have an update out that should help with the issue during February.

I remain sorry that this is occurring.

Thank you, Tynan! I truly appreciate the amount of work you've put into this game and that you continue to put work in. Also, I'm pretty psyched for that update!
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: Tynan on February 18, 2020, 12:39:57 AM
My hope is that with the new Unity version, this is fixed in the 1.1 unstable branch release (see ludeon.com/blog). Can anyone confirm that?
Title: Re: Rimworld doesn’t start after Catalina Update
Post by: tellerjunge on February 20, 2020, 04:19:32 PM
hey,

made an account just to say that it works now.
thank you :)