Ludeon Forums

Ludeon Forums

  • February 24, 2020, 12:58:49 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - milon

Pages: 1 2 [3] 4 5 ... 230
31
Support / Re: [A14-A17] Game can't start(With any version)
« on: July 31, 2017, 10:16:44 AM »
Before needing to do a clean reinstall, if you're getting the "[GAME] is already running" Steam error, try restarting the PC first.  That usually fixes it in my experience, but I've never had that problem with RimWorld before.

32
This is likely a mod-related issue, but I'm going to leave this thread here for now. The fact that you can open it on Mac and not on Windows seems important (but in the end it could be related to how the two handle errors).

EDIT - Forgot to say that I didn't have any immediate ideas, but I'd continue to think about it

33
Mods / Re: Need help with mod list
« on: July 28, 2017, 08:13:13 AM »
I think this will get a better answer in the Mods subforum, so I'll move it over there.

34
Support / Re: Black screen? Or, game won't run?
« on: July 27, 2017, 06:54:51 AM »
Thanks nccvoyager! I was at work when I posted that and couldn't confirm it.

Slashdiablo, about the screenshot - sorry I didn't notice that before. It *is* showing the correct path and stating that access to it it's denied.  That may be a permissions issue, or else another process is using the file. Any idea if another program was using it? Do you know how to investigate & correct permissions?

35
Support / Re: Black screen? Or, game won't run?
« on: July 26, 2017, 03:50:59 PM »
Oh, good find!

AppData is a hidden folder, so it's not easy to find. The easiest way is to open File Explorer and type the following into the address bar:
%AppData%

When you hit enter, you'll be inside the hidden folder. You'll need to follow down a branch or two to find Ludeon (I forget if it's in Local Low or Roaming) and you can wipe it from there.

About the DirectX thing - if you've got higher than 9, but RimWorld only uses DX9, then you may have an old graphics driver. It's used as a fallback in case a newer version can't initialize.

36
Support / Re: Can't install non-Steam mods
« on: July 26, 2017, 01:51:10 PM »
That's possible.

Could you get a screenshot of the mod interface and attach that here?  A log file would be good to include too.

A last random idea - I believe RimWorld stores its current mod config settings as plain text.  You might be able to edit that manually when RimWorld isn't running and see what happens when you start it up.  Just make sure to disable Steam Sync first, or else Steam will revert any changes you make manually.  (I'm at work right now, so I don't have any details on exactly how to do that.)

37
Support / Re: Black screen? Or, game won't run?
« on: July 26, 2017, 12:08:33 PM »
Try a Steam clean install this way:
1. Turn off Steam Sync for RimWorld
2. Uninstall RimWorld
3. Manually go into your Steamapps\ folder and make sure the RimWorld folder is deleted
4. Restart your computer
5. Install RimWorld and cross your fingers

I can't find the exact "clean install" steps right now, so this may be very similar, but I think it's different enough that it's worth a shot.

Don't worry about the log file unless the above doesn't work.

38
Support / Re: Black screen? Or, game won't run?
« on: July 26, 2017, 09:40:50 AM »
Interesting. Sounds like a Steam issue. A clean reinstall "should" have fixed that.

Are you running any mods? Did you run mods before the game broke?

That's a crazy log file. It looks like the game can't find any of its normal Thing definitions (or something like that). I notice it's using DX9. Was this when you were trying to force DX9? What OS are you running?

39
Then it's not there. The forum auto-deletes any attachments that are too old.

Which thread are you trying to get an attachment from?

40
Mods / Re: Help With Mod Load Order
« on: July 26, 2017, 09:34:43 AM »
See link in my sig if you need help finding the log file

41
I'll move the thread if need be.

Are you trying to upload or download attachments?

42
Support / Re: Idle Pawn Lag
« on: July 24, 2017, 05:29:54 PM »
FPS due to idle pawns is because their AI is constantly running through the job tree looking for anything they can possibly do - a very CPU-intensive process.

But my compu-tato (read: crappy PC) doesn't have that problem.  Are you running any mods?  Are you running other apps/services in the background?  Have a look at your log file (see link in my sig) and if it's not "clean", or if you're uncertain about that, upload it here.  It's often the case that there's a bunch of silent error messages happening in the background.

43
Support / Re: Crash on load-Steam/Mac version
« on: July 24, 2017, 05:26:33 PM »
I'm not a Mac user, so I won't be terribly helpful, but I did notice this:
Code: [Select]
Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_INVALID_ADDRESS at 0x000000000000002f

Looks like something attempted to access a protected or invalid memory address, but I could be wrong about that.  The other thing I noticed was that you're using an NVIDIA graphics card.  Make sure the drivers are up to date, and if it has the notorious Screen Share feature, please disable that.  It's caused a LOT of grief for Unity games (like RimWorld).

44
Support / Re: Purple Screen
« on: July 23, 2017, 05:34:08 PM »
Awesome, glad to hear it!

45
Support / Re: Can't install non-Steam mods
« on: July 22, 2017, 09:00:38 AM »
Huh, that's strange.  That should be exactly where to place them.  There is a thread that deals with installing Steam mods as non-Workshop offline mods (https://ludeon.com/forums/index.php?topic=29440.0) but you've basically done everything there.

Are you launching the Steam version of RimWorld or the DRM-free?

Can you screenshot the folder structure of a mod or two?

Pages: 1 2 [3] 4 5 ... 230