Ludeon Forums

Ludeon Forums

  • July 06, 2020, 12:53:53 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 166 167 [168]

Author Topic: [1.1.12] Hospitality (updated 20.06.2020)  (Read 948772 times)

Hrod

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.1.9] Hospitality (updated 01.05.2020)
« Reply #2505 on: May 07, 2020, 03:33:12 AM »

Hey everyone.

After a while without visitors I just spawned some visitors using dev mode. Everything went fine until they had to leave. Now there's some error and it just spams that they are leaving but they can't.

This is the error:

Code: [Select]
Exception while ticking lord with job Hospitality.LordJob_VisitColony:
System.NullReferenceException: Object reference not set to an instance of an object
  at RimWorld.IncidentQueue.Add (RimWorld.QueuedIncident qi) [0x00000] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Hospitality.Hospitality_MapComponent.QueueIncident (RimWorld.FiringIncident incident, System.Single afterDays) [0x0001d] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.GenericUtility.PlanNewVisit (RimWorld.IIncidentTarget map, System.Single afterDays, RimWorld.Faction faction) [0x00044] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.GenericUtility.TryCreateVisit (Verse.Map map, System.Single days, RimWorld.Faction faction, System.Single travelFactor) [0x00036] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.LordToil_VisitPoint.PlanRevisit (RimWorld.Faction faction, System.Single targetGoodwill, Verse.Map currentMap, System.Boolean sentAway) [0x00142] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.LordToil_VisitPoint.DisplayLeaveMessage (System.Single score, RimWorld.Faction faction, System.Int32 visitorCount, Verse.Map currentMap, System.Boolean sentAway) [0x0000a] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.LordToil_VisitPoint.Leave () [0x0015b] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.LordToil_VisitPoint.Cleanup () [0x00001] in <a20d107dfae34012a7901a1f006be785>:0
  at Verse.AI.Group.Lord.GotoToil (Verse.AI.Group.LordToil newLordToil) [0x0000f] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Verse.AI.Group.Transition.Execute (Verse.AI.Group.Lord lord) [0x00055] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Verse.AI.Group.Transition.CheckSignal (Verse.AI.Group.Lord lord, Verse.AI.Group.TriggerSignal signal) [0x000de] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Verse.AI.Group.Lord.CheckTransitionOnSignal (Verse.AI.Group.TriggerSignal signal) [0x00050] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Verse.AI.Group.Lord.LordTick () [0x0002a] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Verse.AI.Group.LordManager.LordManagerTick () [0x00011] in <4489f1367c1c4d76b2ae1272c8ed691d>:0

Anyone know how to fix this? I deleted those visitors and the message stopped. I then spawned a few more visitors and sent them away and the error was back. I'm willing to remove the mod altogether if there's no solution (destroying pawns and beds and uninstalling).

One thing that may be related to this bug: Because I wasn't getting visitors I searched the incident queue in the savegame and besides the main incident queue (empty), there was a hospitality queue with the same message repeated, which I deleted just in case.

Code: [Select]
<queuedIncidents>
<li>
<firingInc>
<def>VisitorGroup</def>
<parms>
<target>Map_0</target>
<threatPoints>-1</threatPoints>
<faction>Faction_100</faction>
<spawnCenter>(-1000, -1000, -1000)</spawnCenter>
<spawnRotation>2</spawnRotation>
<pawnGroups IsNull="True" />
<quest>null</quest>
</parms>
</firingInc>
<fireTick>10500317</fireTick>
</li>
<li>
<firingInc>
<def>VisitorGroup</def>
<parms>
<target>Map_0</target>
<threatPoints>-1</threatPoints>
<faction>Faction_101</faction>
<spawnCenter>(-1000, -1000, -1000)</spawnCenter>
<spawnRotation>2</spawnRotation>
<pawnGroups IsNull="True" />
<quest>null</quest>
</parms>
</firingInc>
<fireTick>11766826</fireTick>
</li>
</queuedIncidents>

Halp.
« Last Edit: May 07, 2020, 04:25:45 AM by Hrod »
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9037
  • Refugee
    • View Profile
Re: [1.1.9] Hospitality (updated 01.05.2020)
« Reply #2506 on: May 07, 2020, 12:22:59 PM »

Hrod,
i don't think it is Hospitality it self it is more a bad configurate faction/race or maybe your current map so they can't leave.
When i am playing a mountain base, mosttimes i dig to the map border at the mountain side. Most caravan leave through these narraow passage and many visitors.

So what version of Hospitality do you use and could you post a complete log (CTRL-F12) after you loaded the safegame and that error happen.
Logged

Hrod

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.1.9] Hospitality (updated 01.05.2020)
« Reply #2507 on: May 07, 2020, 02:05:25 PM »

I'll try digging out the side. It's actually a peninsula tile (coastlines mod) so maybe they can only leave through the north, even after digging to the side.

What I did in the meantime was to destroy the guests in dev mode (sorry friends), change the beds to normal beds, and remove the mod from the load order. Then I loaded the save again without the mod, saved, and put the mod back in the load order and loaded the save. This seems to have worked. A quick test (spawn visitors and then ask them to leave, which was causing the same issue before) shows that the problem is fixed. For now.

Logged

Orion

  • Planetologist
  • ****
  • Posts: 1140
  • And why not
    • View Profile
    • Extra Nice
Re: [1.1.10] Hospitality (updated 24.05.2020)
« Reply #2508 on: May 24, 2020, 02:06:40 PM »

Update
Code: [Select]
1.1.10 - 24.05.2020
- New: Added button to guest tab to manage map defaults
- New: Manage Defaults menu now has a setting for disabling guests for the map
- New: Russian translation by kamadz
- Fix: Beds will now only show royal title information when royalty is active
- Fix: Fixed issue with guests not finding path to base caused by locked doors
- Tweak: Optimized shopping code for performance
- Tweak: Now caching guest comp access for performance

Schwartz

  • Drifter
  • **
  • Posts: 67
  • Refugee
    • View Profile
Re: [1.1.11] Hospitality (updated 25.05.2020)
« Reply #2509 on: June 01, 2020, 01:23:30 PM »

Keep getting error logs like "Alien Framework does not have a method X", where X could be CanEat or CanWear or whatever.

I don't have any Alien Framework mod, either.

Code: [Select]
Alien Framework does not have a method 'CanWear'.
Verse.Log:Error(String, Boolean)
Hospitality.ItemUtility:AlienFrameworkAllowsIt(ThingDef, ThingDef, String)
Hospitality.JoyGiver_BuyStuff:ApparelScoreGain(Pawn, Apparel)
Hospitality.JoyGiver_BuyStuff:Likey(Pawn, Thing)
Hospitality.<>c__DisplayClass5_0:<TryGiveJob>b__5(Thing)
Verse.GenCollection:MaxBy(IEnumerable`1, Func`2, IComparer`1)
Verse.GenCollection:MaxBy(IEnumerable`1, Func`2)
Hospitality.JoyGiver_BuyStuff:TryGiveJob(Pawn)
Hospitality.JobGiver_Relax:GetJob(Pawn, List`1, Job&)
Hospitality.JobGiver_Relax:TryGiveJob(Pawn)
Verse.AI.ThinkNode_JobGiver:TryIssueJobPackage(Pawn, JobIssueParams)
Verse.AI.ThinkNode_PrioritySorter:TryIssueJobPackage(Pawn, JobIssueParams)
Verse.AI.ThinkNode_Priority:TryIssueJobPackage(Pawn, JobIssueParams)
Hospitality.ThinkNode_FilterGuestRooms:TryIssueJobPackage(Pawn, JobIssueParams)
Verse.AI.ThinkNode_Priority:TryIssueJobPackage(Pawn, JobIssueParams)
RimWorld.ThinkNode_Duty:TryIssueJobPackage(Pawn, JobIssueParams)
Verse.AI.ThinkNode_Priority:TryIssueJobPackage(Pawn, JobIssueParams)
Verse.AI.ThinkNode_Conditional:TryIssueJobPackage(Pawn, JobIssueParams)
Verse.AI.ThinkNode_Priority:TryIssueJobPackage(Pawn, JobIssueParams)
Verse.AI.ThinkNode_Tagger:TryIssueJobPackage(Pawn, JobIssueParams)
Verse.AI.ThinkNode_Subtree:TryIssueJobPackage(Pawn, JobIssueParams)
Verse.AI.ThinkNode_Priority:TryIssueJobPackage(Pawn, JobIssueParams)
RimWorld.ThinkNode_JoinVoluntarilyJoinableLord:TryIssueJobPackage(Pawn, JobIssueParams)
Verse.AI.ThinkNode_Priority:TryIssueJobPackage(Pawn, JobIssueParams)
Verse.AI.Pawn_JobTracker:DetermineNextJob(ThinkTreeDef&)
Verse.AI.Pawn_JobTracker:TryFindAndStartJob()
Verse.AI.Pawn_JobTracker:DMD<DMD<EndCurrentJob_Patch1>?-1040466432::EndCurrentJob_Patch1>(Pawn_JobTracker, JobCondition, Boolean, Boolean)
Verse.AI.Pawn_JobTracker:JobTrackerTick()
Verse.Pawn:Tick()
Verse.TickList:Tick()
Verse.TickManager:DoSingleTick()
Verse.TickManager:TickManagerUpdate()
Verse.Game:UpdatePlay()
Verse.Root_Play:Update()
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9037
  • Refugee
    • View Profile
Re: [1.1.11] Hospitality (updated 25.05.2020)
« Reply #2510 on: June 01, 2020, 01:41:52 PM »

Alien Framework = Humanoid Alien Races 2.0
These mod need nearly any race as requirement.

Do you use any race mods ? When these error show up, after rimworld startup or during gameplay ? What is about to include a full log (CTRL-F12) ?

Logged

Schwartz

  • Drifter
  • **
  • Posts: 67
  • Refugee
    • View Profile
Re: [1.1.11] Hospitality (updated 25.05.2020)
« Reply #2511 on: June 01, 2020, 01:44:09 PM »

No, I don't use any race mods. These errors show up during gameplay. They started showing up after I updated Hospitality to latest version. Before that, I used a version from maybe 1-2 months ago, and I never had this kind of error.

Here's the log: https://gist.github.com/HugsLibRecordKeeper/33f1fc963f7b5cb9767345c20c174ac1
« Last Edit: June 01, 2020, 01:46:12 PM by Schwartz »
Logged

Orion

  • Planetologist
  • ****
  • Posts: 1140
  • And why not
    • View Profile
    • Extra Nice
Re: [1.1.11] Hospitality (updated 25.05.2020)
« Reply #2512 on: June 01, 2020, 04:33:59 PM »

It should work fine without Alien Framework. I'll see if I can reproduce this.

Orion

  • Planetologist
  • ****
  • Posts: 1140
  • And why not
    • View Profile
    • Extra Nice
Re: [1.1.12] Hospitality (updated 20.06.2020)
« Reply #2513 on: June 20, 2020, 03:45:37 PM »

Update
Code: [Select]
1.1.12 - 20.06.2020
- New: Added setting to disable helping with warden tasks
- Fix: Error when not using Alien Race framework
- Fix: Removed warning when a guest needs no sleep
- Fix: Freeholders are no longer buggy (free recruiting, etc.)
- Fix: Error from apparel check
- Tweak: Increased attractiveness of single bed rooms and pure guest rooms
- Tweak: Royals are 2.5x more likely to show up
- Tweak: Guests will now never bring items with thingSetMakerTags of "NotForGuests"
- Tweak: Happy guest joins event now won't work with royals
- Tweak: Most empire guests can not be recruited now as a tradeoff for their valuable gear

DrFred

  • Muffalo
  • *
  • Posts: 11
  • Refugee
    • View Profile
Re: [1.1.12] Hospitality (updated 20.06.2020)
« Reply #2514 on: July 04, 2020, 01:31:19 PM »

Hi again,

sorry for not posting anymore, it was some mixture of personal reasons and frustration about that weird bug... Anyway, I think I might have found the reason to my problem (all pawns' names were just a grey blurry bar and I couldn't click in the game). My PC is quite old and when I got it, it had a 32 bit OS preinstalled on it (for some reason), so I always assumed I had a 32 bit architecture and upgraded to 32 bit, until I recently found out that it also supports 64 bit. I have reinstalled my OS to 64 bit now, and the mod works!
My very first guest insulted one of my colonists and they started a social fight, angering the faction leader :D (Screenshot just for the fun of it)

It works well though, and I also got some guests recruited already.

I just noticed one thing: When I send a group of guests away, they scatter all over the map instead of leaving together, even when I send them away right after they appeared, they all just run off in different directions, rather than just going straight back. It doesn't have any impact on the game, but it seems weird to me.

And there's one thing I'd like to suggest: When my colonists throw a party, the guests just don't participate, even while hanging out in the same room where the party is. They should be invited too, unless it's outside of the guest area, just because parties are great! :)

Anyway, thanks again for doing your best to help me!
« Last Edit: July 04, 2020, 02:03:20 PM by DrFred »
Logged
Pages: 1 ... 166 167 [168]