Ludeon Forums

Ludeon Forums

  • May 29, 2020, 03:31:56 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 166 167 [168]

Author Topic: [1.1.11] Hospitality (updated 25.05.2020)  (Read 934108 times)

Hrod

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.1.9] Hospitality (updated 01.05.2020)
« Reply #2505 on: May 07, 2020, 03:33:12 AM »

Hey everyone.

After a while without visitors I just spawned some visitors using dev mode. Everything went fine until they had to leave. Now there's some error and it just spams that they are leaving but they can't.

This is the error:

Code: [Select]
Exception while ticking lord with job Hospitality.LordJob_VisitColony:
System.NullReferenceException: Object reference not set to an instance of an object
  at RimWorld.IncidentQueue.Add (RimWorld.QueuedIncident qi) [0x00000] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Hospitality.Hospitality_MapComponent.QueueIncident (RimWorld.FiringIncident incident, System.Single afterDays) [0x0001d] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.GenericUtility.PlanNewVisit (RimWorld.IIncidentTarget map, System.Single afterDays, RimWorld.Faction faction) [0x00044] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.GenericUtility.TryCreateVisit (Verse.Map map, System.Single days, RimWorld.Faction faction, System.Single travelFactor) [0x00036] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.LordToil_VisitPoint.PlanRevisit (RimWorld.Faction faction, System.Single targetGoodwill, Verse.Map currentMap, System.Boolean sentAway) [0x00142] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.LordToil_VisitPoint.DisplayLeaveMessage (System.Single score, RimWorld.Faction faction, System.Int32 visitorCount, Verse.Map currentMap, System.Boolean sentAway) [0x0000a] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.LordToil_VisitPoint.Leave () [0x0015b] in <a20d107dfae34012a7901a1f006be785>:0
  at Hospitality.LordToil_VisitPoint.Cleanup () [0x00001] in <a20d107dfae34012a7901a1f006be785>:0
  at Verse.AI.Group.Lord.GotoToil (Verse.AI.Group.LordToil newLordToil) [0x0000f] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Verse.AI.Group.Transition.Execute (Verse.AI.Group.Lord lord) [0x00055] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Verse.AI.Group.Transition.CheckSignal (Verse.AI.Group.Lord lord, Verse.AI.Group.TriggerSignal signal) [0x000de] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Verse.AI.Group.Lord.CheckTransitionOnSignal (Verse.AI.Group.TriggerSignal signal) [0x00050] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Verse.AI.Group.Lord.LordTick () [0x0002a] in <4489f1367c1c4d76b2ae1272c8ed691d>:0
  at Verse.AI.Group.LordManager.LordManagerTick () [0x00011] in <4489f1367c1c4d76b2ae1272c8ed691d>:0

Anyone know how to fix this? I deleted those visitors and the message stopped. I then spawned a few more visitors and sent them away and the error was back. I'm willing to remove the mod altogether if there's no solution (destroying pawns and beds and uninstalling).

One thing that may be related to this bug: Because I wasn't getting visitors I searched the incident queue in the savegame and besides the main incident queue (empty), there was a hospitality queue with the same message repeated, which I deleted just in case.

Code: [Select]
<queuedIncidents>
<li>
<firingInc>
<def>VisitorGroup</def>
<parms>
<target>Map_0</target>
<threatPoints>-1</threatPoints>
<faction>Faction_100</faction>
<spawnCenter>(-1000, -1000, -1000)</spawnCenter>
<spawnRotation>2</spawnRotation>
<pawnGroups IsNull="True" />
<quest>null</quest>
</parms>
</firingInc>
<fireTick>10500317</fireTick>
</li>
<li>
<firingInc>
<def>VisitorGroup</def>
<parms>
<target>Map_0</target>
<threatPoints>-1</threatPoints>
<faction>Faction_101</faction>
<spawnCenter>(-1000, -1000, -1000)</spawnCenter>
<spawnRotation>2</spawnRotation>
<pawnGroups IsNull="True" />
<quest>null</quest>
</parms>
</firingInc>
<fireTick>11766826</fireTick>
</li>
</queuedIncidents>

Halp.
« Last Edit: May 07, 2020, 04:25:45 AM by Hrod »
Logged

Canute

  • Transcendent
  • *****
  • Posts: 8871
  • Refugee
    • View Profile
Re: [1.1.9] Hospitality (updated 01.05.2020)
« Reply #2506 on: May 07, 2020, 12:22:59 PM »

Hrod,
i don't think it is Hospitality it self it is more a bad configurate faction/race or maybe your current map so they can't leave.
When i am playing a mountain base, mosttimes i dig to the map border at the mountain side. Most caravan leave through these narraow passage and many visitors.

So what version of Hospitality do you use and could you post a complete log (CTRL-F12) after you loaded the safegame and that error happen.
Logged

Hrod

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.1.9] Hospitality (updated 01.05.2020)
« Reply #2507 on: May 07, 2020, 02:05:25 PM »

I'll try digging out the side. It's actually a peninsula tile (coastlines mod) so maybe they can only leave through the north, even after digging to the side.

What I did in the meantime was to destroy the guests in dev mode (sorry friends), change the beds to normal beds, and remove the mod from the load order. Then I loaded the save again without the mod, saved, and put the mod back in the load order and loaded the save. This seems to have worked. A quick test (spawn visitors and then ask them to leave, which was causing the same issue before) shows that the problem is fixed. For now.

Logged

Orion

  • Planetologist
  • ****
  • Posts: 1138
  • And why not
    • View Profile
    • Extra Nice
Re: [1.1.10] Hospitality (updated 24.05.2020)
« Reply #2508 on: May 24, 2020, 02:06:40 PM »

Update
Code: [Select]
1.1.10 - 24.05.2020
- New: Added button to guest tab to manage map defaults
- New: Manage Defaults menu now has a setting for disabling guests for the map
- New: Russian translation by kamadz
- Fix: Beds will now only show royal title information when royalty is active
- Fix: Fixed issue with guests not finding path to base caused by locked doors
- Tweak: Optimized shopping code for performance
- Tweak: Now caching guest comp access for performance
Pages: 1 ... 166 167 [168]