RimWorld1284Mac does not launch

Started by grumpy girl, October 03, 2016, 10:13:01 AM

Previous topic - Next topic

grumpy girl

Hi there,
in various attempts to solve the problem that RimWorld does not launch at all on my Mac with OS X 10.10.5, I have done the following: downloaded RimWorldAlpha15cMac.zip, extracted with Archive Utility, set security options to no restrictions for it to open,  disabled my virus scanner (Sophos). Tried to open with Terminal.

I have also tried the suggestions here:
I have executed chmod "+x RimWorld1284Mac.app/Contents/MacOS/RimWorld1284Mac" in Terminal

I have redownloaded twice and r-unpacked numerous times, also with 7 Zip. In the latter case it says "File cannot be open". If Unpacked with mac utility the little icon pops up on the toolbar and closes again.
I have renamed the app. file, moved it to applications, tried everything there as well.

Found the advice to "chmod 644" the whole folder and while I tried this, too, I probably didn't do it right. If that could be the solution I would be very happy for the exact command lines. I have to add that I am not very code literate but desperate to try what needs to by tried.

many thanks!

grumpy girl

I also have to add, the error -10810 appeared only at the first attempt.

I now cleaned out all the files and downloaded for the 4th time, unzipped into completely new folder. It doesn't open with open RimWorld1284Mac.app. No -10810 this time. On first trial I am asked if I want to open a file not from Mac Store, after that the small icon pops up and disappears.

tried chmod +x RimWorld1284Mac.app/Contents/MacOS/RimWorld1284Mac nonetheless, no changes.

I am quite frustrated I can't play the game, but have run out of suggestions what to do - can you help? many thanks

grumpy girl

Hey, thanks for your help,this is what happened:
/Applications/RimWorld1284Mac.app/Contents/MacOS/RimWorld1284Mac -force-openg
Mono path[0] = '/Applications/RimWorld1284Mac.app/Contents/Resources/Data/Managed'
Mono config path = '/Applications/RimWorld1284Mac.app/Contents/Data/Managed/etc'
Segmentation fault: 11

Unfortunately no progress. I had this "segmentation fault 11" line before at some point.
as for the second idea (force open g RimWorldAlpha15cMac.zip), there is no such file.

Any more ideas?
thanks a lot!


Unfortunately, I can't help, but I think I might be having the same problem. I'm afraid I'm also much less technically literate, so can't give as many details, but in case it helps characterise the same bug:

I am running Mac OS 10.6.8 on a 2007 white MacBook with 2GB RAM, 2GHz Intel Core 2 Duo. I recently bought the DRM-free game via the website and downloaded the file RimWorldAlpha15cMac.zip

I unzipped it using the default Archive Utility app in my Downloads folder and dragged the application RimWorld1284Mac to my Applications folder.

When I then launch the app, it starts to launch in the dock, then crashes, with the error message:

'RimWorld1284Mac cannot be opened because of a problem.
Check with the developers to make sure RimWorld1284Mac works with this version of Mac OS X. You may need to reinstall the application. Be sure to install any available updates for the application and for Mac OS X.'

I have deleted the app completely (I had a look in the Application Support folder for any other related files but there weren't any - presumably because the app has never successfully launched) and redownloaded a new file from the website, but the same problem happened again.

I thought this may be because I am running such an old version of OS X (unfortunately given the age of my laptop I am not willing to try updating to a newer version of the OS). However, it sounds like grumpy girl might be having a similar problem on 10.10.5, so perhaps it is not just me?



I can't help solve the problem but can confirm that the games runs 'out of the box' on my early 2009 iMac running 10.11.6. I think 10.11 was a pretty major upgrade so it sounds like an OS compatibility issue.

My hardware is too old to upgrade to 10.12 so I'm a little nervous about the next Rimworld update.


Having same issue as described above, on a Mac mini running OSX 10.6.8. I don't have an easy way to connect this particular computer to the internet, so I downloaded the file to my Android smartphone and the transferred it via Bluetooth to the Mac, but that seems unlikely to be the source of the issue.


To the users above. I just downloaded the Mac version and had the same issue. I used the terminal commands and it worked for me - I just had to tweak them them a little.

First, direct your terminal to the folder that contains rimworld.app (maybe downloads)

then in terminal type:
chmod +x RimWorld1284Mac.app/Contents/MacOS/RimWorld1284Mac

For future versions of the game - just change 1284 to the correct version number. It is also possible that future versions might change the naming structure. If you are unfamiliar with terminal, right click on RimWorldXXXXMac.app in Finder and click on the view contents option. Then navigate to the Contents/MacOS/ folder. You should see a file with an extension - that's what you're looking for. It won't open for you unless you chmod it though.

By the way, once this is done you can click on the .app like you usually would.


Thanks for the suggestion. No joy, I'm afraid - although it could well be something I'm doing wrong - I've never used Terminal before!

I managed to work out how to navigate to the correct folder (Applications, in my case) and then typed the command you suggested. It didn't seem to do anything - no output in Terminal, just a new command line. When I subsequently try to launch the app, the same crash happens. I have tried restarting my computer after entering the chmod command but still no joy.

I am using the 1393 version (0.16.1393 rev544), and changed the command accordingly.

For what its worth, what does 'chmod' mean?