Object reference not set to an instance of an object

Started by maskedmonkyman, July 14, 2017, 09:34:52 PM

Previous topic - Next topic


about 20 hours into a save, with mods. Suddenly game starts getting massively laggy.

I checked the dev log:
System.NullReferenceException: Object reference not set to an instance of an object
  at RimWorld.IncidentDef.TargetAllowed (IIncidentTarget target) [0x00000] in <filename unknown>:0
  at RimWorld.IncidentWorker.CanFireNow (IIncidentTarget target) [0x00000] in <filename unknown>:0
  at RimWorld.Storyteller.TryFire (RimWorld.FiringIncident fi) [0x00000] in <filename unknown>:0
  at RimWorld.IncidentQueue.IncidentQueueTick () [0x00000] in <filename unknown>:0
  at RimWorld.Storyteller.StorytellerTick () [0x00000] in <filename unknown>:0
  at Verse.TickManager.DoSingleTick () [0x00000] in <filename unknown>:0

I loaded a previous auto save, and there is no problem, after a few minutes it comes back. reloaded 3 times exact same thing happens, I can't tell what is causing it though. It seams to happen at the same point in the save each time.

Is there any way to better track down what is causing the problem?


This sort of issue is usually caused by either adding / removing mods to a running game, or some other general mod related issue, as I can't recall seeing any reports of this error appearing in a vanilla game (although I could be wrong).


I'm having the exact same problem. I've played a lot with mods without any problems, including the set of mods currently active. Tried to revert every mod that got updated recently. Also tried to disable suspicious mods. Tried executing all incidents, and altho some of them gave an error (from Cthulhu modpack), they were different and much better explained. I also tried to caravan out and abandon the colony.
No luck so far.

Anything I could do to narrow down the problem?
Even if the savefiles are corrupted beyond recovery I would like to know more about the problem.