Ludeon Forums

Ludeon Forums

  • September 25, 2022, 04:02:24 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 156 157 [158] 159 160 ... 167

Author Topic: [1.3] Miscellaneous w MAI+Robots  (Read 1381802 times)

Gen

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.1 / 25.10.2018)
« Reply #2355 on: November 08, 2018, 05:47:59 AM »

Having this error on MAI when activating an AI and spawning an activated one from dev mode.
Manufactured it as well on a new clean save to check if there would be a difference: nope

Error while creating AIPawnE.
Could not load type 'CommonMisc.Radar' from assembly 'AIPawn'.
STACK:
  at AIPawn.AIPawnGenerator.GenerateAIPawn (Verse.PawnGenerationRequest& request, Verse.Map map, Int32 tries) [0x00000] in <filename unknown>:0
  at AIPawn.AIPawnGenerator.GenerateAIPawn (System.String kindDefName, RimWorld.Faction faction, Verse.Map map, Gender gender) [0x00000] in <filename unknown>:0
  at AIPawn.Building_AIPawnCreator.CreateAIPawn (System.String pawnDefName, IntVec3 position, Verse.Map map, RimWorld.Faction faction, Gender gender) [0x00000] in <filename unknown>:0
  at AIPawn.Building_AIPawnCreator.CreateAIPawn (System.String pawnDefName, IntVec3 position, Verse.Map map, Gender gender) [0x00000] in <filename unknown>:0
  at AIPawn.Building_AIPawnCreator.Create () [0x00000] in <filename unknown>:0
  at AIPawn.Building_AIPawnCreatorEnhanced.Create () [0x00000] in <filename unknown>:0
  at AIPawn.Building_AIPawnCreator.Tick () [0x00000] in <filename unknown>:0

happens at correct order of Core > Miscellaneous 'CORE' > Misc. MAI
even without any other mod.
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.1 / 25.10.2018)
« Reply #2356 on: November 09, 2018, 05:03:46 AM »

It can not find the dll from Core. It should be found here:
..\Steam\steamapps\workshop\content\294100\704181221\Assemblies\CommonMisc.dll
or if you have the DRM free running:
..\RimWorld\Mods\Miscellaneous_Core\Assemblies\CommonMisc.dll

The error means RimWorld can't find this file..
Logged

Gen

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.1 / 25.10.2018)
« Reply #2357 on: November 10, 2018, 08:35:07 PM »

It is there. just below ColonistKeys.dll
CommonMisc is 18kb and was last modified 19 Oct
Logged

makotech222

  • Muffalo
  • *
  • Posts: 6
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.1 / 25.10.2018)
« Reply #2358 on: November 10, 2018, 10:47:50 PM »

On the latest release, i keep getting a null ref exception when finishing the bill for turning on a mobile ai. It doesn't crash game, but bill completes and nothing happens afterwards; no new AI player and mobile AI remains. I've tried disabling other mods and re-ordering, but nothing working. I think it was working back when 1.0 first came out and you had your first update for it.

Edit: debug log, with ounly hugslib and the misc core + misc AI + misc robots + misc robots ++

Error while creating AIPawnE.
Could not load type 'CommonMisc.Radar' from assembly 'AIPawn'.
STACK:
  at AIPawn.AIPawnGenerator.GenerateAIPawn (Verse.PawnGenerationRequest& request, Verse.Map map, Int32 tries) [0x00000] in <filename unknown>:0
  at AIPawn.AIPawnGenerator.GenerateAIPawn (System.String kindDefName, RimWorld.Faction faction, Verse.Map map, Gender gender) [0x00000] in <filename unknown>:0
« Last Edit: November 10, 2018, 10:56:25 PM by makotech222 »
Logged

Heymom

  • Drifter
  • **
  • Posts: 91
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.1 / 25.10.2018)
« Reply #2359 on: November 13, 2018, 11:01:51 AM »

I dont seem to be able to install a weapon on the "weapon base". Is this a known bug?
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.2 / 13.11.2018)
« Reply #2360 on: November 13, 2018, 02:48:11 PM »

I've updated MAI to circumvent this error.
Honestly, I have no idea why RimWorld doesn't find the CORE assemblies, but now MAI should nonetheless spawn, even when it is not found.

@Heymom:
I've tested it and I can install weapons on my side without problems.
Do you have a ranged weapon (not one-use weapon) in your storage?
Then select colonist, right-click the installed base and it should show your possible weapons as a floating menu.
When selected the weapon will be hauled and installed into the turret base, activating it.
Logged

Gen

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.2 / 13.11.2018)
« Reply #2361 on: November 13, 2018, 08:53:23 PM »

When devmode is open as I tested, this kept on spamming the log.
(When devmode is off, its perfect, since the debug log isn't visible.)

Code: [Select]
Exception ticking Erin (at (130, 0, 117)): System.NullReferenceException: Object reference not set to an instance of an object
  at RimWorld.GatheringsUtility.ShouldGuestKeepAttendingGathering (Verse.Pawn p) [0x00000] in <filename unknown>:0
  at Psychology.InteractionWorker_HangOut.RandomSelectionWeight (Verse.Pawn initiator, Verse.Pawn recipient) [0x00000] in <filename unknown>:0
  at RimWorld.Pawn_InteractionsTracker+<TryInteractRandomly>c__AnonStorey0.<>m__0 (RimWorld.InteractionDef x) [0x00000] in <filename unknown>:0
  at Verse.GenCollection.TryRandomElementByWeight[InteractionDef] (IEnumerable`1 source, System.Func`2 weightSelector, RimWorld.InteractionDef& result) [0x00000] in <filename unknown>:0
  at RimWorld.Pawn_InteractionsTracker.TryInteractRandomly () [0x00000] in <filename unknown>:0
  at RimWorld.Pawn_InteractionsTracker.InteractionsTrackerTick () [0x00000] in <filename unknown>:0
  at Verse.Pawn.Tick () [0x00000] in <filename unknown>:0
  at Verse.TickList.Tick () [0x00000] in <filename unknown>:0
Verse.Log:Error(String, Boolean)
Verse.TickList:Tick()
Verse.TickManager:DoSingleTick()
Verse.TickManager:TickManagerUpdate()
Verse.Game:UpdatePlay()
Verse.Root_Play:Update()

Erin is the name of the colonist that activated the MAI.
I think the bill wasn't closed properly or something? tho I'm just guessing from thin air here.
and thanks for fixing it in a short time.
« Last Edit: November 13, 2018, 08:56:31 PM by Gen »
Logged

ptb_666777

  • Muffalo
  • *
  • Posts: 11
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.2 / 13.11.2018)
« Reply #2362 on: November 14, 2018, 06:26:49 AM »

I,ve now triple checked my double check. Weapon base is still not working. The .dll files are there, load order on par and it just isnt happening. No pop-up menu. Been using this mod since its first release. I see now im not the only person. Really love your work, let me know what I can do to help find the problem.
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.2 / 13.11.2018)
« Reply #2363 on: November 14, 2018, 09:12:50 AM »

No error in the log window i mean generell not only when you try to use the weapon base ?
Maybe just post one. CTRL-F12/Share log button should do it if you use hugslib.

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.2 / 13.11.2018)
« Reply #2364 on: November 14, 2018, 04:25:31 PM »

When devmode is open as I tested, this kept on spamming the log.
(When devmode is off, its perfect, since the debug log isn't visible.)

Code: [Select]
Exception ticking Erin (at (130, 0, 117)): System.NullReferenceException: Object reference not set to an instance of an object
  at RimWorld.GatheringsUtility.ShouldGuestKeepAttendingGathering (Verse.Pawn p) [0x00000] in <filename unknown>:0
  at Psychology.InteractionWorker_HangOut.RandomSelectionWeight (Verse.Pawn initiator, Verse.Pawn recipient) [0x00000] in <filename unknown>:0
  at RimWorld.Pawn_InteractionsTracker+<TryInteractRandomly>c__AnonStorey0.<>m__0 (RimWorld.InteractionDef x) [0x00000] in <filename unknown>:0
  at Verse.GenCollection.TryRandomElementByWeight[InteractionDef] (IEnumerable`1 source, System.Func`2 weightSelector, RimWorld.InteractionDef& result) [0x00000] in <filename unknown>:0
  at RimWorld.Pawn_InteractionsTracker.TryInteractRandomly () [0x00000] in <filename unknown>:0
  at RimWorld.Pawn_InteractionsTracker.InteractionsTrackerTick () [0x00000] in <filename unknown>:0
  at Verse.Pawn.Tick () [0x00000] in <filename unknown>:0
  at Verse.TickList.Tick () [0x00000] in <filename unknown>:0
Verse.Log:Error(String, Boolean)
Verse.TickList:Tick()
Verse.TickManager:DoSingleTick()
Verse.TickManager:TickManagerUpdate()
Verse.Game:UpdatePlay()
Verse.Root_Play:Update()

Erin is the name of the colonist that activated the MAI.
I think the bill wasn't closed properly or something? tho I'm just guessing from thin air here.
and thanks for fixing it in a short time.

This looks more to be a problem from Psychology than from Mai.
Something in the interaction handling throws the NullRefException.
I see nothing in there that comes from MAI.

I,ve now triple checked my double check. Weapon base is still not working. The .dll files are there, load order on par and it just isnt happening. No pop-up menu. Been using this mod since its first release. I see now im not the only person. Really love your work, let me know what I can do to help find the problem.

Can you please do as Canute said and provide a log file?
Which RimWorld version are you playing with?
Logged

ptb_666777

  • Muffalo
  • *
  • Posts: 11
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.2 / 13.11.2018)
« Reply #2365 on: November 15, 2018, 07:14:01 AM »

Root level exception in OnGUI(): System.TypeLoadException: Could not load type 'CommonMisc.Helper' from assembly 'WeaponBase'.
at (wrapper dynamic-method) RimWorld.FloatMenuMakerMap.AddHumanlikeOrders_Patch2 (UnityEngine.Vector3,Verse.Pawn,System.Collections.Generic.List`1<Verse.FloatMenuOption>) <0x093cd>
at RimWorld.FloatMenuMakerMap.ChoicesAtFor (UnityEngine.Vector3,Verse.Pawn) <0x002d2>
at RimWorld.FloatMenuMakerMap.TryMakeFloatMenu (Verse.Pawn) <0x001e2>
at RimWorld.Selector.HandleMapClicks () <0x00287>
at RimWorld.Selector.SelectorOnGUI () <0x0001c>
at RimWorld.MapInterface.HandleLowPriorityInput () <0x0006d>
at RimWorld.UIRoot_Play.UIRootOnGUI () <0x002f9>
at Verse.Root.OnGUI () <0x00112>

Verse.Log:Error(String, Boolean)
Verse.Root:OnGUI()
1.0.2056(64 - bit)
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.2 / 13.11.2018)
« Reply #2366 on: November 15, 2018, 12:10:21 PM »

Why do you hide the complete logfile ? Do you have anything to hide ? :-))
Yes that the error about the weapon base, but information like patching (if you use the hugslib function), previously errors or modlist are helpful too.


ptb_666777

  • Muffalo
  • *
  • Posts: 11
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.2 / 13.11.2018)
« Reply #2367 on: November 15, 2018, 02:10:36 PM »

Maybe if you had read my previous postsyou would know i do not have internet service on my pc, im using my phone to send this info. Nvm i edited the post and left that info out. Anyway I got copy n paste to txt that I can transfer .txt file to phone, copy paste again to forum. There are sum other errors, nothing breaking game and non other with this mod (have not tryed mia). Light weight accusations aren't cool. I do not appreciate it. Want more info, just ask.
« Last Edit: November 15, 2018, 02:26:59 PM by ptb_666777 »
Logged

JT

  • Colonist
  • ***
  • Posts: 136
  • Big Whoop
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.2 / 13.11.2018)
« Reply #2368 on: November 16, 2018, 06:30:09 PM »

Hi Haplo,

Going through my mods and trimming out copies of core abstracts*, I noticed that you have a couple minor errors in Miscellaneous Core (and other Misc mods):

1) You have copies of vanilla abstracts in the mods.  This practice was outdated as of A15/A16 and is definitely not recommended anymore.  Any abstract that duplicates a vanilla abstract is deprecated and can cause errors, either in your mod or in others'.

2) When you do remove the vanilla abstracts, however, you will run into an interesting problem: your Hediffs for the Brain-Pal implants in Miscellaneous Core derive from the ParentName of ImplantBase, which is a vanilla ThingDef class that will cause nasty errors on loading.  They should be changed to the ImplantHediffBase ParentName instead.

* I've had to clean up numerous hastily-updated mods (not yours) that had bad abstracts for AnimalBase and BuildingBase, for instance, that were perpetuating bad errors into all sorts of mods.  Most prominent is the change from BulletImpactMetal to BulletImpact_Metal for soundImpactDefault, which innumerable mods included in their invalid BuildingBase abstracts that they didn't even need in the first place.
« Last Edit: November 16, 2018, 06:31:50 PM by JT »
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots (V 1.0.2 / 13.11.2018)
« Reply #2369 on: November 17, 2018, 11:41:27 AM »

Thank you for the info about the abstracts. You're actually the second one who brought this to me. I have updated the Steam and the Github versions for this. The abstracts got a mod Name to their Name to reduce incompatibilities.
Unfortunately im currently down für to illness so I cant Update the actual links in the first Post..
Please check out the mods on github if they are now working better
Logged
Pages: 1 ... 156 157 [158] 159 160 ... 167