Ludeon Forums

Ludeon Forums

  • July 01, 2022, 04:17:54 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 75 76 [77] 78 79 ... 167

Author Topic: [1.3] Miscellaneous w MAI+Robots  (Read 1357728 times)

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 10.01.2016)
« Reply #1140 on: January 11, 2016, 12:02:47 PM »

If you want a hauler bot, you'll need the minimized recharge station of the bot as an starting object.
The bot itself will self destruct if it can't find his recharge station.

But I'm not sure if you can add minimized objects in PC...
Logged

exodus1028

  • Muffalo
  • *
  • Posts: 11
  • Refugee
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 10.01.2016)
« Reply #1141 on: January 11, 2016, 12:25:54 PM »

kinda makes sense, completely forgot about that, that they come minimized ....bummer, this might indeed be the entire case here

thanks for pointing that out ;)
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 10.01.2016)
« Reply #1142 on: January 14, 2016, 03:50:57 AM »

TEST: PATCH RELEASE:
I have made a patch for Combat Realism.
Anyone who uses CR and Miscellaneous and/or Misc.TrainingFacility is welcome to test them.
Please give me some feedback if there remain any problems with them.

Note: Load the patches AFTER the involved original mods. They are NOT usable without them!

Here is the patch for Miscellaneous (WeaponBase):
http://www.mediafire.com/download/x8j2toba29dm3uh/Miscellaneous_Patch_CombatRealism.zip

And here is the patch for the TrainingFacility:
http://www.mediafire.com/download/j14x14dx7kni4pq/Miscellaneous_TrainingFacility_Patch_CombatRealism.zip
« Last Edit: January 15, 2016, 05:25:20 PM by Haplo »
Logged

LittleGreenStone

  • Colonist
  • ***
  • Posts: 286
  • Does this moss make me look fat?
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 10.01.2016)
« Reply #1143 on: January 14, 2016, 04:59:35 AM »

TEST:
I have made a patch for Combat Realism.
Anyone who uses CR and Miscellaneous and/or Misc.TrainingFacility is welcome to test them.
Please give me some feedback if there remain any problems with them.

Note: Load the patches AFTER the involved original mods. They are NOT usable without them!

Here is the patch for Miscellaneous (WeaponBase):
http://www.mediafire.com/download/x8j2toba29dm3uh/Miscellaneous_Patch_CombatRealism.zip

And here is the patch for the TrainingFacility:
http://www.mediafire.com/download/j14x14dx7kni4pq/Miscellaneous_TrainingFacility_Patch_CombatRealism.zip

A patch for...training facility?
Why?
I've been using it and CR and to me it seemed pawns do use them and receive the benefits as well.
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 10.01.2016)
« Reply #1144 on: January 14, 2016, 06:50:47 AM »

Did they really use them, or only until the ammo was used up?
The patched version will reset the ammo as long as they are training.
Logged

LittleGreenStone

  • Colonist
  • ***
  • Posts: 286
  • Does this moss make me look fat?
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 10.01.2016)
« Reply #1145 on: January 15, 2016, 07:38:48 AM »

Did they really use them, or only until the ammo was used up?
The patched version will reset the ammo as long as they are training.

You are right.
I haven't forced pawns to train yet (until now), as they've been doing it by themselves when they had the time, they always shoot a 2-4 times then leave, whether they run out of ammo or not.
Forcing them doesn't work because reload seems to interrupt it.
My mistake.
« Last Edit: January 15, 2016, 07:40:37 AM by LittleGreenStone »
Logged

Grimandevil

  • Colonist
  • ***
  • Posts: 213
  • Refugee
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 10.01.2016)
« Reply #1146 on: January 15, 2016, 11:41:54 AM »

works great so far, xept for Mai. but that'd require a separate patch, i guess ;)
Logged
welcome to the Rimworld - a world full of cannibal drug-addicted psychos, but free of vegetarians.

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 15.01.2016)
« Reply #1147 on: January 15, 2016, 05:22:22 PM »

Thanks for the info, but what do you mean with Mai?
I'm not aware of any problems with Mai and CR?
Logged

Grimandevil

  • Colonist
  • ***
  • Posts: 213
  • Refugee
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 15.01.2016)
« Reply #1148 on: January 16, 2016, 10:57:19 AM »

Thanks for the info, but what do you mean with Mai?
I'm not aware of any problems with Mai and CR?
sorry, i hadnt time to fully test it last time.
theres no problem with Mai, rather with shotguns. the ammo doesnt reset for shotguns, they fire like before till reload.
then theres another one. i've tested some extra guns adapted for CR (namely, heavy sniper rifles). some of them have larger aiming time than "target shooting delay", resulting in never firing.

i understand that pawns, equipped with grenade launchers, never go practicing by themselves. thats good.

there is, actually, one problem with Mai, not related to these patches. She lacks "reload gun" button.
« Last Edit: January 16, 2016, 11:02:37 AM by Grimandevil »
Logged
welcome to the Rimworld - a world full of cannibal drug-addicted psychos, but free of vegetarians.

Carlsf

  • Drifter
  • **
  • Posts: 21
  • Refugee
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 15.01.2016)
« Reply #1149 on: January 17, 2016, 04:13:00 AM »

I'm using Misc. Vanila Enhanced, Training Facilities, Combat Realism and Crash Landing. There isn't any conflicts but I'm not sure if patches work with Vanilla Enhanced.
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 15.01.2016)
« Reply #1150 on: January 17, 2016, 01:49:01 PM »

Yes, these patches will also work with the Vanilla Enhanced version.
I've updated the note on the first post to make this clear. Thanks.
Logged

Carlsf

  • Drifter
  • **
  • Posts: 21
  • Refugee
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 15.01.2016)
« Reply #1151 on: January 18, 2016, 05:51:47 AM »

Your welcome.  :)
Logged

Vas

  • Colonist
  • ***
  • Posts: 875
  • Dragon
    • View Profile
    • Feral Dragon
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 15.01.2016)
« Reply #1152 on: January 24, 2016, 01:53:12 PM »

Alright, I give up.  I tried and tried but this mod has too many bugs in it.  I miss MD2 Droids.  I could have a droid built that was specialized and it didn't need a bed set directly to it, it also didn't have this issue where colonists tried to sleep in the charging stations (beds).  They also didn't show up on the EDB Interface mod top thing I don't think.

First issue, was when I tried to deactivate the droid to install an AI chip from a crashed space ship part.  It died when I used deactivate.
Second issue, when the new one got shot up, and went to the bed/charging station with a nanite repair thing beside it filled with plasteel, it layed there for a minute, then got beaten to death by an invisible nothing and used up half my plasteel too.
Third issue, I tried to move the bed/charging station to a big empty area, and the nanite thing too.  When I did, infinite job loop errors on a colonist trying to fill the nanite repair thing which for some reason had this new "allow rotten" option in it.  I had to deconstruct it and buy a new one from traders, the new one worked on letting me fill it.  I didn't get the chance to test a 3rd robot because of the forth issue.
Fourth issue, this is the only new mod I have.  I saved my game, and now it's corrupted the map.  After many hours of work making a perfect and amazing base on a place where it never goes above 8F.  All my work, gone.
http://pastebin.com/aRb14Qvy (lasts 1 week)

That really sucks.  Because that was an amazing map I had found.  The perfect map spawn.  I don't think I'll ever find another map seed as good as that one was.  I thought about trying your other mods in this post, the Misc stuff, but meh, right now I'm rather upset that i lost all my hard work.  :/

Hell, another issue is the cleaning bots don't quite work right.  They do this odd thing where they wander around for a while even with a mess directly in the room next to their thing and they only go out a certain distance from their pods.  I mean sure, fine, if its a certain distance only but in the room right next door while it cleans half way across the base some small patch?  Then suddenly decides while there is a mess right next to it, it's gonna wander around for a while?...
Logged
Click to see my steam. I'm a lazy modder who takes long breaks and everyone seems to hate.

RickyMartini

  • Planetologist
  • ****
  • Posts: 1510
  • Brewing Beer
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 15.01.2016)
« Reply #1153 on: January 24, 2016, 02:43:27 PM »

Hey Vas! I seem to have the same issue with this darn nanite repair thing.

It definitely doesn't work and how it works is just.... wrong.... or buggy. Something is not working right.
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [A12d] Miscellaneous w MAI+Robots (V 1.12.10 / 15.01.2016)
« Reply #1154 on: January 25, 2016, 06:51:31 AM »

...
I honestly thought my mod was rather bug free as I didn't hear of any problems other than maybe the replace lost limbs problem :(

Ok, I'll try to address your problems as far as I can.. (Not at home right now, so can't take a look at your savegame)

Your first issue: You tried to deactivate Mai? Did you read the description? Mai, once activated, doesn't like you to mess with her programming, so will rather initiate her self destruction then let you do that.
Sorry, but that is intentional and I'm not sure I want to change that for now.

Second issue: That sounds like a bug with my code to replace the lost limbs. Normally it should replace the lost limb with a limb that has a health of 1HP. To do this I create a new limb and add damage to the limb with a count of (maxHealth - 1). If your Mai dies of it, then I missed some critical changes of the limb and health system in a12. it did work in a11, but their was a big change and it Looks like I missed something important here.. Sorry, that is really a bug of my work.

Third issue: The nanite repair station is effectively a renamed and retextured Hopper. I'm not sure if I can locate the problem that's causing the Job loop, but I'll at least try to find it.

Fourth issue: To be honest, I have no idea what would cause the savegame to get corrupted, but I'll look into your savegame and try my best to find the root of this.

The cleaning bot issue: The cleaning bots use the vanilla cleaning tasks. So if your colonists will clean something, then the bot also will clean that. If you colonists won't clean something ...
The only idea I have why your bot didn't clean something is, that it may not be inside the cleaning area (homezone)? The range of the bots is only defined by this: They'll return to their base if they are further away than 50 cells and their battery is < 50% (I'm not 100% sure about the values yet. I must look them up at home to give you an accurate number)


All in all I'm sorry that you got some gamebreaking bugs and I'll definitly look into them.
If I can't find a solution for the Mai-limb-replace-bug, I'll at least remove the nanite assembler until I find a working solution.

Logged
Pages: 1 ... 75 76 [77] 78 79 ... 167