Ludeon Forums

Ludeon Forums

  • November 28, 2021, 08:56:59 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 161 162 [163] 164 165 ... 168

Author Topic: [1.3] Miscellaneous w MAI+Robots  (Read 1288791 times)

82ab53e4

  • Drifter
  • **
  • Posts: 34
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2430 on: February 04, 2019, 02:56:23 PM »

Hi, awesome mod creator. I want to report about issue with Misc. robots and Rimatomics (i'm also using misc. robots++ but not sure if that important). Hauler bots get radiation sickness from hauling radioactive items than never go off, permanently weakening them (and potentially killing).
Logged

bullet

  • Drifter
  • **
  • Posts: 77
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2431 on: February 05, 2019, 02:50:26 PM »

Hi Haplo. Are your robots finally got ability automatically go back to station if no work find?  ;)
Logged

Jiro

  • Guest
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2432 on: February 08, 2019, 11:55:08 PM »

Hi, what is "BeeAndHoney 'Urban'"?
Logged

Lupin III

  • Drifter
  • **
  • Posts: 96
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2433 on: February 27, 2019, 11:12:25 AM »

When my pawns shoot at the shooting range I get multiple of these errors:

Code: [Select]
Exception in JobDriver tick for pawn Gobanro driver=JobDriver_ShootingRange (toilIndex=3) driver.job=(UseShootingRange (Job_2743416) A=Thing_ShootingRangeTarget288641 B=(180, 0, 152)) lastJobGiver=null
System.NullReferenceException: Object reference not set to an instance of an object
at Verse.DefMap`2<RimWorld.JoyKindDef, single>.get_Item (RimWorld.JoyKindDef) <0x0001b>
at RimWorld.JoyToleranceSet.JoyFactorFromTolerance (RimWorld.JoyKindDef) <0x00043>
at RimWorld.Need_Joy.GainJoy (single,RimWorld.JoyKindDef) <0x00058>
at TrainingFacility.JobDriver_ShootingRange.WatchTickAction () <0x008a0>
at TrainingFacility.JobDriver_ShootingRange.<GetToil_ShootAtTarget>b__5_0 () <0x0001b>
at (wrapper dynamic-method) Verse.AI.JobDriver.DriverTick_Patch1 (object) <0x004c8>

The pawns still get XP for Shooting though and it doesn't seem to break anything else.
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2434 on: February 27, 2019, 11:57:59 AM »

Must be a mod conflicht with some other mod (Do you use CE maybe).
Did you try to move the training mod at the end of the modlist or near the beginning.

Jan2607

  • Colonist
  • ***
  • Posts: 389
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2435 on: February 27, 2019, 12:32:44 PM »

It should be working with CE (at least it works for me), but the colonists may hang in a reloading loop for a while (it ends, when they leave the range to do other stuff). But that's not a big issue. You can reload them manually or just wait until their reloading loop ends.
Logged

Lupin III

  • Drifter
  • **
  • Posts: 96
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2436 on: February 27, 2019, 01:23:09 PM »

Yes, I'm using CE and, yes, it happens when they are reloading. I saw them put more than 20 rounds into a revolver. Do they at least still get the joy bonus? Will this be fixed at some point or is this to big of an incompatibility with CE?
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2437 on: March 06, 2019, 03:08:33 AM »

I've updated the shooting range to catch this error for now. It shouldn't create any errors, other than not increasing the joy now.
Unfortunately I have no idea what CE does to cause this error at all so I can't do anything to really fix it. :(
Logged

atewithouttabIe

  • Drifter
  • **
  • Posts: 22
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2438 on: March 06, 2019, 07:18:04 AM »

For shats'n giggles -
- Mai Misc Robots (Haulers specifically)
- CE
- Defensive Turret Pack CE compatible ( https://ludeon.com/forums/index.php?topic=45727.0 ):

Initial load of turret from above pack gets finished fine by haulerbot, REloading turret afterwards by bot always results in reloading loop ad nauseum
Logged

Senio

  • Drifter
  • **
  • Posts: 64
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2439 on: May 17, 2019, 03:04:22 PM »

About Miscellaneous Robots
Can you help us support Multiplayer mod?
https://ludeon.com/forums/index.php?topic=69.0
Thanks.
Logged

Senio

  • Drifter
  • **
  • Posts: 64
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2440 on: May 18, 2019, 08:39:36 AM »

<Snipped by Haplo --> Really, the full main post? :)>
Watiing robots support for Multiplayer mod......
« Last Edit: May 22, 2019, 04:00:13 PM by Haplo »
Logged

account13123

  • Drifter
  • **
  • Posts: 50
  • downloads shouldn't require logins
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2441 on: May 21, 2019, 04:11:00 PM »

I found an incompatibility with another mod. When using this with Targeting Modes, your turretbase turrets miss every shot and throw this red error into the log each time they shoot at a pawn:

Code: [Select]
Exception ticking Bullet_BoltActionRifle121403: System.ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
at System.Collections.Generic.List`1<Verse.VerbProperties>.get_Item (int) <0x00083>
at TargetingModes.TargetingModesUtility.CanUseTargetingModes (Verse.ThingDef,Verse.Thing) <0x001aa>
at TargetingModes.TargetingModesUtility.ResolvePrioritizedPart (Verse.BodyPartRecord,Verse.DamageInfo,Verse.Pawn) <0x00093>
at TargetingModes.HarmonyPatches.Postfix_ChooseHitPart (Verse.BodyPartRecord&,Verse.DamageInfo,Verse.Pawn) <0x00046>

This happens regardless of which of the two mods is on top of the other. Uninstalling Targeting Modes removed the issue.
« Last Edit: May 21, 2019, 04:18:27 PM by account13123 »
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2442 on: May 22, 2019, 03:57:23 PM »

@account13123: Thanks for the info. I'll add it to the known issues.

@Senio: You'll have to wait a while longer. Currently I have another project I'm working on, so MP support will not be done anytime soon, sorry.

So.. I was inactive for a while because of RL. It just doesn't allow me as much time as in the past unfortunately..
Currently my precious time is spent working on a small new idea.
This little project has the following description. Who can guess what it might be? :)

..and if thy survive
the onslaught by a pair of moon,
this will be your price
ol' civic right in thee harvest soon..
« Last Edit: May 22, 2019, 04:08:57 PM by Haplo »
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2443 on: May 24, 2019, 05:00:19 PM »

New Mod: Misc. EndGame
Do you think your base is done? You have nothing more to do, but you don't really want to leave the planet?
Why not try to get your own town charter via martial law instead? Here is your option for this...
Logged

Senio

  • Drifter
  • **
  • Posts: 64
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2444 on: May 25, 2019, 12:57:28 PM »

New Mod: Misc. EndGame
Do you think your base is done? You have nothing more to do, but you don't really want to leave the planet?
Why not try to get your own town charter via martial law instead? Here is your option for this...
Thanks,Free time please update robots for  support multiplayer mod
Logged
Pages: 1 ... 161 162 [163] 164 165 ... 168