Ludeon Forums

Ludeon Forums

  • August 11, 2022, 03:32:24 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 162 163 [164] 165 166 167

Author Topic: [1.3] Miscellaneous w MAI+Robots  (Read 1370869 times)

Tocato

  • Colonist
  • ***
  • Posts: 105
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2445 on: October 15, 2019, 03:00:49 PM »

Hello can we get less dangerous ammo (maybe bb) equipped for all weapons not just explosions for the shooting dummy?  I'm inside a cave and when my colonists miss they end up destroying the walls. Even throwing ro is would be better than spending a ton of time repairing
Logged

MiniMishii

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2446 on: December 10, 2019, 02:50:56 AM »

I can't successfully use the robots :c It just has the option to repair, but repairing doesn't actually do anything. I've also tried putting it at the top or at the bottom of the load order.

Attached is what the dev log throws when I click activate. I'm not sure how to even start to go about trying to fix this one =\

I've used them before perfectly successfully in a mod-heavy game, so I don't even know what I should try disabling to find a conflict.
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2447 on: December 10, 2019, 03:19:40 AM »

MiniMishii,
when the robot's worked before and you didn't change anything it could be a conflict with another mod. Then a full logfile would be more helpful, click on the green "Share log" button at the log window for a combined modlist + logfile.

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2448 on: December 10, 2019, 06:37:24 AM »

This looks like a conflict with another mod:
More_Scenario_Parts.HarmonyPatches.TryGenerateNewPawnInternal_ScenPartExSupport
-> Do you have a new mod added? Something that adds 'More Scenarios' maybe?
This can only be fixed on their side. There is nothing I can do about it, sorry.
Logged

MiniMishii

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2449 on: December 10, 2019, 10:57:50 PM »

Thank you! Found what it was conflicting with, and tbh, I'm not even sure what that mod does, as it's no longer on Steam. Guess it's time for that one to go...fingers crossed that's the only issue :)
Logged

linreche

  • Muffalo
  • *
  • Posts: 5
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2450 on: February 19, 2020, 01:24:03 PM »

hello
Misc. MapGen FactionBase
Error pop up when attacking pirate base !

Code: [Select]
Error in BlueprintHandler.CreateBlueprintAt(..): System.InvalidCastException: Cannot cast from source type to destination type.
  at MapGenerator.BlueprintHandler.CreateBlueprintAt (IntVec3 c, Verse.Map map, MapGenerator.MapGeneratorBaseBlueprintDef blueprint, RimWorld.Faction faction, Verse.ThingDef& wallStuff, System.Collections.Generic.List`1& usedSpots) [0x00000] in <filename unknown>:0
Verse.Log:Error(String, Boolean)
MapGenerator.BlueprintHandler:CreateBlueprintAt(IntVec3, Map, MapGeneratorBaseBlueprintDef, Faction, ThingDef&, List`1&)
MapGenerator.Genstep_CreateBlueprintBase:ScatterAt(IntVec3, Map, Int32)
Verse.GenStep_Scatterer:Generate(Map, GenStepParams)
Verse.MapGenerator:GenerateContentsIntoMap(IEnumerable`1, Map, Int32)
Verse.MapGenerator:GenerateMap(IntVec3, MapParent, MapGeneratorDef, IEnumerable`1, Action`1)
Verse.GetOrGenerateMapUtility:GetOrGenerateMap(Int32, IntVec3, WorldObjectDef)
Verse.GetOrGenerateMapUtility:GetOrGenerateMap(Int32, WorldObjectDef)
RimWorld.Planet.SettlementUtility:AttackNow(Caravan, SettlementBase)
RimWorld.Planet.<Attack>c__AnonStorey0:<>m__0()
Verse.LongEventHandler:UpdateCurrentSynchronousEvent(Boolean&)
Verse.LongEventHandler:LongEventsUpdate(Boolean&)
Verse.Root:Update_Patch1(Object)
Verse.Root_Play:Update()
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2451 on: February 19, 2020, 04:21:19 PM »

Thank you for the info.
I have no idea what the problem might be, but I'll try to find and fix it :)
Logged

EbeneezerSquid

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2452 on: February 20, 2020, 11:58:30 AM »

I love your Robots, and now that 1.1 unstable is out, I find myself REALLY missing the little guys.

Any update plans you care to share?
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2453 on: February 20, 2020, 01:38:28 PM »

To be honest, core, robots and training are already updated.
I just need a bit more testing, then I'll most likely drop them.
So expect them soon(TM)  8)
Logged

Jan2607

  • Colonist
  • ***
  • Posts: 389
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2454 on: February 22, 2020, 11:24:22 AM »

When you say robots, do you mean MAI too? That's one of my most important mods I really need for a new 1.1 playthrough :D
Logged

EbeneezerSquid

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2455 on: February 22, 2020, 12:46:37 PM »

I just need the little guys, for cleaning and hauling.

Everything else is a bonus.

Never actually built MAI, but used the training constantly.
« Last Edit: February 22, 2020, 12:48:12 PM by EbeneezerSquid »
Logged

CEPMatos

  • Muffalo
  • *
  • Posts: 18
  • Weakened sight
    • View Profile
    • facebook
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2456 on: March 12, 2020, 04:08:00 PM »

Nice, please update the title to 1.1
Logged

xNuviettex

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2457 on: March 12, 2020, 08:30:40 PM »

Quick Question and an idea for you. first question. is your turret base mod compatible with 1.1?

and the idea is see if you can implement the locks mod from Avius, to where your robots can have there own access to specific colonist owned doors.
Logged

Haplo

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 2136
  • Shadow
    • View Profile
Re: [1.0] Miscellaneous w MAI+Robots
« Reply #2458 on: March 14, 2020, 04:56:27 PM »

Turret base is currently not ready for 1.1, sorry.
Logged

Angelix

  • Drifter
  • **
  • Posts: 57
  • Refugee
    • View Profile
Re: [1.0/1.1] Miscellaneous w MAI+Robots
« Reply #2459 on: March 17, 2020, 08:05:15 AM »

There is a little problem with area reset in case rechargers outside of permitted area. Its an infestation. In case it happens near recharging bases it is too difficult to protect bots. Can we have some override switch?
Logged
Pages: 1 ... 162 163 [164] 165 166 167