Ludeon Forums

Ludeon Forums

  • March 28, 2020, 08:04:14 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 5 6 [7]

Author Topic: [1.0] Don't Shave Your Head! - v1.0.0  (Read 43229 times)

gaberad

  • Muffalo
  • *
  • Posts: 10
  • Refugee
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #90 on: March 11, 2020, 02:12:00 AM »

Yeah, hairstyles need custom textures in order for them to display correctly, otherwise it'll just do the vanilla behaviour.

So new hair styles (like from Royal DLC, other hair mods) won't work unless a custom texture is added.

First post has details on how to do that.

It's what I'm trying to eliminate with the experimental build I'm working on.
Logged

Fakeaccount123

  • Muffalo
  • *
  • Posts: 18
  • Refugee
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #91 on: March 12, 2020, 02:48:08 PM »

gaberad thank you for updating this mod. It would be awesome if you manage to make that experimental build to work. However i have a problem with the mod: it wors fine with pawns in the map but when you look at pawns in the portrait, in the top of the screen, you will notice that the hats and helmets are drawn behind the hair. Do you think you can change that?
Logged

gaberad

  • Muffalo
  • *
  • Posts: 10
  • Refugee
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #92 on: March 13, 2020, 01:25:52 AM »

Yeah, I see what you mean. I don't play with head gear visible on the pawn bar, so I didn't notice, but I'll see if I can find out what's causing it.

Logged

gaberad

  • Muffalo
  • *
  • Posts: 10
  • Refugee
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #93 on: March 13, 2020, 11:15:21 PM »

I think I found/fixed the issues: there was a floating point comparison issue, as well as the render offset being applied to both the hair and headgear (rather than just the headgear), which meant that the hair and headgear were trying to render at the same level.

Worked with my tests, but again let me know if there are any issues with it.

https://github.com/gaberad/DontShaveYourHead
Logged

Fakeaccount123

  • Muffalo
  • *
  • Posts: 18
  • Refugee
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #94 on: March 14, 2020, 11:06:12 AM »

I think I found/fixed the issues: there was a floating point comparison issue, as well as the render offset being applied to both the hair and headgear (rather than just the headgear), which meant that the hair and headgear were trying to render at the same level.

Worked with my tests, but again let me know if there are any issues with it.

https://github.com/gaberad/DontShaveYourHead

That was fast. Thank you
Logged

Simstu

  • Drifter
  • **
  • Posts: 34
  • Ranger
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #95 on: March 17, 2020, 05:04:14 PM »

I think I found/fixed the issues: there was a floating point comparison issue, as well as the render offset being applied to both the hair and headgear (rather than just the headgear), which meant that the hair and headgear were trying to render at the same level.

Worked with my tests, but again let me know if there are any issues with it.

https://github.com/gaberad/DontShaveYourHead
Hello there! I'm running into the same problem but with 1.0... And also just my pawns are displaying properly, raiders just have their hair through hats... Any chance you could help me?
Logged

gaberad

  • Muffalo
  • *
  • Posts: 10
  • Refugee
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #96 on: March 19, 2020, 02:20:14 AM »

yeah I'll take a look at 1.0 this weekend.
Logged

Simstu

  • Drifter
  • **
  • Posts: 34
  • Ranger
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #97 on: March 19, 2020, 06:40:43 AM »

Thanks, mate! *Tips cowboy hat*
Logged

gaberad

  • Muffalo
  • *
  • Posts: 10
  • Refugee
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #98 on: March 21, 2020, 05:11:54 AM »

I've pushed out the update for the 1.0 fix, and made the mod into one of those combined 1.0/1.1 mods.

Logged

Simstu

  • Drifter
  • **
  • Posts: 34
  • Ranger
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #99 on: March 22, 2020, 08:15:20 AM »

Will try later in the day.

EDIT: Works fantastic! Thank you very much, partner!

Hats off to ya!
 ;)
« Last Edit: March 22, 2020, 11:10:23 AM by Simstu »
Logged

gaberad

  • Muffalo
  • *
  • Posts: 10
  • Refugee
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #100 on: March 27, 2020, 04:06:56 AM »

Ok, so, the experimental branch didn't work out, hair styles are too varied to get it working consistently.

So instead I decided to go for a 'fallback texture', where if the current hair style doesn't have a custom texture, it will choose a semi-random default custom texture, based on it's hair length (so short hair chooses a short custom texture etc).

It figures out the length of hair based on the lowest pixel. Hair styles with built-in beards probably won't work so well.

for both 1.0 and 1.1

https://github.com/gaberad/DontShaveYourHead/tree/fallback-texture
Logged

BlueTressym

  • Drifter
  • **
  • Posts: 62
  • Refugee from Mundania
    • View Profile
Re: [1.0] Don't Shave Your Head! - v1.0.0
« Reply #101 on: March 27, 2020, 10:05:37 PM »

Hi.  Is there a way to make this compatible with Automatic's 'Gradient Hair'?  I didn't get a reply when I asked them about it some time back but they have said since that they have a dedicated API (Whatever that is; I am not fluent in Code) and that it should make it easy for people to add support.  There was some talk about it when some other people were asking about compatibility with other mods.  I don't know enough to know if it's something you can fix. 

I would really love to be able to use both mods together but currently, using this one disables the gradient on the pawn; they still show as having it in Prep. Carefully or the Change Dresser but not on screen.  The hair renders correctly in terms of not being shaved but the second colour doesn't display.  I have pictures if that helps. 
Logged
Pages: 1 ... 5 6 [7]