Ludeon Forums

Ludeon Forums

  • November 20, 2018, 12:16:09 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 28 29 [30]

Author Topic: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0  (Read 153044 times)

中村ジロ

  • Drifter
  • **
  • Posts: 85
  • Knowledge Navigation Apprentice
    • View Profile
Re: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0
« Reply #435 on: November 02, 2018, 03:07:40 AM »

This looks really really good, better than Centralized Climate Control even. How well does it work with Bad Hygiene? Does it conflict at all?
Logged
People say the funniest things, don't they?

Morgloz

  • Colonist
  • ***
  • Posts: 104
  • Refugee
    • View Profile
Re: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0
« Reply #436 on: November 02, 2018, 12:30:41 PM »

Testing inside a cool base averaging 15c, a heater in one room will reach 21c easily. But an adjacent room connected by either a vanilla or redistheat vent will be practically unaffected, hovering around 17c. Even double walled, it doesn't remain insulated at all, and this gap only widens the colder the ambient temperature is.

Take a map with a cold ambient temp of -30c, two adjacent 5x5 rooms, double walled and connected by a vent, and only one with a heater. The heated room will struggle to maintain 19c, but the one next to it will barely approach 8c. Better than the outside temp, but still unsatisfactory. Adding two more heaters to the first room allows it to stay stable at 21c, but the room next to it still will not go above 10~12c.
I didn't notice any changes in the code regarding equalization. I'll check what can be done.
When I have no choice but to put a cooler or heater in every room to maintain a stable temperature, it defeats the entire purpose of having vents in the first place. Is there any way to tweak the effectiveness of redistheat vents, to make them more efficient in trading temps?
Not now, but I should be able to change the code to make the efectiveness tweakable
Logged
My mods:
RedistHeat

Morgloz

  • Colonist
  • ***
  • Posts: 104
  • Refugee
    • View Profile
Re: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0
« Reply #437 on: November 02, 2018, 12:32:08 PM »

This looks really really good, better than Centralized Climate Control even. How well does it work with Bad Hygiene? Does it conflict at all?
I didn't hear anybody complaining about conflicts with Bad hygiene, so I guess it works well
Logged
My mods:
RedistHeat

HomoPuerRobustus

  • Muffalo
  • *
  • Posts: 1
  • Refugee
    • View Profile
Re: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0
« Reply #438 on: November 03, 2018, 01:13:12 PM »

Quote
Also, to install RH on existing colonies, you must first destroy every vent and temperature building first.

Could you explain this, please? Will this mod will break vanilla vents, heaters, and coolers?
Logged

Morgloz

  • Colonist
  • ***
  • Posts: 104
  • Refugee
    • View Profile
Re: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0
« Reply #439 on: November 04, 2018, 07:41:40 AM »

Yes, it breaks them
Logged
My mods:
RedistHeat

Babycakes

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0
« Reply #440 on: November 05, 2018, 09:31:57 PM »

Could someone please do a quick fix and make this mod buildable on smooth walls?

Please please pretty pleeeease!
Logged

publicuser

  • Drifter
  • **
  • Posts: 68
  • Refugee
    • View Profile
Re: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0
« Reply #441 on: November 09, 2018, 12:45:31 AM »

Add some Simplified Chinese translations which untranslated based on existing translation, by master_wu. In attachment
Logged

Kassidoo

  • Drifter
  • **
  • Posts: 57
  • Refugee
    • View Profile
Re: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0
« Reply #442 on: November 09, 2018, 08:51:53 AM »

Hi, it seems the balancing of the heaters of this mod is off, I have 2 industrial heaters and somehow they are able to heat a massive base on ice sheet;
https://imgur.com/ad6d00e7-6f73-4f7c-b5ae-4f5aba90b42a

2 industrial heaters with 2 intakes (so total airflow of 32) and 35 outlets (I thought it was 4 airflow per outlet?) is somehow able heat all this to comfortable temperature even when outside temperature is -94*C
Logged

zmadz

  • Drifter
  • **
  • Posts: 92
  • Refugee
    • View Profile
Re: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0
« Reply #443 on: November 13, 2018, 02:52:57 PM »

i noticed today that it spams the log so much that it kills fps of a playable game :(
Logged

Asero

  • Drifter
  • **
  • Posts: 84
  • Muffalo Herder
    • View Profile
Re: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0
« Reply #444 on: November 13, 2018, 08:54:02 PM »

i noticed today that it spams the log so much that it kills fps of a playable game :(

Same problem here, though it luckily doesn't seem to affect the framerate on my end. It's pretty annoying though since it makes the log useless to track potential problems with other mods during gameplay or testing.

Edit: Seems if you have Debug mode enabled, you get your log spammed up with this nonsense. Also I just found out that this mod uses // Assembly-CSharp, Version=1.0.6864.30442 instead of // Assembly-CSharp, Version=1.0.6864.30166 (Stable version)

Either way, I'm moving on to something else.
« Last Edit: November 17, 2018, 02:41:27 AM by Asero »
Logged

Anexgohan

  • Drifter
  • **
  • Posts: 23
  • Anex
    • View Profile
Re: [1.0] RedistHeat (Oct 29, v50) Ported to 1.0
« Reply #445 on: November 17, 2018, 01:09:28 AM »

I'm getting this errors in yellow colour
"
Multiple nets on the same cell (169, 0, 130). This is probably a result of an earlier error.
Verse.Log:Warning(String, Boolean)
RimWorld.PowerNetGrid:Notify_PowerNetDeleted(PowerNet)
RimWorld.PowerNetManager:DeletePowerNet(PowerNet)
RimWorld.PowerNetManager:TryDestroyNetAt(IntVec3)
RimWorld.PowerNetManager:UpdatePowerNetsAndConnections_First()
Verse.Map:MapUpdate()
Verse.Game:UpdatePlay()
Verse.Root_Play:Update()

"
&
"

Two power nets on the same cell (169, 130). First transmitters: Power switch and Power switch.
Verse.Log:Warning(String, Boolean)
RimWorld.PowerNetGrid:Notify_PowerNetCreated(PowerNet)
RimWorld.PowerNetManager:RegisterPowerNet(PowerNet)
RimWorld.PowerNetManager:TryCreateNetAt(IntVec3)
RimWorld.PowerNetManager:UpdatePowerNetsAndConnections_First()
Verse.Map:MapUpdate()
Verse.Game:UpdatePlay()
Verse.Root_Play:Update()


"


Also my Debug Log is filled with this message in white colour

"
RedistHeat: Equalize pushers 32 pullers 32

RedistHeat: Intake net result temp: -22.38774 with diff: 318 force: 16 temp: 16.59494 count: 334

RedistHeat: Intake room result temp: 16.59212


RedistHeat: Outlet force: 4 with pullers: 32 and pushers: 32


RedistHeat: DuctOutlet count 218 pushers 32 pullers 32 force 4 result 17.37583


RedistHeat: Outlet result temp: 17.37583 with diff: 214 force: 4 temp: -22.38774 count: 218


"


Any idea what's going on.


Logged
Pages: 1 ... 28 29 [30]