Ludeon Forums

Ludeon Forums

  • May 09, 2021, 08:55:21 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Pawns looking for deconstruct order that no longer exists  (Read 109 times)

megaPerson

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Pawns looking for deconstruct order that no longer exists
« on: May 02, 2021, 01:14:52 PM »

I've been playing this run for a while, but yesterday started having and issue where my pawns have started "standing" when they would normally be deconstructing. The debug log gives the "Pawn started 10 jobs in one tick." notification, identifies the job as "deconstruct" and then "A=Thing_Frame_Turret_MiniTurret679470" which I assume means it's looking to deconstruct a miniturret. I have no miniturrets currently waiting to be deconstructed.

Edit: Pawns will construct automatically, as well as any other job. this only happens with deconstructing.

I'm playing with a handful of mods -- I've already tried removing a lot of unused ones -- but I think this is an issue with Save Our Ship 2. We are in space, I have 3 different ships that I've captured (they're now on the same map as my main ship) and I've been deconstructing them for parts/using them as extra defense in battle. One such battle destroyed a ton of buildings I'd had cued for deconstruction, including a number of miniturrets, but they don't seem to have been removed from the job queue, which leaves my pawns looking to deconstruct something that isn't there. Is there any way to reset the job queue, or refresh the map to check which tiles are actually present? any other solutions? I really don't want to have to start a new game...

I'm having trouble sharing my logs, HugsLib is giving me an error saying it's finding an unprocessable entry. Luckily I'm only getting one error message, so here's a copy paste:

Code: [Select]
Squint started 10 jobs in one tick. newJob=Deconstruct (Job_8243109) A=Thing_Frame_Turret_MiniTurret1679470 jobGiver=RimWorld.JobGiver_Work jobList=(Deconstruct (Job_8243089) A=Thing_Frame_Turret_MiniTurret1679470) (Deconstruct (Job_8243091) A=Thing_Frame_Turret_MiniTurret1679470) (Deconstruct (Job_8243093) A=Thing_Frame_Turret_MiniTurret1679470) (Deconstruct (Job_8243095) A=Thing_Frame_Turret_MiniTurret1679470) (Deconstruct (Job_8243097) A=Thing_Frame_Turret_MiniTurret1679470) (Deconstruct (Job_8243099) A=Thing_Frame_Turret_MiniTurret1679470) (Deconstruct (Job_8243101) A=Thing_Frame_Turret_MiniTurret1679470) (Deconstruct (Job_8243103) A=Thing_Frame_Turret_MiniTurret1679470) (Deconstruct (Job_8243105) A=Thing_Frame_Turret_MiniTurret1679470) (Deconstruct (Job_8243107) A=Thing_Frame_Turret_MiniTurret1679470) (Deconstruct (Job_8243109) A=Thing_Frame_Turret_MiniTurret1679470)
 
« Last Edit: May 02, 2021, 01:18:42 PM by megaPerson »
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9941
  • Refugee
    • View Profile
Re: Pawns looking for deconstruct order that no longer exists
« Reply #1 on: May 02, 2021, 04:00:54 PM »

You can try to look at your safegame for "MiniTurret679470" and delete the entry.
Don't forget to backup the safegame before you edit it.

Could it be that you have minified turrets at your stockpile and maybe these got the deconstruct order but you let the pawn uninstall it manualy so the deconst order is maybs still there ?

megaPerson

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: Pawns looking for deconstruct order that no longer exists
« Reply #2 on: May 03, 2021, 11:09:28 AM »

Thanks for the tip, I deleted MiniTurret1679470 from the save file and the error went away, but then ALL of my pawns were just "standing"... aaaand I forgot to back up my save like the very smart man I am. Luckily I'm not playing on permadeath, so I had some older autosaves that weren't too far back. Your advice helped me locate the turret in question: it was a blueprint that I'd forbidden, but it was on top of another blueprint (a hardpoint, if you're familiar with SOS2) which couldn't be built while another blueprint was on top of it. Pawns normally deconstruct everything on top of the hardpoint blueprint (even if it means constructing the blueprints first), then build the hardpoint, but since the turret was forbidden they couldn't access it. Going back to my most recent autosave, I allowed the offending blueprint so that it could be deconstructed, and once that was out of the way, the problem was solved. My pawns are deconstructing things on their own again.
Logged