Game keeps crashing, downloads 6mb of something and has missing executable

Started by Ser Kitteh, April 11, 2018, 10:23:04 AM

Previous topic - Next topic

Ser Kitteh

Yeah, it's most very likely a Steam thing. I am 90% sure this is no longer just a Rimworld problem considering it's affecting ALL my games.

I've gone to Steam support, checked all their guides, but every game I boot up, they all crash within 3-5 minutes. Each game is completely clean, brand new save files and all. There are only 3 games installed out of my 81 (Rimworld, Star Wars Battlefront II - 2005 and Homeworld Remastered).

I am at my wits ends here. Barring a clean wipe, something I can't really afford considering my limited time, money and abundance of assignments, Idk what else to do. I spent 3 years yesternight with troubleshooting on Rimworld's Discord server and another 2 hours this morning. If there's anything that can be done, please help.

[attachment deleted due to age]


Okay we're going to need some more info and test info here I think to help determine what's causing the issue. So firstly what are your system specs? CPU, RAM, GPU, O/S, laptop or desktop?

Then some test data is needed:

1 - Have you tried uninstalling your AV completely? If you haven't tried it yet then please do (if you are using Windows 10 then it won't allow you to remove AV protection from your system completely, and will revert to using Defender if it can't detect any other active protection. But that's fine for the purposes of this test).
1a - If you have tried it then was the problem still the same? Or were there some differences you could detect? (see next)
1b - Related to 1a, what nature are these crashes taking? Is an error message popping up when a game crashes? Or are you just being thrown back to the desktop with no message at all? Or is the computer shutting down? Or... ?? And is the nature consistent? (ie. Do you always get an error message? Or do you get one sometimes, but other times not).
1c - If any sort of error message appears then please post a screenshot of it.

Tbh I'm not sure this is AV related because you say your games (or RimWorld at least) are running for a few minutes before crashing (still do test 1 though). And any AV (worth anything) wouldn't allow a suspect executable to launch in the first place (since your system would be compromised the moment it was). It's possible that *something* is happening after a few minutes into a game with Steam and in relation to its internet connection, and the AV is detecting this *something* and shutting down Steam and the game. So...

2 - Try launching any non-Steam game. If you have no GoG games (or the like), then try a free game or a demo. I spent some time playing BoW (Battle of Wesnoth) years ago so try downloading, installing, and playing that game for an hour to see if it crashes or not.

It's vital from a troubleshooting PoV to establish if these crashes are Steam related or not, as otherwise it's going to be impossible to determine what's causing the problem. Maybe you have already confirmed that Steam is the cause (just not sure why), but if you have then you haven't relayed that information here yet, so I am assuming Steam is just a suspect right now (and not confirmed as the cause)

2a - If BoW* crashes then try again but make sure you are disconnected from the internet this time (and make sure to turn off auto-connect).

Whether or not BoW* works or not should help narrow down the cause, and likewise should help determine how to proceed with pinpointing it.
(*or whatever non-Steam, non-internet dependent game your tried)

Although you can still try #3 in relation to (at least) RimWorld.

3 - Make sure RimWorld is properly installed (either by checking file integrity or performing another clean reinstall), exit Steam completely, then navigate to the RimWorld install directory and then run the RimWorldWin.exe directly from the install folder. You will get a "Steam is not running" error when the main menu loads, but you can just click ignore (or close, can't remember which) and access the main menu as usual (but Steam related services and mods etc won't work for obvious reasons).

3a - If it crashes then as with 2a, disconnect from the internet and try again.

If RimWorld still crashes when launched this way then I can't see how it's a Steam problem. And if an AV issue is ruled out as well then I'm afraid it's starting to look like a hardware issue (I think defective RAM can cause random crashes, but other things can as well).

But lets try to rule out software related possibilities before assuming it's hardware related.

Ser Kitteh

OS Name   Microsoft Windows 7 Professional
Version   6.1.7600 Build 7600
Other OS Description    Not Available
OS Manufacturer   Microsoft Corporation
System Name   USER-PC
System Manufacturer   ASUSTeK COMPUTER INC.
System Model   K55VD
System Type   x64-based PC
Processor   Intel(R) Core(TM) i3-3120M CPU @ 2.50GHz, 2500 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date   American Megatrends Inc. K55VD.408, 31/1/2013
SMBIOS Version   2.7
Windows Directory   C:\Windows
System Directory   C:\Windows\system32
Boot Device   \Device\HarddiskVolume1
Locale   (removed)
Hardware Abstraction Layer   Version = "6.1.7600.16385"
User Name   user-PC\user
Time Zone   (removed)
Installed Physical Memory (RAM)   8.00 GB
Total Physical Memory   7.89 GB
Available Physical Memory   4.12 GB
Total Virtual Memory   7.89 GB
Available Virtual Memory   3.87 GB
Page File Space   0 bytes

My laptop is an Asus A55V. It's about six years old. It's pretty old and beat up.

I have no AV installed other than basic Windows Defender. I'm a sitting duck atm but that's okay as long as the problem is fixed.

Steps 1:

Nature of crashes:

Here's how it goes, I boot up a game via my Steam library, it loads normally but shows at as updating as seen in the attachment below plus the mysterious 6 mb. I quit or the game crashes and there's no need to download the 6 mb again until I need to do it again. So basically it happens every second boot up.

I leave the game running for a while before it crashes after a few minutes. There are no pop-up messages of any kind. It just goes kaput. This happens with the other two games as well (SWBF II and Homeworld). I leave the game running to get a drink and sees it's crashed to desktop without even saying why.

All my drivers are up to date.

Yes, I reinstalled Steam from what I can only assume is the 7th time.

Steps 2:

I booted up the Fight Knight beta and let it running for ten minutes. I downloaded Paths of Exile and it also works fine. I left both games running in the main menu, I'm not actually playing them.

I can only assume this is a Steam thing. Steams says "missing executable" for all my games despite the fact the games boot up just fine.


I put my Steam client/launcher in E. However, when I install a new game, the new games and files goes to: E:\Program Files (x86)\Steam\steamapps\common

My old uninstalled files (games I haven't played in a while but still have saved games of) I put in: E:\Steam\steamapps\common

Could this be the cause of the problem or are program files (x86) a completely different beast?

[attachment deleted due to age]


Thanks for the info. It's certainly sounding a lot more like a purely Steam based issue (to me) now than it was before.

If you haven't tried installing Steam and/or Steam games on your c:drive (boot/system) drive yet then I'd certainly try that, since not everything is happy to work from locations away from the c:drive. I know a lot of people do install Steam and run Steam games on non c:drives, but perhaps Steam changed *something* recently while fiddling with their client (as they regularly do), and this has caused (I assume unintentionally) a problem for non c:drive installation.

And did RimWorld work when run outside of Steam? (test #3). I can't see where you answered that (apologies for my blindness if you did).

But if this is a Steam issue them I'm afraid you'll have to rely on Steam support to sort it out, not least because I don't have to know how to help with a purely Steam technical issue (others here might, but I can only speak for myself in this regard).

Only other things I can think of:

1 - You're using a laptop, so have you altered your power management settings at all recently? And/or check your power management options to make sure everything is set to max power / max performance (note I'm assuming your laptop is plugged in).

This would more likely apply if you had a dedicated GPU, since they have idling options that can cause issues. AFAIK there are no such options with the Intel HD4000 GPU

1a - Maybe there's a faulty (or genuine) low power report being flagged due to a failing laptop battery, and this is causing a partial system shutdown to save power. Which can happen even if it's plugged in (ie. faulty). So try shutting your computer down, removing the battery, plugging in the power lead and trying again. Most (all?) laptops don't actually require the battery to work, and will function as normal when directly plugged in (but obviously without the failsafe in the event of a power cut).

But this is a long long long shot, and tbh I can't see how it's the cause of the issue based on the info you've provided (and I'm only mentioning it in relation to "list all non-Steam causes that could, in theory, even if it's a wild theory, be causing this problem")

2 - Check the Windows Event Viewer and see what's being reported at the time the game crashes. It should be accessible via Control Panel>Administrative Tools, but my Windows history skipped 7, so the former is based on how to access it in Win8 (but of course Google will be able to tell you if you can't access it this way).

If you haven't used Event Viewer before then FYI it can take quite a while to populate the list after you click on an entry under Windows Logs. It doesn't always tell you it's populating the list either, so at first it might seem like there are no logs at all. But they are there, but you might have to wait several minutes for them to appear.

Ser Kitteh

So I think I just found out what was that mysterious 6 mb.

It was RimworldWin. Aka the missing executable. And I have proof in the attachments below.

That was the BEFORE and AFTER. I booted the game outside of Steam. I didn't do step #3, I forgot about it. My apologies. I didn't use Steam, I launched it from the folder, but the problem repeated.

So I booted up the game. I let it run in the background and it disappeared 4-5 minutes later. It just went kaput. That's why there's no error message. The executable literally deleted itself and honestly I have no idea where it went.

I repeated the same thing with SWBF II and the same thing occurred. The win.exe for the game deleted itself.

So this isn't Rimworld, it's Homeworld. I took it off from event viewer as you told me to, and this is the result:

- <Event xmlns="">
+ <System>
  <Provider Name="Application Hang" />
  <EventID Qualifiers="0">1002</EventID>
  <TimeCreated SystemTime="2018-04-13T00:29:37.000000000Z" />
  <Security />
- <EventData>

I can only assume all the red application hangs are the same thing for Rimworld. Idk what to do with the information, but I assume it's of some importance.

My power issue however, is thankfully at no fault. My battery is in tip top shape despite its six years and I have issues with it. I say this while typing without battery plugged into the wall.

I followed some other Steam advice in regards to "repairing my library folder" but that doesn't seem to fix the issue. Something else that occurred to me is that two weeks ago is that I installed Advanced System Care. I got rid of that too.

I've followed the whole "delete steamapps advice" as well but I've done it numerous ways. I've done it before re-downloading my games and done it after re-downloading my games. Same thing for the Steam client itself.

I also have two folders for steamapps,

in C:\Program Files (x86)\Steam\steamapps\common

and in E:\Steam\steamapps\common

I wonder if this part of the reason this conflict happens. The C: part does not contain the executables for any games however.

Lastly, the third attachment is my output log for the crash.

[attachment deleted due to age]

Ser Kitteh

So I just downloaded a fresh install of Microsoft Security Essentials and found a bunch of Hacktools and Trojans. Got it all quarantined and removed. I'm not 100% sure if that'll fix the issue.



Firstly, your log file does contain some info about the crash. Which is a good thing since at least it's something to go on, and confirms the game is crashing (rather than the O/S or AV or something else randomly shutting it down). Unfortunately the errors are not ones I've seen before, and Googling them brings up a handful of results, but not one of the people encountering this error got any sort of reply.

0x0533EB48 ((<unknown>))
ERROR: SymGetSymFromAddr64, GetLastError: 'The specified module could not be found.' (Address: 0533EA39)
ERROR: SymGetModuleInfo64, GetLastError: 'A dynamic link library (DLL) initialization routine failed.' (Address: 0533EA39)

The error suggests that the game is failing to find a dll, which could be consistent with you having two install locations for Steam.

So my advice would be to tidy up your Steam installation and put everything on the c:drive. I don't know if having them split is causing problems, but right now it's by far the #1 most likely cause IMO. Even if you've had them split before, and it always worked fine, don't rule out a Steam update suddenly deciding it's no longer fine. If you don't have the space on your c:drive to install all your games then personally I'd say worry about that later, since that's less of a concern than getting to the bottom of what's causing these crashes. RimWorld needs very little space (not sure how much the Steam client uses though, and I don't have it installed to check).

I'd also advise using Revo Uninstaller to uninstall Steam (if you don't use it already) Since if I were experiencing this problem I'd be trying to clean up every trace of Steam I could before reinstalling, since otherwise some residual reference to the e:drive paths could mess everything up after the reinstall and negate the point of the whole endeavour.

Secondly, something I just noticed is that there are two references to your GPU(s) in the log. I have never seen this before and I can't see how it's a good thing. My immediate thinking is that Steam is launching two instances of RimWorld and these two instances are both writing to the same log file. Which doesn't make any sense at all, but I can't think of any other way for there to be two GPU references. Plus two instances could explain the crashing, since perhaps the game is trying to use a dll that is being used by the other instance. I don't know to be honest, since two GPU references just doesn't make any sense.

Plus it appears you have a dual GPU laptop with a Nvidia GPU. You didn't mention this when I asked for your system specs. I don't think this crash is related to that, but it does provide another troubleshooting option.

Thirdly, the event viewer is registering the crash (for HomeWorld at least). The crash info doesn't contain any useful info (for me at least), but I wouldn't rule out you wanting to contact Microsoft support about this issue if it can't be figured out (and Microsoft support might well be able to use such crash info).

So, to summarise the plan:

1 - Uninstall Steam completely. Use Revo (and maybe CCleaner) to remove as many Steam references as possible.
1a - Once that is done install Steam to the c:drive.
1b - Then install RimWorld to the c:drive. Don't put anything on the e:drive (or any other drive) at all. Only use the c:drive.
1c - Exit Steam, goto the RimWorld installation directory and copy the entire RimWorld folder to somewhere else on your harddrive. But not to a Windows controlled folder (so not documents or downloads etc). So just copy the folder to the root drive or something.
1d - Launch Steam and then launch RimWorld and play it until it crashes (or hopefully not).

2 - If it crashes then exit Steam completely and check to see if the RimWorldWin.exe has been deleted again or not. No action is required either way, but make sure to make a note of whether the .exe is still there or not.
2a - Go to wherever you copied the RimWorld installation to in 1c and launch the RimWorldWin.exe from there (remember not to have Steam running).
2b - If it crashes again then check the copy of the installation folder to see if the RimWorldWin.exe has been deleted or not. Again no action required, but it's important to know if the .exe is still there or not.

If the .exe is being deleted in both cases, then it must be getting deleted by either Windows itself, Windows Defender, or by a virus. The game wouldn't delete it's own .exe (for any reason at all), and 2b should rule out any Steam involvement. You still have Windows Defender activated, so AV can't be ruled out yet.

One test you can to rule that out is:

3 - Reinstall RimWorld again (you must be sick of doing this by now but troubleshooting mysterious problems is rarely quick, and always involves laborious repetition),
3a - Exit Steam and copy the RimWorld installation directory somewhere else again (same place as last time should be fine).
3b - Disconnect from the internet completely (make sure you disable auto-connect).
3c- Disable Windows Defender (Win7 should allow you to disable it, as it's nanny bot settings aren't as nannying as Win10)
3d- Run RimWorldWin.exe from the copy of the installation directory again.

If Steam isn't running, and if you have no AV running, and the .exe still gets deleted, then... ?!? it's either Windows itself, a virus, or a total mystery.

I'll leave it there for now and wait for you to report back. There's another test you can try involving disabling your Nvidia GPU, and with the aim of trying to get rid of those two GPU references in the log file (which as I said can't be a good thing). But better to rule out other stuff first (as I don't know your computer know-how, so I'm not sure how comfortable you are with disabling devices).

Ser Kitteh

Quick question as I am not very well versed in this:

Does that mean programfilesx86 should be put in Steam and only Steamin C:? Because for as long as I can remember, Steam and program files have been two seperate folders.


Ah, just seen your post (the one above my lengthy one). I hadn't ruled out this being caused by a virus, but I had pushed it down the list because you said you were running Malwarebytes, which I assume meant you were using Malwarebytes active protection, and so in theory couldn't or shouldn't, have picked any unwanted crap.

So before anything else, and if Microsoft Security Essentials doesn't fix it, then I'd recommend downloading and running Rogue Killer . I've been using this together with Malwarebytes for several years and as yet I haven't come across anything that they haven't been able to detect and remove.


Quote from: Ser Kitteh on April 13, 2018, 11:34:37 AMDoes that mean programfilesx86 should be put in Steam and only Steamin C:?
Not entirely sure what you mean here (have you written these two folders the wrong way around? Since you can't put the Program Files (x86) folder in the Steam folder, but you can put the Steam folder inside Program Files (x86) fodler).

The Program Files and/or Program Files (x86) folder(s) is always located at the base/root of the c:drive. ie. c:\Program Files. I don't know if Win7 has one or both of these folders. Win8 and Win10 have both, but I don't know if Win7 does.

But the installation directory that Steam defaults to should be one of these folders, so just install it to whatever the default installation path is. Note, this is assuming it defaults to the c:drive (since I do not know if you have altered your Windows setting and selected another default path for programs or not).

Quote from: Ser Kitteh on April 13, 2018, 11:34:37 AMBecause for as long as I can remember, Steam and program files have been two seperate folders.
They are separate folders, with the Steam folder usually being located inside the Program Files folder. So for example C:\Program Files\Steam .

Ser Kitteh

So Idk how it's done, but Rimworld is running just fine. I left it running for 20 or so minutes and it worked just fine. I haven't extensively played it due to my workload, but as far as I can tell, Rimworld is fixed!

Granted my C: drive can only hold like, 4 games, but that's a small cost to get Rimworld working again. I've no clue how mods would work as well. But no more 6 mb downloads, no more missing RimworldWin. It works.

I guess I could go on another 3 pages on how to put games in E: and see how that works but I don't game much other than a few sessions of Rimworld. I truly appreciate your assistance, Calahan!

(As a minor aside, you advised me to get rid of everything Steam related via RevoUninstaller. Thank God I didn't, I almost erased every single save file on my older games. I was ONE click away from wiping away my hundreds of hours in Pillars of Eternity and other RPGs. Basically, I uninstalled Steam but didn't wipe out its traces which included my save files)

I can only assume the reasons of my problems, were as you said, having Steam in E: and maybe Steam client updated and went haywire. That and the dozens or so viruses which I removed via RogueKiller and Microsoft Security Essentials.


Great to hear everything is working again. The split installation locations was the most likely cause (as I said maybe Steam changed something that now causes problems or such setups), although those viruses / malware certainly weren't helping in general.

And many apologies for almost costing you your hard earned collection of save games. Your shooting skill just increase by +2 due to you keen sense perception to danger. I thought (quite mistakenly it seems) that save data from SuchAndSuch game would always be stored in their own LocalLow folders (like RimWorld's), and that Steam's footprint wouldn't be tagged as having association with the folders for individual games, and so removing all traces of Steam wouldn't also mean all traces of every game installed via Steam. My lack of knowledge and experience with Steam was certainly on full display for this one :-[

Ser Kitteh

Nah man, thank YOU. The fact I was able to do this on a weekend at my home with my superfast Internet ensured I didn't pull my hair out like crazy if I were doing it on campus. It would have taken thrice as long if I did it on campus.

As I've said, I wouldn't 100% know until I put a few hours into Rimworld, something I'm afraid I won't be able to do this week. BUT afterwards, when things calm down, I'm gonna play a long session and mess around with mods. Again, thank you for your amazing assist.:)