Ludeon Forums

Ludeon Forums

  • September 27, 2021, 10:02:08 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: [1.0.2059] Nobody is dealing/taking any damage (save file included)  (Read 763 times)

KOT

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile

Hey everyone.

My friend just sent me his save file and he said that whenever somebody is fighting - no damage is registering. If he starts a new scenario - all is working as intended.
I tried loading up and checking his colony on my computer and yes - nobody can hit/kill anyone, even mortars don't work.

Even once the infestation starts - the bugs attack, everybody's fighting but nobody is taking damage.

Any way to fix this?

I've uploaded the save file in case anyone's interested. https://www.dropbox.com/s/eepv4km01g1irm2/%D0%A1%D0%B5%D0%B2%D0%B5%D1%80%D0%BE-%D0%B7%D0%B0%D0%BF%D0%B0%D0%B4%D0%BD%D1%8B%D0%B9%20%D0%91%D0%BB%D0%BE%D0%BA30.rws?dl=0
Logged

mlzovozlm

  • Colonist
  • ***
  • Posts: 144
  • Refugee
    • View Profile
Re: [1.0.2059] Nobody is dealing/taking any damage (save file included)
« Reply #1 on: November 06, 2018, 10:59:12 PM »

if starting a new game fix it, hmm, is it a cross-version save (mod or vanilla)?
Logged

KOT

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.0.2059] Nobody is dealing/taking any damage (save file included)
« Reply #2 on: November 07, 2018, 06:00:10 AM »

It's a recent game (started some time after release). Also he doesn't use any mods that change mechanics of the game. Only some minor mods for the interface.

I run a completely vanilla version of the game and was able to run his save and check if his bug works on my game and it does.

Also he said that he was able to dig out another older save file where the bug doesn't occur. Meaning it happened somewhere mid game, regardless of the version.
« Last Edit: November 07, 2018, 06:20:59 AM by KOT »
Logged

Krutonz101

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.0.2059] Nobody is dealing/taking any damage (save file included)
« Reply #3 on: November 08, 2018, 10:08:30 AM »

I have the exact same problem.  I have these mods loaded Hugslib, lovely hair styles, animal variety coats, interaction bubbles, color coded mood bars, psychology.   I believe this problem arose when I had to play in offline mode and turn off all my mods one time.  It does not work when I try to run just the core game or the game with all the mods
Logged

Kenneth

  • Colonist
  • ***
  • Posts: 305
  • Refugee
    • View Profile
Re: [1.0.2059] Nobody is dealing/taking any damage (save file included)
« Reply #4 on: November 29, 2018, 06:02:56 PM »

Couldn't reproduce this on vanilla, when loading the savegame I got an exception that indicates there is some corrupt data in the savegame most likely caused by a mod.
Apart from that the savegame worked fine for me, when attacking raiders they took and dealt damage, so I assume it's something mod-related.

If it happens again or is not solved for anyone yet, please create a thread in the mod bugs forum.
Logged