Ludeon Forums

Ludeon Forums

  • April 21, 2019, 01:00:18 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Colonists won't spawn when loading a save/auto-save  (Read 207 times)

GruntHouse

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Colonists won't spawn when loading a save/auto-save
« on: December 15, 2018, 06:32:20 PM »

So they were still there before I loaded a auto-save AND they were present when the game autosaved. I tried looking through the debug-log but I do not get how I should approach it.

Debug log is attached as a .txt file since it is too big for a post.

MOD LIST:
HugsLib
JecsTools
Humanoid Alien Races 2.0
Faction Discovery
[XND] Turret Extensions
Lord of the Rims - The Third Age
Camera+
Hospitality
Doors Expanded
Snap Out
Misc. Training
More Sculpture
RimQuest
Heat Map
Megafauna
Map Reroll
Realistic Rooms
Expanded Prosthetics and Organ Engineering
Psychology
More Faction Interaction
[KV] Faction Control - 1.0
Lord of the Rims - Dwarves
Wandering Caravans [v2.4.0]
Quarry 1.0
[L]MoreDetailBody
Mad Skills
Call of Cthulhu - Cosmic Horrors
Call of Cthulhu - Elder Things id=882126182
Simple sidearms
Harvest Organs Post Mortem - 4.1 [1.0]
Harvest Everything!
Prisoner Harvesting
SF Grim Reality 1.0
Rich Traders
Giddy-up! Core
Giddy-up! Ride and Roll
Giddy-up! Caravan
A Dog Said... Animal Prosthetics
Alpha Animals
Animals Logic
Interaction Bubbles
H.P. Lovecraft Storyteller - Remastered
Call of Cthulhu - Straitjackets
Rim of Madness - Werewolves
More Practical Traits
Colony Leadership
RimWriter - Books, Scrolls, Tablets, and Libraries
[RF] Etched Stone Walls [1.0]
Feed The Colonists
Color Coded Mood Bar
Logann RaceArgonians of Blackmarsh
Fantasy Goblins
Orc Invasion
Rim of Madness - Arachnophobia
Door Mat R1.0
[sd] bridges
Real Ruins
Infused
Research Scrollbars
[SS]Lovely Hair Style
[Ods] Mens Hair
Let's Trade! [1.0]
Sometimes Raids Go Wrong
More Components Light
1.0 - Imprisonment On The Go! (Make Pawns Prisoners Without Beds)
[SYR] Coffee and Tea
Death Rattle
Story Framework
PhiClient
[KV] More Trait Slots - 1.0
[KV] Consolidated Traits - 1.0
Craftsmanship
Draw a bead
[1.0] Dire Raids
[1.0] Modlist
RimHUD
Relations Tab
Kidnapped colonist camp
Goblin Slayer
Advanced Biomes
[RF] Rainbeau Flambe - Storyteller [1.0] |
Realistic Darkness (Lighter Version) 1.0
Field Medic [1.0]
Evil Tactician's RimWorld Tweaks
Zen Garden
The Witcher Trials v2.0
Medieval Times
Dragon Mod
Arrow Please
Weapons+
Jernfalk's Skeletal Legion
Lord of the Rims - Elves
Lord of the Rims - Hobbits
Prison Labor
Defensive Positions
Rim of Madness - Vampires
Rim of Madness - Bones
Giddy-up! Battle Mounts
Call of Cthulhu - Cults
[WD] Additional RAIDs! 1.0
RuntimeGC
Stack XXL
Blueprints
No Debris B18
Locks
FishIndustry
Dubs Skylights
No Burny (less flammable metals)
[sd] nopower comms console
Dirt Paths
[CP] Chicken Mitchell - Hairstyles (1.0)
[KV] Don't stop the music - 1.0
[sd] medicaddons
[sd] round tables
Herd Migration Revival
Pharmacist 
Share The Load
RunAndGun |
[RF] Tribal Raiders [1.0]
The Drow Race
Children, school and learning
Alien Children Compatibility
MendAndRecycle
A RimWorld of Magic
[1.0] Combat Shields
Plague Doctor's Suit - (1.0)
Medieval Bones
Animal Variety Coats
[RF] Pawns are Capable! [1.0]
[KV] Show Hair With Hats or Hide All Hats - 1.0 |
Vanilla-like wheat 1.0.0
Slave Outfits [1.0]
Incident Person Stat
Selling prisoners with no guilt
Logged

Canute

  • Transcendent
  • *****
  • Posts: 6942
  • Refugee
    • View Profile
Re: Colonists won't spawn when loading a save/auto-save
« Reply #1 on: December 16, 2018, 01:48:41 AM »

Hi,
did you even took a look at the error's from the log ?
They are all based about faction like
"Failed to find RimWorld.FactionDef named AsariUnion. There are 51 defs of this type loaded."
But i don't see the Asari race at your modlist.

Btw. we are not that old that we need magnifier ! :-)
Logged

GruntHouse

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: Colonists won't spawn when loading a save/auto-save
« Reply #2 on: December 16, 2018, 06:59:34 AM »

I think the problem lies with: Tried to spawn pawn without def Adkins. (Adkins is the colonist)

But Idk what that means >_<

PS: Idk why I get the faction errors, but I think they shouldn't have a impact on spawning a colonist upon loading...right?
Logged

GruntHouse

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: Colonists won't spawn when loading a save/auto-save
« Reply #3 on: December 18, 2018, 05:33:58 PM »

It seemed that the Third age mod made pawns that joined my colony during the wanderer joins incident unable to be saved...
Logged

austin

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: Colonists won't spawn when loading a save/auto-save
« Reply #4 on: January 11, 2019, 10:42:37 PM »

This can be fixed by replacing "Villager" with "LotR_MedievalVillager" in your save file.

Your save file can be opened with any text editor. On Windows, it is located at C:\Users\$USER\AppData\LocalLow\Ludeon Studios\RimWorld by Ludeon Studios\Saves where $USER is your username.

Then, you replace the text. First, find:

Code: [Select]
>Villager
And, replace:

Code: [Select]
>LotR_MedievalVillager
Logged