Ludeon Forums

Ludeon Forums

  • November 21, 2019, 05:55:22 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 [2]

Author Topic: Rimworld doesn’t start after Catalina Update  (Read 2015 times)

klhsn

  • Muffalo
  • *
  • Posts: 4
  • Refugee
    • View Profile
Re: Rimworld doesn’t start after Catalina Update
« Reply #15 on: October 20, 2019, 04:16:13 AM »

Apparently you can't manually update graphic drivers on a mac. They are automatically installed and updated via OS-Updates.
Other games like Faster Than Light start without problems.
Logged

rave1976

  • Muffalo
  • *
  • Posts: 4
  • Refugee
    • View Profile
Re: Rimworld doesn’t start after Catalina Update
« Reply #16 on: October 20, 2019, 05:31:57 AM »

Agreed. Right now no more Updates for Mac OS. Others games start without Problems on iMac Mid 2014.

Tried it also on my MacPro 2013. There the Game starts and run smoothly. So only the Mac from my Girlfriend (iMac Mid 2014 with Intel Iris Pro 5000) has the mentioned problems...
« Last Edit: October 20, 2019, 10:17:37 AM by rave1976 »
Logged

Tynan

  • Developer
  • Administrator
  • Transcendent
  • *****
  • Posts: 11856
    • View Profile
    • Tynan's Blog
Re: Rimworld doesn’t start after Catalina Update
« Reply #17 on: October 20, 2019, 02:05:26 PM »

I have to admit I'm kind of stumped and frustrated that apparently Apple is now breaking working software.

I hope a future RimWorld update will fix these issues; we'll probably update the Unity version at some point and that might help. But it's not something that'll be released super soon. I'm sorry I can't fix this now, I just have no insight into the problem and can't reproduce it at all.
Logged
Tynan Sylvester - @TynanSylvester - Tynan's Blog

klhsn

  • Muffalo
  • *
  • Posts: 4
  • Refugee
    • View Profile
Re: Rimworld doesn’t start after Catalina Update
« Reply #18 on: October 21, 2019, 04:55:22 AM »

I totally understand your frustration. At the moment my solution will be a new partition with an older macOS version to boot from to play RimWorld. Not the most convenient solution, but workable. Luckily RimWorld doesn't take up much space!
I still hope that one day an update will fix it and that apple doesn't ruin it right away :D
If i could help you in the future with more logs or so just hit me up, it's also in my interest.
However thanks again for the support, I'm now partitioning!
« Last Edit: October 21, 2019, 05:12:37 AM by klhsn »
Logged

rave1976

  • Muffalo
  • *
  • Posts: 4
  • Refugee
    • View Profile
Re: Rimworld doesn’t start after Catalina Update
« Reply #19 on: October 21, 2019, 01:12:21 PM »

I also understand your frustration. Sad... but it seems we/you can`t change the situation right now.

Let`s hope maybe the next update of Rimworld or Catalina fix this problem, so we can enjoy Rimwold again.

For the moment thank you for your effort and greetings from a German Rimworld-Fan!
Logged

Canute

  • Transcendent
  • *****
  • Posts: 7811
  • Refugee
    • View Profile
Re: Rimworld doesn’t start after Catalina Update
« Reply #20 on: October 21, 2019, 01:58:07 PM »

Maybe i found the issue/solution.
Unity use some 32 bit wav importer and Catalina don't support 32 bit anymore.
https://forum.unity.com/threads/installing-unity-on-macos-catalina.689089/

Not sure if there is a solution, maybe take a look self.
Logged

mindlar

  • Muffalo
  • *
  • Posts: 4
  • Refugee
    • View Profile
Re: Rimworld doesn’t start after Catalina Update
« Reply #21 on: October 23, 2019, 02:24:06 PM »

I had problems launching the game from Steam after reinstalling on my mac laptop (mid-2015) after upgrading to Catalina. Had tried nuking everything mentioned in the threads on how to do a clean install.

Steam was tossing up an error: Failure to update and not even making it to Rimworld to launch.

What fixed things for me was navigating to the executable and launching from Finder. Game launched with errors saying that it couldn't talk to Steam overlay. Closed the game, and then launched from Steam and so far everything is good.
Logged

Tynan

  • Developer
  • Administrator
  • Transcendent
  • *****
  • Posts: 11856
    • View Profile
    • Tynan's Blog
Re: Rimworld doesn’t start after Catalina Update
« Reply #22 on: October 25, 2019, 02:12:00 AM »

Thanks mindlar!
Logged
Tynan Sylvester - @TynanSylvester - Tynan's Blog

rave1976

  • Muffalo
  • *
  • Posts: 4
  • Refugee
    • View Profile
Re: Rimworld doesn’t start after Catalina Update
« Reply #23 on: October 31, 2019, 08:40:47 AM »

A little Feedback: newest Update of Catalina (10.15.1) didn't change the problem. Game still freezes at "Initializing.." on iMac 2014.

So... hopefully waiting for an update...
Logged

ItchyFlea

  • Who's a good kitty?
  • Administrator
  • Planetologist
  • *****
  • Posts: 1909
  • Psychotic Squirrel
    • View Profile
Re: Rimworld doesn’t start after Catalina Update
« Reply #24 on: November 08, 2019, 03:32:44 PM »

Log received via email support. Username stripped from report.

Initialize engine version: 5.6.5f1 (2cac56bf7bb6)
GfxDevice: creating device client; threaded=1
2019-11-03 17:16:35.383 RimWorldMac[848:14210] Metal devices available: 1
2019-11-03 17:16:35.383 RimWorldMac[848:14210] 0: Intel Iris Pro Graphics (low power)
Initializing Metal device caps: Intel Iris Pro Graphics
Begin MonoManager ReloadAssembly
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp-firstpass.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/Assembly-CSharp.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.UI.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.UI.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.Networking.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/UnityEngine.Networking.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/TextMeshPro-1.0.55.56.0b11.dll (this message is harmless)
Loading /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/TextMeshPro-1.0.55.56.0b11.dll into Unity Child Domain
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Core.dll (this message is harmless)
- Completed reload, in  0.035 seconds
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.dll (this message is harmless)
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Xml.dll (this message is harmless)
UnloadTime: 1.499783 ms
Setting breakpad minidump AppID = 294100
Steam_SetMinidumpSteamID:  Caching Steam ID:  [Stripped Numbers] [API loaded no]
RimWorld 1.0.2408 rev749
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Metal RecreateSurface[0x1090b0f00]: surface size 1920x1080
Platform assembly: /Users/[Username]/Library/Application Support/Steam/steamapps/common/RimWorld/RimWorldMac.app/Contents/Resources/Data/Managed/System.Xml.Linq.dll (this message is harmless)
Receiving unhandled NULL exception
Obtained 12 stack frames.
« Last Edit: November 10, 2019, 04:53:54 AM by ItchyFlea »
Logged
All my mods are licensed under a Attribution-NonCommercial-ShareAlike 4.0 International
Ask for permission before using in ModPacks

Click here for a list of the mods I've created

Tynan

  • Developer
  • Administrator
  • Transcendent
  • *****
  • Posts: 11856
    • View Profile
    • Tynan's Blog
Re: Rimworld doesn’t start after Catalina Update
« Reply #25 on: November 09, 2019, 03:11:27 AM »

Thanks Michael!

This does seem to be related to an interaction between Catalina, Metal drivers, older integrated video cards, and RimWorld's version of Unity. It's crashing as it tries to initialize a rendering surface for the whole screen, which is a low-level graphics init function.

While I'm annoying that Apple released an update that broke the game, I can understand players are more annoyed at not being able to play it.

We can't quick-fix this because it doesn't relate to code we wrote; it comes from code in the Unity engine/MacOS/Metal driver. The only real option seems to be to update Unity wholesale to a new version several years ahead of the old one, but that is a major overhaul that would break everyone's games. I do intend to address this, but I can't promise a quick immediate fix to it.
Logged
Tynan Sylvester - @TynanSylvester - Tynan's Blog

Tynan

  • Developer
  • Administrator
  • Transcendent
  • *****
  • Posts: 11856
    • View Profile
    • Tynan's Blog
Re: Rimworld doesn’t start after Catalina Update
« Reply #26 on: November 13, 2019, 11:36:08 PM »

I've posted an older version of RimWorld 1.0 to Steam under the beta branch catalina_test.

Some users reported this version works with Catalina.

Anyone having trouble on the latest version - can you give this one a shot and tell me if there's a difference? Thanks!
Logged
Tynan Sylvester - @TynanSylvester - Tynan's Blog
Pages: 1 [2]