Ludeon Forums

Ludeon Forums

  • February 19, 2020, 02:05:23 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: [1.0.2408] Missing Colonist Bar  (Read 221 times)

ntswm2

  • Muffalo
  • *
  • Posts: 1
  • Refugee
    • View Profile
[1.0.2408] Missing Colonist Bar
« on: December 20, 2019, 11:23:29 PM »

Hi Everybody.  I've gotten a missing colonist bar.  I haven't been able to figure out what's causing the problem, but it isn't resolution, I don't think, as I've tried it in every resolution possible, including 1080.

It seems attached to the savegame file, as if I go back to an autosave, the problem seems to resolve itself, but reappears quickly.

The log I get when I attempt to toggle the bar back on:

Root level exception in OnGUI(): System.ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
at System.Collections.Generic.List`1<int>.get_Item (int) <0x0007a>
at RimWorld.ColonistBarDrawLocsFinder.CalculateColonistsInGroup () <0x00131>
at RimWorld.ColonistBarDrawLocsFinder.CalculateDrawLocs (System.Collections.Generic.List`1<UnityEngine.Vector2>,single&) <0x000ac>
at RimWorld.ColonistBar.CheckRecacheEntries () <0x00c92>
at RimWorld.ColonistBar.get_Entries () <0x0001c>
at RimWorld.ColonistBar.ColonistBarOnGUI () <0x000cc>
at (wrapper dynamic-method) RimWorld.MapInterface.MapInterfaceOnGUI_BeforeMainTabs_Patch1 (object) <0x00109>
at RimWorld.UIRoot_Play.UIRootOnGUI () <0x0009c>
at Verse.Root.OnGUI () <0x00112>

Verse.Log:Error(String, Boolean)
Verse.Root:OnGUI()
« Last Edit: December 20, 2019, 11:30:12 PM by ntswm2 »
Logged