Ludeon Forums

Ludeon Forums

  • September 25, 2020, 10:32:24 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: zone bug  (Read 324 times)

penlowe

  • Muffalo
  • *
  • Posts: 5
  • Refugee
    • View Profile
zone bug
« on: January 07, 2020, 11:14:47 AM »

I use no mods at all, playing straight vanilla.

I have on numerous occasions made a zone, say for hay, that was used for a while then suddenly my pawns stop hauling to it. If I try to direct them to do so I get "no accessible spot" message. Yes it is! you hauled stuff there yesterday!(in game yesterday). USUALLY If I delete the zone and remake it, either in the same spot or maybe shifted slightly, it's fine and everything works again. Mind you, these are all storage areas within my home area.

Today I'm ready to tear my hair out. Not only are my new zones not working, (moved it four times) but they didn't haul the dead guy to the graveyard. I get no hauling option to bury him at all on any person, I get only strip or consume messages, as though there is no grave to haul him to.

I have: saved and exited. Saved, exited, restarted and made a new zone. Saved and restarted my computer, made a new zone. It still not working. This group started so well, I really don't want to start over.
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9350
  • Refugee
    • View Profile
Re: zone bug
« Reply #1 on: January 07, 2020, 12:05:08 PM »

Hi,
at first to to enable developer mode at the option.
Then you can open the log window with the top left icon.
When you see red text (errors) the log file would be handy. Read the sticky "How to report..." to locate the logfile and attach it as file to your answer. You need to use Reply to get file attachment options.

When you don't have errors (i don't think you got any) a safegame would be helpful.
Use an archive tool to compress it, since the file limit of the forum is pretty small or use an external hoster.
Best would be a description what isn't working at that point of the safegame.

Logged

LWM

  • Planetologist
  • ****
  • Posts: 1035
  • Little White Mouse
    • View Profile
Re: zone bug
« Reply #2 on: January 07, 2020, 04:46:31 PM »

Having spent a lot of time answering similar questions for my storage mod, I have a possible explanation of what's going on:

The hauling engine requires that when a pawn is hauling hay somewhere, they have to reserve the spot they're heading to.  That reservation means no one else can reserve that spot, so no one else can haul to it.  Is it possible you have a lot of people hauling to a nearly full stockpile zone?  If the only valid places to put hay are already reserved, then....no valid storage spot.

If someone has already reserved the corpse, maybe something similar is going on?

I don't know if that helps.

If you're running vanilla, you can also zip the savegame and upload it?
Logged