Ludeon Forums

Ludeon Forums

  • January 18, 2021, 10:03:57 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Crash on startup  (Read 468 times)

Wambambler

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Crash on startup
« on: September 11, 2020, 03:58:30 PM »

Hi all,

I'm looking for some assistance with a startup crash that started impacting me today. I've owned Rimworld since June 2020 and it has been running without a hitch for around 40 hours playtime. I loaded it up this afternoon, played for approximately 45 minutes and then shut it down. When I came back 15 minutes later and restarted the game I was met with the following error: Rimworld by Ludeon Studios - Unity 2019.2.17f1_8e603399ca02 (see attached screenshot). I've checked the error log and it states the following in every case:

igd10iumd64.dll caused an Access Violation (0xc0000005)
  in module igd10iumd64.dll at 0033:421b1839.

So far I've tried uninstalling / reinstalling, disabling anti-virus and firewall, deleting local config files, verifying integrity of game files on Steam and restarting the machine. Nothing has worked thus far. Also worth noting that I run vanilla with no mods.

Any help would be appreciated and happy to share further info.

Cheers,

Wambambler
« Last Edit: September 11, 2020, 04:03:02 PM by Wambambler »
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9714
  • Refugee
    • View Profile
Re: Crash on startup
« Reply #1 on: September 11, 2020, 05:25:49 PM »

Hi,
igd10iumd64.dll is for your video card.
You should try and update these.
But since it is the driver for an integrated intel video card could it be that you use another video card too ?
Then you need to tell windows that these card should be used instead the intel one when you start Rimworld.
Logged

Wambambler

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: Crash on startup
« Reply #2 on: September 11, 2020, 05:34:26 PM »

Hi Canute,

First off thanks very much for the response. I've already checked my integrated graphics drivers for updates and they are up to date.

I don't have a dedicated card and have been playing Rimworld using an Intel UHD G1 integrated set up for 40+ hours. The only thing that has changed in terms of my set up recently is the addition of a second monitor but Rimworld has played fine for around 2-3 hours since this was installed.

Cheers,

Wambambler
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9714
  • Refugee
    • View Profile
Re: Crash on startup
« Reply #3 on: September 12, 2020, 03:06:01 AM »

The only i can say is the crash error is related to the video card.
I would try
- play not at fullscreen/windowed mode whatever you used.
- unplug 2. monitor
and check if that made a difference.

Maybe try the unity forum too, since i didn't found an entry for the G1, you should just start a new topic there.
Logged

Wambambler

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: Crash on startup
« Reply #4 on: September 14, 2020, 12:58:57 PM »

Hi again Canute,

Thanks again for taking the time to respond. After your input I went on the hunt for updated graphics drivers again and it turns out I was 2 updates behind. The initial search turned up nothing but installing a little Intel Driver and Support Assistant sorted the problem right out. I'm pleased to report that Rimworld is back up and running again.

Thanks Again,

Wambambler
Logged