Ludeon Forums

Ludeon Forums

  • January 22, 2021, 08:15:05 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Interface failing to initialise  (Read 169 times)

BuddhaMakesSense

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Interface failing to initialise
« on: November 15, 2020, 03:06:27 AM »

After updating to Big Sur, I'm unable to play Rimworld on my MacBook Pro 13" 2020. It loads and I see the loading picture briefly, and the message that the interface is being initialised, and then everything goes black, although the game's triangular mouse pointer remains.
Logged

BuddhaMakesSense

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: Interface failing to initialise
« Reply #1 on: November 15, 2020, 02:24:52 PM »

Nevermind, I figured it out. For anyone on a Mac having the same issue:

The cause is the installation of the Royalty Expansion. If you simply drag the Data folder into the package contents of RimWorldMac.app it doesn't merge the contents, but replaces one with the other. In the base game, there's a Core folder that gets deleted when you do it this way.

The instructions for installation that come with the zip need a little rewriting, as the difference between copying and moving isn't always one that's fully appreciated by myself, and probably others too ;-) I'm not even sure if copying the data folder actually gives the option of merging, since I don't want to mess anything up by playing around with it all again. It might be better to just say to move the Royalty folder into the Data folder.

Quote
How to install RimWorld expansions

1) Right-click the RimWorld application -> "Show Package Contents".
2) Copy the downloaded "Data" folder to RimWorld.
Logged