Ludeon Forums

Ludeon Forums

  • January 19, 2021, 11:31:15 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: 1.2.3.3 Combat Extended - Invalid.package.id  (Read 472 times)

Kaiser09

  • Drifter
  • **
  • Posts: 29
  • Refugee
    • View Profile
1.2.3.3 Combat Extended - Invalid.package.id
« on: November 25, 2020, 01:11:52 PM »

Hi guys, I have a lot of mods, all of them seem fine, but when I try to put CE Mod, it gives me this "Depend on invalid.package.id which is not loaded".

What Am I supposed to do?
« Last Edit: November 26, 2020, 03:02:59 AM by Kaiser09 »
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9714
  • Refugee
    • View Profile
Re: Combat Extended - Invalid.package.id
« Reply #1 on: November 25, 2020, 03:17:41 PM »

Hi,
at first read the topic "How to report a bug".

I am curious why Base isn't labeled Core, so maybe try at first to set the game back to engl. just to check if that helps.
1.2.3.3 is the latest CE version. And at last at github there is the right packageID for Harmony which is the only required mod for CE.
Since the that version is from Nov.1  many other would report an issue and a hotfix would made pretty fast, so i think the problem is at your end.

Try to delete Harmony and CE folder from Mods and reinstall them(or unsubscribe and resubscribe) to be sure you don't have any unwanted old file's left at these mods.

Logged

Kaiser09

  • Drifter
  • **
  • Posts: 29
  • Refugee
    • View Profile
Re: Combat Extended - Invalid.package.id
« Reply #2 on: November 26, 2020, 12:00:04 PM »

Hi,
at first read the topic "How to report a bug".

I am curious why Base isn't labeled Core, so maybe try at first to set the game back to engl. just to check if that helps.
1.2.3.3 is the latest CE version. And at last at github there is the right packageID for Harmony which is the only required mod for CE.
Since the that version is from Nov.1  many other would report an issue and a hotfix would made pretty fast, so i think the problem is at your end.

Try to delete Harmony and CE folder from Mods and reinstall them(or unsubscribe and resubscribe) to be sure you don't have any unwanted old file's left at these mods.

First of all, thanks.

I tried to delete my entire mod list, even mod manager and set up the language to english, I loaded harmony and CE only, there was no error. Then I loaded the mod manager, "base" returned to "core" but the error is still there.
I mean, I can't see it when I use the defaut mod display, while I can see it when I use mod manager.
Logged

Kaiser09

  • Drifter
  • **
  • Posts: 29
  • Refugee
    • View Profile
Re: 1.2.3.3 Combat Extended - Invalid.package.id
« Reply #3 on: November 26, 2020, 12:22:17 PM »

Well, I randomly found this warning from the autor of a Vanilla Expanded that says:"If you're receiving Invalid package.id when using Mod Manager, please note that this is a random issue and a massive lie at the same time - this issue doesn't appear when NOT using the mod manager at all. The mod works fine." So I guess everything is fine.
Logged

k-two

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: 1.2.3.3 Combat Extended - Invalid.package.id
« Reply #4 on: December 09, 2020, 11:01:45 AM »

hey i have a lil question i try to find CE and i can not find it for non steam wersion any one know where can i find it ? im new on the platform so i dont know how to make my own question sorrry :P
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9714
  • Refugee
    • View Profile
Re: 1.2.3.3 Combat Extended - Invalid.package.id
« Reply #5 on: December 09, 2020, 11:56:34 AM »

Logged

Pheanox

  • Global Moderator
  • Colonist
  • ****
  • Posts: 567
  • Refugee
    • View Profile
Re: 1.2.3.3 Combat Extended - Invalid.package.id
« Reply #6 on: December 16, 2020, 10:54:57 AM »

I am moving this to the modded bugs forum.
Logged