Ludeon Forums

Ludeon Forums

  • April 18, 2021, 05:32:12 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Strange Harmony (maybe?) bug logs and mods not working.  (Read 167 times)

Kv1_Desempregado

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Strange Harmony (maybe?) bug logs and mods not working.
« on: February 11, 2021, 09:46:57 PM »

I was playing with tons of mods for some time, and I decided to add SRTS to my game, but this caused RimWorld to load forever, I deleted SRTS expanded, because I believed he was having some sort of inconpatibility with other mod. Anyway, now, when I load my mods (that were working fine) the game will start showing lots of Harmony related errors, and the mods wont work. I have no ideia if this is related to the deletion of SRTS (even though I never got to use it), so I came here for help. Here are the erros that show up on the logs:
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9906
  • Refugee
    • View Profile
Re: Strange Harmony (maybe?) bug logs and mods not working.
« Reply #1 on: February 12, 2021, 03:12:07 AM »

Hi,
next time please just post the original rimworld player.log (button at the option to show the file location) or when you use hugslib too use the green button "Share logs" or press CTRL-F12.

When you delete a mod folder it can't affect any other mod normaly, beside to add or modify some config settings while the mod was active.
You can delete all the config's (same area you can find the player.log) maybe just rename the Config folder into _Config at example. But i don't think it would change anything.

I suggest that you disable all mods and rebuild a minimal modlist.
Harmony,hugslib.
When you don't got error's try to delete Harmony too, and reinstall it. Maybe it got corrupt at some way.
Then add some other mods, and when no error's happen add the remaining mods.

Btw. you should delete old mods like "Combat Extended Guns". The  "missing packageId" is a sign that it isn't made for Rimworld 1.2.
« Last Edit: February 12, 2021, 03:13:51 AM by Canute »
Logged

Kv1_Desempregado

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: Strange Harmony (maybe?) bug logs and mods not working.
« Reply #2 on: February 12, 2021, 11:51:27 AM »

Hi,
next time please just post the original rimworld player.log (button at the option to show the file location) or when you use hugslib too use the green button "Share logs" or press CTRL-F12.

When you delete a mod folder it can't affect any other mod normaly, beside to add or modify some config settings while the mod was active.
You can delete all the config's (same area you can find the player.log) maybe just rename the Config folder into _Config at example. But i don't think it would change anything.

I suggest that you disable all mods and rebuild a minimal modlist.
Harmony,hugslib.
When you don't got error's try to delete Harmony too, and reinstall it. Maybe it got corrupt at some way.
Then add some other mods, and when no error's happen add the remaining mods.

Btw. you should delete old mods like "Combat Extended Guns". The  "missing packageId" is a sign that it isn't made for Rimworld 1.2.

Ok, thank you for the advice.
Logged