Ludeon Forums

Ludeon Forums

  • December 05, 2022, 08:36:32 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: [1.3 Beta] UI vanish after assigning med carry  (Read 804 times)

MrBright01

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
[1.3 Beta] UI vanish after assigning med carry
« on: July 04, 2021, 08:53:34 PM »

Version: 1.3.3050

Circumstances: Set pawns to carry 1 medicine

Expected: Pawns grab medicine

Result: Pawns cease all movement while attempting to grab medicine. UI for controls vanish, but UI for details and escape key popup remains.

Steps: Assign all pawns to carry 1 medicine.

Pre-bug save: https://drive.google.com/file/d/1q9wcUeri3BJDwHdC89gsLO1hTQaYbJ2Q/view?usp=sharing

Post-bug save: https://drive.google.com/file/d/1hOPXNCUbME6Y7jCCLsIb-Wa9owQ-1vQB/view?usp=sharing

Log: https://docs.google.com/document/d/1hSIxqz0H5PPdx7_oTCZjVw9X-KzsLd8q-YEvnYap8II/edit?usp=sharing

Log was copy/pasted because for whatever reason the actual notepad file would not upload.

When setting my pawns to carry 1 medicine, the UI vanishes. Clicking on an item in world (pawn, work table, ect) shows detail screen, but no options to interact.
« Last Edit: July 04, 2021, 08:55:10 PM by MrBright01 »
Logged

Flu007

  • Muffalo
  • *
  • Posts: 7
  • Refugee
    • View Profile
Re: [1.3 Beta] UI vanish after assigning med carry
« Reply #1 on: July 05, 2021, 11:07:55 AM »

Same for me.

In my case, I set one pawn to carry some herbal, while they were sleeping. The UI vanshing thing happened as soon as they woke up. The pawn is also stuck on the task. (not moving, task line pointing at the herbal meds in stockpile)


save file
https://www28.zippyshare.com/v/jGh9eHFi/file.html

player.log
https://www28.zippyshare.com/v/8at5hGtx/file.html

« Last Edit: July 05, 2021, 11:32:11 AM by Flu007 »
Logged

AugustusLemonade

  • Muffalo
  • *
  • Posts: 1
  • Refugee
    • View Profile
Re: [1.3 Beta] UI vanish after assigning med carry
« Reply #2 on: July 05, 2021, 01:38:51 PM »

In my experience assigning 3 medicines also caused this issue. So, I don't think the number matters? It can be reverted by returning to main menu, loading the save game, pausing the game as soon as it loads and setting the number back to 0.
Logged

MikeLemmer

  • Colonist
  • ***
  • Posts: 468
  • Refugee
    • View Profile
Re: [1.3 Beta] UI vanish after assigning med carry
« Reply #3 on: July 05, 2021, 02:55:02 PM »

I had something similar happen to me after I assigned meds to a colonist. Reloading the save seems to have cleared it up.

UPDATE: Reloading the save did not clear it up. Exact same bug happened the moment I undrafted my colonist and he went for the meds.

Uploaded the save here. Just DL it, unpause it, and redraft/undraft the colonist standing still in the bedroom to replicate the bug.
https://www94.zippyshare.com/v/Z02scTnD/file.html
« Last Edit: July 05, 2021, 03:27:58 PM by MikeLemmer »
Logged

modestalchemist

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.3 Beta] UI vanish after assigning med carry
« Reply #4 on: July 05, 2021, 02:56:38 PM »

Same issue.
the UI is invisible, but it seems to still work. clicking on the screen where the buttons usually are brings up the appropriate menus. reassigning 0 meds to carry does not fix.

new game - no mods installed
Logged

Jan2607

  • Colonist
  • ***
  • Posts: 389
  • Refugee
    • View Profile
Re: [1.3 Beta] UI vanish after assigning med carry
« Reply #5 on: July 05, 2021, 03:23:16 PM »

Same for me. Set pawns to carry 2 medicine. After a few seconds, the UI was gone and only my first colonist is shown in the bar. After reloading, it works for a few seconds, then breaks again. No mods installed.
Logged

Shinbu150

  • Muffalo
  • *
  • Posts: 1
  • Refugee
    • View Profile
Bad: Bug 1.3 UI Disappears and Pawns Stuck
« Reply #6 on: July 05, 2021, 04:53:57 PM »

I did several things a few seconds before this bug happened but I believe it is because I assigned them to carry medicine while drafted. They seem to be stuck trying to pick up the medicine. Clicking on the pawn causes the UI to disappear and tooltips to freeze on screen.

Order of events:
1) 1 person raid came in.
2) My colonist was using a lead at the time to bring an animal to a pen.
3) I recruited them while they were using a lead.
4) Fought the raid.
5) Assigned them to carry medicine.

For some reason the website wont let me upload the save game even though it's only 7mb...
Logged

MrBright01

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: Bad: Bug 1.3 UI Disappears and Pawns Stuck
« Reply #7 on: July 05, 2021, 09:02:55 PM »

It's the medicine pickup assignment. Posted elsewhere with saves and logs, but even without the raid and/or the animal leads, it does the same thing when you assign them to carry meds.

Also, the limit on files for the website is 600kb, so you'd have to host the files elsewhere, as mentioned in the sticky on how to report a bug.
Logged