[1.3.3055] Screen Rapidly Flickering When Unpaused

Started by Meitana, July 09, 2021, 01:56:48 PM

Previous topic - Next topic


1. What the circumstances were.

The new game update dropped and I loaded into the game. I had been playing fine earlier today before this new version was downloaded

2. What happened.

As soon as the game loaded and was unpaused, the screen started flickering between showing the game and showing a black screen multiple times a second. This was running in windowed mode, so I changed to fullscreen; the flickering still occurred. I saved the game in fullscreen settings, exited, and restarted; the flickering still occurred.

3. What you expected to happen.

The game to be running as it was earlier, with no flickering

4. Steps we can follow to make the bug appear on our machine. This part is important! We need a set of steps which we can follow to get the same results you're seeing. Ideally you'll test these steps to make sure they work from scratch.

As stated above, load into the game on the 1.3.3055 version. There is a possibility this is because of specific graphics card/driver settings, so I have attached my log file which includes this info

5. Savegame file

Attached as 'West Toentuay 1b.rar'.


i have same thing, except menu bar and colonist names arent flickering



It's not deleting the dumping stockpile that does it: it's removing the permissions to have corpses in a stockpile (which, if you've got a dumping stockpile set to allow rotting corpses, will solve the issue).

For me, the flickering persisted even when I deleted my dumping stockpile; only when I deleted both that and my fridge stockpile zone did the flickering cease. Re-adding the fridge zone with all the prior permissions started the flickering; disallowing all corpses solved the issue, but allowing even one type of corpse back in resumed the flickering.


I am also getting the flickering now since the update, but have an 11 day rain storm from a quest I began last night before the latest patch, and thought it might've been related.


For me the flickering was fixed when I deleted my "allow only fresh animal corpses" stockpile. After I verified that the flickering was gone, I re-created the stockpile and the issue did not happen again. So for me re-making the stockpile was the fix.


As others have mentioned, this seems to be an issue with corpses. If a corpse is in a stockpile zone AND allowed to be in that zone, flickering occurs. If either of those conditions is false, there is no flickering. I also noticed that checking/unchecking "animal corpse" in the allow list has strange behavior. I tried to check it, but it turned into a ~ instead -- some checked and others didn't. Couldn't figure out the rhyme or reason for that, though.

In case it helps, I've attached my logs to this post. Also, here is link to my save file:
URL: https://mega.nz/file/lVcT3a6I
Decryption Key: YH2EAaGS2Ixk4s9GePb3r0Imj4rSvZg4mvXowS59NUI


Confirmed that removing corpses from my stockpile stopped the flickering.

Moderator note:

This bug was resolved already earlier this week.