Help with UI disappearing

Started by Shadowblight, August 08, 2021, 02:34:28 AM

Previous topic - Next topic


Hi folks,

I have quite a lot of mods I'm running, and normally it works okay, but there's been some weird issue where my UI keeps disappearing after I have a rescuee join my colony. It basically just makes the bottom bar and the buttons go completely missing. I tried to disable the obvious stuff, like maybe RimHUD, but nothing seems to work. Can someone look at my log to maybe give me a better idea what's causing it? I am afraid this is rather long and looks all like greek to me...


disable all mods that give startup errors, it's just waste of time trying to debug your build when you obviously have mods for wrong version.


Hi thanks for responding!

I did complete an audit, and found one mod where I'd subscribed to apparently the 1.3 version for it, but an old one was blocking it from taking effect (Where is my weapon), so I fixed that. I saw the Doors Expanded says only 1.2 compatible, but at the same time I'm not really using any on this map. I could remove it easily, though I don't see how this would affect anything to do with pawns. I didn't see any others.

Something else I noticed was that the pawn in question had a skill in Plants that somehow looked weird and seemed to be counting down. Like it was saying 11.-02 or something. And when I killed the pawn and res'd them with the resurrect tool, they seemed to reset, and the UI began to work again. I don't know if it's related to one of the trait mods I have maybe? The trait mods are one of the things I definitely threw on this run that I'd never tried before.

Can you help me to know what mods are "startup errors"? Because my list is long, I'm not sure what I'm looking at.



it's difficult to explain abstractly

let's pick very first startup error, your guess what mod cause it?
Could not find type named VFECore.Misc.EquipmentOffsetConditions from node <li Class="VFECore.Misc.EquipmentOffsetConditions"><techLevels><li>Neolithic</li><li>Medieval</li></techLevels></li>
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)


QuoteCan you help me to know what mods are "startup errors"? Because my list is long, I'm not sure what I'm looking at.
Maybe take a look at the of my signature.