Ludeon Forums

Ludeon Forums

  • November 28, 2021, 10:17:22 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: game fails to load after 10 minutes with unity screen right before crash.  (Read 256 times)

Spoula

  • Muffalo
  • *
  • Posts: 5
  • Refugee
    • View Profile

i was screwing with the character editor mod last night when my game crashed and has since refused to open with my current modlist. it runs fine if i remove the mod config files, which disables the mods and launches the basegame. ive tried editing my modlist but ive had no luck and i really dont want to spend hours trying trial and error to fix it. ive checked the crash files and with my lobotomite brain ive figured its a memory issue, but i cant make sense of what mod it causing it. if anyone can look through them and tell me what mod (or mods) to take off my list i would appreciate it. if you need the crash dump file or modlist i can give you that (if you tell me how, theres probably over a hundred mods in there). if the mod is in important one like character editor id like to try to fix the issue with the mod rather than just remove it. any help or advice would be appreciated. thanks for your time!
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile

Hi,
could it be that you still use a 32bit windows or the 32bit rimworld ?
I saw
"Could not allocate memory: System out of memory!"
that could the reason for the crash then.
Use the 64bit rimworld when you got a 64bit OS, or
use less mod's, smaller world and map to decrease the memory usage.

Spoula

  • Muffalo
  • *
  • Posts: 5
  • Refugee
    • View Profile

my system is 64bit, also pretty sure my rimworld is 64bit. the mods were running fine until something caused a crash and caused the list to no longer work. i would try using a smaller map and world but like i said the game wont even launch. i would use fewer mods but i need to know which mods are causing the issues because id rather not brute force my way through. thanks for the response though, i appreciate it!
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile

Ok,
since you use all 64bit you can scratch the smaller map/world thing, i don't think that got any influence.
Must be another issue about the out of memory.

To reset the modlist, you should delete the ModConfig.xml at the Config folder (same area the savegame are).
But i can't say which mod would cause the problem.

Spoula

  • Muffalo
  • *
  • Posts: 5
  • Refugee
    • View Profile

thanks, ill keep looking into it
Logged