[1.3] UI bottom bar disappears when specific area is in view + more issues

Started by Gap, December 23, 2021, 04:44:36 PM

Previous topic - Next topic


Right after a tribal raid was stopped by deadfall traps, the bottom bar of my UI disappeared. I usually play with various quality of life mods, mostly UI-related, so I uninstalled them all but the problem persisted.

After some additional testing, I realised the UI does reappear and work as intended as long as a specific area (a few tiles high and wide) is not in view. I suspected it only disappears if specific items or corpses are visible. I have tried framing the affected area (in the middle of the top line of deadfall traps) more accurately with a series of screenshots available here: https://drive.google.com/drive/folders/1UvR5uF-EG27zR004jotfyngT1dStfjm4?usp=sharing

The save is here on my Google Drive: https://drive.google.com/file/d/1OPRL0bqG43TAAcEOLfUh0daHP0lOId90/view?usp=sharing

I have just checked the log, and items named "Mosquito" and "Caamb" seem to cause problems. I suspect these are 2 tribal raider corpses in that corridor. The log file is here: https://drive.google.com/file/d/11M_wW7DbPvbnNJnb_lUw2GO1hiZmyhgN/view?usp=sharing

Since I am almost done constructing the ship I would really appreciate any suggestion for repair.

PS: I am only playing vanilla, no DLC.


EDIT: Ah even though the UI reappears if the area is not in sight, I apparently can't select any item/pawn/etc in game by clicking on it. Dragging over an area does allow me to select items, pawns, etc.

ADDITIONAL ISSUE: Colonists run in fear as if an enemy was still there when they try to get to the bodies to drag them to the corpse stockpile! I will add a picture to the folder in a second.


So I think I have solved the issue (will post again if not) by using dev mode to destroy the contents of the bugged tile. Apparently there were 3 corpses (or 2 corpses and a living mob) on the same tile.

Anyway, thanks for a great game - still enjoy it after 3 years even without any DLC :)


Thanks for the report and glad you figured it out.  Let me know if you have this problem again.  I can't really test the game modded, because even qol mods can cause bugs that people report, that they wouldn't expect.  Trust me, I know from experience from not believing a bug could be from a certain mod, and narrowing it down to that one through testing.  But I'll keep an eye out on my other testing to see if it occurs.