(1.3.3159 + Both) Received bugged Covert Complex Investigation mission

Started by Etheran, November 29, 2021, 05:47:36 PM

Previous topic - Next topic

Etheran

Hi,

I was playing a game of RimWorld and had completed a single relic information mission, a subquest of 'The Ideo-Pendant of Reformed Justice', when another relic information mission appeared that was bugged.  It's called a 'Covert Complex Investigation' and is (as far as I can tell) uncompletable.  It has the entire raw string template with the variable names, including the 'ERR:' prefix.

It happened quite a while ago in-game (6 years or so) and I hoped it would somehow resolve itself but it hasn't and has prevented the completion of the parent quest.

I've uploaded the 28mb save file here: https://infiniteecho.ca/rimworld/rws.rws

Let me know if there's more information I can help out with.

Thanks,
Etheran

Canute

Hi,
when you use Steam you can try to switch to the unstable/beta version.
Just to check if these error is allready fixed.

Etheran

Hi Canute,

Thanks for checking.  Loading the save in the unstable version didn't fix the quest.  I played for a bit but nothing ended up changing with this issue.

Thanks,
Etheran

Etheran

Although... I'm definitely selecting the unstable build in Steam and 'RimWorld' is changing to 'RimWorld (unstable)' but I can't see any difference when I run the executable (through Steam or directly).  And checking the logs it looks like the same version is being run regardless of whether I have 'unstable' selected.  I'm unsure if I'm doing something wrong or if the unstable branch is currently just the latest release?

Thanks for any help.

Etheren

Ark

Right now unstable is the same as the release version. 1.3.3200 was released yesterday.
https://store.steampowered.com/news/app/294100/view/3137316801198575089
https://game-updates.info/rimworld

In Options, enable Development mode.
In Quests tab, select active quests, "The Ideo-Pendant of Reformed Justice", check Dev: Debug, Remove Active QuestPart, Generate QuestPart.
Disable Development mode, accept the new quest.

Etheran

Thanks, Ark!  Worked well and after I deleted it I had to create and finish subquests to get to 4/5 quests but that worked, too.

Pheanox

Thanks for the bug report and we apologize for the inconvenience with the quest.  Thanks a lot for uploading the save, I'm currently collecting as many of these as we can so our devs can figure out the bug and fix it once and for all.  I'll add this to our list.