Ludeon Forums

Ludeon Forums

  • July 04, 2022, 04:40:59 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: [1.3.3200] ideo edit page error can't edit the idology in reforming  (Read 606 times)

demonpeen

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile

I'm getting this error and can't reform the ideology. Its some null exception. the results is that half the window doesn't render and i can't interact with the invisible unrendered portion (sometimes). But in this case when i hit reform, the game kinda freezes and the debug log goes crazy. Nothing works on the invisible portion and the screen won't pop up when i hit reform.

Exception filling window for RimWorld.MainTabWindow_Ideos: System.ArgumentNullException: Value cannot be null.
Parameter name: key
  at System.Collections.Generic.Dictionary`2[TKey,TValue].FindEntry (TKey key) [0x00008] in <eae584ce26bc40229c1b1aa476bfa589>:0
  at System.Collections.Generic.Dictionary`2[TKey,TValue].ContainsKey (TKey key) [0x00000] in <eae584ce26bc40229c1b1aa476bfa589>:0
  at RimWorld.IdeoStyleTracker.StyleForThingDef (Verse.ThingDef thing, RimWorld.Precept precept) [0x00000] in <cdbd0ed5089a418da09b9a259f9dbd8f>:0
  at RimWorld.Ideo.GetStyleAndCategoryFor (Verse.ThingDef thingDef) [0x0003a] in <cdbd0ed5089a418da09b9a259f9dbd8f>:0
  at RimWorld.Ideo.GetStyleFor (Verse.ThingDef thingDef) [0x00000] in <cdbd0ed5089a418da09b9a259f9dbd8f>:0
  at RimWorld.Precept_Apparel.DrawIcon (UnityEngine.Rect rect) [0x00000] in <cdbd0ed5089a418da09b9a259f9dbd8f>:0
  at RimWorld.Precept.DrawPreceptBox (UnityEngine.Rect preceptBox, RimWorld.IdeoEditMode editMode, System.Boolean forceHighlight) [0x0045e] in <cdbd0ed5089a418da09b9a259f9dbd8f>:0
  at RimWorld.IdeoUIUtility.DoPreceptsInt (System.String categoryLabel, System.String addPreceptLabel, System.Boolean mainPrecepts, RimWorld.Ideo ideo, RimWorld.IdeoEditMode editMode, System.Single& curY, System.Single width, System.Func`2[T,TResult] filter, System.Boolean sortFloatMenuOptionsByLabel) [0x00f27] in <cdbd0ed5089a418da09b9a259f9dbd8f>:0
  at RimWorld.IdeoUIUtility.DoPrecepts (System.Single& curY, System.Single width, RimWorld.Ideo ideo, RimWorld.IdeoEditMode editMode) [0x00216] in <cdbd0ed5089a418da09b9a259f9dbd8f>:0
  at RimWorld.IdeoUIUtility.DoIdeoDetails (UnityEngine.Rect inRect, RimWorld.Ideo ideo, UnityEngine.Vector2& scrollPosition, System.Single& viewHeight, System.Boolean editMode, System.Action`1[T] ideoLoadedFromFile, System.Boolean allowLoad, System.Boolean allowSave, System.Boolean reform, System.Boolean forArchonexusRestart) [0x001d1] in <cdbd0ed5089a418da09b9a259f9dbd8f>:0
  at RimWorld.IdeoUIUtility.DoIdeoListAndDetails (UnityEngine.Rect fillRect, UnityEngine.Vector2& scrollPosition_list, System.Single& scrollViewHeight_list, UnityEngine.Vector2& scrollPosition_details, System.Single& scrollViewHeight_details, System.Boolean editMode, System.Boolean showCreateIdeoButton, System.Collections.Generic.List`1[T] pawns, RimWorld.Ideo onlyEditIdeo, System.Action createCustomBtnActOverride, System.Boolean forArchonexusRestart, System.Func`2[T,TResult] pawnIdeoGetter, System.Action`1[T] ideoLoadedFromFile, System.Boolean showLoadExistingIdeoBtn, System.Boolean allowLoad, System.Action createFluidBtnAct) [0x00167] in <cdbd0ed5089a418da09b9a259f9dbd8f>:0
  at RimWorld.MainTabWindow_Ideos.DoWindowContents (UnityEngine.Rect rect) [0x00000] in <cdbd0ed5089a418da09b9a259f9dbd8f>:0
  at Verse.Window.InnerWindowOnGUI (System.Int32 x) [0x001ce] in <cdbd0ed5089a418da09b9a259f9dbd8f>:0
UnityEngine.StackTraceUtility:ExtractStackTrace ()
Verse.Log:Error (string)
Verse.Window:InnerWindowOnGUI (int)
UnityEngine.GUI:CallWindowDelegate (UnityEngine.GUI/WindowFunction,int,int,UnityEngine.GUISkin,int,single,single,UnityEngine.GUIStyle)

and this error too:
Mouse position stack is not empty. There were more calls to BeginScrollView than EndScrollView. Fixing.
UnityEngine.StackTraceUtility:ExtractStackTrace ()
Verse.Log:Error (string)
Verse.Widgets:EnsureMousePositionStackEmpty ()
(wrapper dynamic-method) Verse.Root:Verse.Root.Update_Patch1 (Verse.Root)
Verse.Root_Play:Update ()
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: [1.3.3200] ideo edit page error can't edit the idology in reforming
« Reply #1 on: January 10, 2022, 03:21:10 AM »

Hi,
since you use mods, i see these"Update_Patch1", it sould be a problem from one of your mods.
So it is impossible to say where the problem are.
Be sure you don't have error's at the startup before you load a savegame. The error don't give any hint about a mod, so try to disable all mod's that are save to disable.

demonpeen

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.3.3200] ideo edit page error can't edit the idology in reforming
« Reply #2 on: January 11, 2022, 10:39:29 PM »

update 1) I have a sinking suspicion its an interaction in vanilla expanded framework. rimthreaded was having issues with dubs bad hygiene-- but the screen issue seems to have no easily identifiable source. I removed all mods it remained on a loaded save. on a fresh save its gone-- regardless of mods. still loading in mods. half already done, none related to vanilla expanded.

update 2) added most mods, notable exceptions are anything vanilla expanded, runtime gc, rim73 performance booster, rim threaded, and lastly sos2. bug not reproducible.

update 3) added everything but rim-thread and vanilla expanded stuff. still not reproduced

update 4) added all of vanilla expanded stuff but not rim threaded. still not reproduced.  not going to test rim threaded cause that has other bugs as of current build time and didn't have it during time of bug in question.

conclusion: i have no idea what caused the bug. Its neither a mod nor an interaction with one.

 Hypothesis-- i was having extreme problems with vanilla expanded framework, vanilla expanded out posts, and vanilla expanded ancients and repeatedly reported to them issues and bugs. the solution was to unsub and resub. and the issue only extends to old saves. before i found the issue of VEF/VEOP/VEA being the culprits I thought it was other mods and unsubbed and removed many i was not utilizing anymore. and perhaps the save is looking for something that doesn't exist anymore? will try loaded save and see if issue persists... tested and still bugged. So save is broken and issue is some missing interaction.

Logged