Ludeon Forums

Ludeon Forums

  • July 02, 2022, 04:52:29 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Modded with only 2 to 4 fps  (Read 491 times)

T3sCoconuts

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Modded with only 2 to 4 fps
« on: January 26, 2022, 09:48:49 PM »

Hi all,
So I have my rimworld modded, currently I have around 150 mods though this issue happens even if I have 5 mods

When I start a new game, I have around 20 fps with in a 20 to 40 Min my fps drops down to 10
At this point I still have only 3 pawns and around 4 to 10 animals,
I use clean up mod, it improves for a little,

This is on a normal map most of the time on 30% with extra clans, though this is great same if I max out my map size at 100% world map?

Going to try a a preformace mod, but other then that I'm not sure what's wrong,

My computer is pretty strong, I get that rimworld can only run on 1 core though I ha e 4.3ghz 8 cores 32gb ram and a 3080

Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: Modded with only 2 to 4 fps
« Reply #1 on: January 27, 2022, 03:56:47 AM »

Hi,
even with 150 mod's you shouldn't except such a heavy fps loose.
Some people playing with 300-400 mods pretty well.

Mosttimes the issue for that is a mod that cause error's and the error outputs slow down the fps. Special repeating errors.
Now the question, do you have error's at Rimworld startup ? You should eliminate these first. Maybe read the 2.link of my signature.
When you still geting error's during gameplay later, maybe these error's give you some help to identify the mod, then you should either kontakt the author of that mod, don't use that mod or live with that error.

Samapple31

  • Drifter
  • **
  • Posts: 71
  • Little Apple
    • View Profile
    • Semantic Mediawiki
Re: Modded with only 2 to 4 fps
« Reply #2 on: January 27, 2022, 04:03:18 PM »

This was exactly the same thing as mine!
Logged
Born with pleasure and patience.

T3sCoconuts

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: Modded with only 2 to 4 fps
« Reply #3 on: January 29, 2022, 01:30:42 AM »

Hi,
even with 150 mod's you shouldn't except such a heavy fps loose.
Some people playing with 300-400 mods pretty well.

Mosttimes the issue for that is a mod that cause error's and the error outputs slow down the fps. Special repeating errors.
Now the question, do you have error's at Rimworld startup ? You should eliminate these first. Maybe read the 2.link of my signature.
When you still geting error's during gameplay later, maybe these error's give you some help to identify the mod, then you should either kontakt the author of that mod, don't use that mod or live with that error.

I I do get the error message, though it's for only 1 mod, thing is that mod I put in after the issue started, still working on that mod though trying to work out why I'm getting error

Sorry for the late reply been working on my studio all week and have not been able check replys
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: Modded with only 2 to 4 fps
« Reply #4 on: January 29, 2022, 04:09:52 AM »

Quote
still working on that mod though trying to work out why I'm getting error
When you got expierence with modding sure you can do it.
And when you identify the mod, you should try at first to use it with that mod only or at last minimal mods, to be sure there is no conflict with other mods.

Otherwhile i just would report it to the mod author, he know his mod mosttime better then you.

Would you mind to share a log ? When you use hugslib too, just use the green Share log button after you loaded the savegame and played a few mins and post the link.
That include the modlist,patchlist and the log.

Or just file attach the player.log (need to use Reply to see file attachment options).