Grey screen bug

Started by uzzi44, March 26, 2022, 03:06:57 PM

Previous topic - Next topic


Hello. I haven't played Rimworld in a long while and I decided to give it a go a few days ago with my roughly 200 installed mods. Everything was working well until a few hours ago some issues started to arise, one of them being a grey screen whenever I load a save, I've found a workaround which is just reloading the save until it loads without a grey screen but I'd rather just get to the bottom of the cause so I won't have to do that. Now, I tried looking into the logs to find out what's causing issues and it has worked to some degree as I got to eliminate several problem causing mods but doing so didn't fix the grey screen. I suspect one of the mods conflicting or having the wrong load order. The logs still show a bunch of errors but I've been unable to decypher and figure out exactly what they are pointing at, thus, I'm coming here in the hopes that somebody more experienced with reading Rimworld logs would kindly help me out by taking a quick look.

Grey screen:



i think the grey screen come's from the repeating error
QuoteRoot level exception in Update(): System.NullReferenceException: Object reference not set to an instance of an object
  at Verse.GlowFlooder.AddFloodGlowFor (Verse.CompGlower theGlower, UnityEngine.Color32[] glowGrid) [0x0001f] in <360933dd75ad47e8a6d2a631ae77b5d8>:0
  at Verse.GlowGrid.RecalculateAllGlow () [0x000ad] in <360933dd75ad47e8a6d2a631ae77b5d8>:0
  at Verse.GlowGrid.GlowGridUpdate_First () [0x00008] in <360933dd75ad47e8a6d2a631ae77b5d8>:0
  at (wrapper dynamic-method) Verse.Map.Verse.Map.MapUpdate_Patch3(Verse.Map)
  at Verse.Game.UpdatePlay () [0x00031] in <360933dd75ad47e8a6d2a631ae77b5d8>:0
  at Verse.Root_Play.Update () [0x00032] in <360933dd75ad47e8a6d2a631ae77b5d8>:0 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)
when i search for flood i found at the patchlist
QuoteFloodFiller.FloodFill: PRE:
  • RimThreaded.FloodFiller_Patch.FloodFill
so i think it is a problem with RimThreaded.
Try to ask at the RimThreaded-discussion about it.


I get the same thing except it mostly happens, really without exception when I leave my map with all of my colonists. If one stays behind it doesnt happen, but if all leave i get that screen. Cant even load it afterward have to restart.