Ludeon Forums

Ludeon Forums

  • July 04, 2022, 06:18:08 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Caravan doesnt move on the world map  (Read 255 times)

Ruisuki

  • Planetologist
  • ****
  • Posts: 1009
  • Anti?
    • View Profile
Caravan doesnt move on the world map
« on: April 18, 2022, 12:19:06 PM »

1a) After a certain point I became no longer able to travel with a caravan. Any caravans built, with any combination of my 9 colonists linger outside in the adjacent tile to my settlement. While I can use devmode to travel this is not ideal. If I have all of my colonists leave the colony (even if done in groups or one at a time) I get a gray screen and cant even load afterward so I must reboot. https://cdn.discordapp.com/attachments/319678499118120960/965571951601000458/unknown.png

1b) Additionally, the music no longer plays. When i first noticed it I didnt think it a big deal but I did load an earlier save and noticed this wasnt affected. Unfortunately I kept going with the affected file. That said idk if it would have eventually ended up like this anyway.

1c) Lastly the map itself is a problem. I noticed enemies and hostile wildlife sometimes disappeared when fighting me. I recently found out they were still in my map when my colonists drew their weapon and shot at seemingly nothing. I used dev mode to kill by clicking in the general direction. Once dead, their bodies appeared. That said there are still a couple areas near and inside the edge of the colony map where my colonists cant move towards even when drafted. If I somehow do manage to pathfind to these areas they themselves disappear, and I cannot get them back out of whatever they are stuck in.

2) I expected to be able to travel with caravans and not have the map cause these weird hiccups. There seems to be instances where old hostiles are trying to reach me and cause a constant ticking based on what I can decipher from the logs. That and unable to draw an object, im guessing the raiders themselves.

3) Partial Solution - I did figure out that by abandoning the map I am able to get the game back to normal. Not only does the music immediately come back on, but all of my caravans suddenly are able to move. Unfortunately this means leaving behind all colony progress and no confirmation whether this issue will just travel with me to another base eventually

I have since tried a few things. veryifying games integrity on steam, cleared my config files, resorted all mods once manually and now through rimpy manager, downloaded all your base, and have prayed to the rimgods. Ive attached my modlist, save and config files below
https://drive.google.com/file/d/1sJMQmE6k7BAmXsbr3sviSZ78BwVjmS46/view?usp=sharing
https://drive.google.com/file/d/1IhQQGXvFLdcXRnNOvVnkiorlEdMz3-oy/view?usp=sharing
https://gist.github.com/5b72ddefa330b8d0053edf20f0857a71
Logged