RimWorld has no problem creating new game, can't load saves of any kind (modded)

Started by Celstar, October 14, 2023, 01:35:21 PM

Previous topic - Next topic


As the title describes it, I am currently running RimWorld with 469 mods (the list of mods is as follows: https://pastebin.com/y3xwWd73 )

The crash log is at the end.

I have every DLC active, and I can't possibly think of any hard incompatibility issue that could cause the saves to break in this way (I have no mods that change core features like Combat Expanded or anything that modifies the save mechanics). The game has no problem starting a new game, colonists act as normal, there are no texture issues, nothing, the game runs as it should. It saves like normal, plays like normal, and all's good. But whenever I try loading a save, the game will take ages loading and then just crash before the game even loads. It's not a problem that affects only one specific save, as any saves created will have this problem. I can start a new game, save immediately as soon as it loads, go to the menu and try loading that save, and it will have this same problem. I have RimPy Mod Manager, and everything seems to be in the right order. It is important to note that if I try removing all mods, the game will load saves as it should. I have tried verifying the integrity of files on Steam, reinstalling every single mod, every single game file and even ModsConfig.xml, but nothing seemed to fix the issue. I've never seen any other post complaining about this sort of crashing specifically, so I am really feeling lost here. If anyone could provide any insight into this, I'd be incredibly thankful.

The crash log is here:


TL;DR: Game has no problem starting new game, but crashes when I try loading saves. Tried reinstalling everything and that didn't solve it. Help.