[W|0.8.651] Weird bug with the new crafting system

Started by Madcat, December 11, 2014, 06:19:35 AM

Previous topic - Next topic

Dr. Z

I run into a similar bug were I ordered a muffalo parka and a devilstand button-down shirt. Crafter starts on parka, the while he was busy with other things someone took it in storage, then the crafter made the shirt, and then he started a new parka (only ordered one).
Prasie the Squirrel!

Darth Fool

In a perhaps related bug, I have had a crafter move an unfinished parka into a stockpile, at which point, the tailoring table was no longer usable.  I tried building another tailoring table and it would also allow me to add bills, but when right clicking on it would get no ability to assign someone to the task and no statement about why I couldn't.


Damn, this is not good.

Can someone please post a save+world where this bug is about to occur?

Or some repro steps that work consistently and can be carried out from a new game?

Because I tried to make this happen, and it didn't.
Tynan Sylvester - @TynanSylvester - Tynan's Blog


Thank for the reply.

I managed to avoid the bug with keeping one colonist doing only crafting and one only doing art.
So i continued my game (year two now) but i will try to reproduce it.
Do you want a save with a fresh game or this one (year two)?

EDIT : I can't reproduce it on my year two game, crafters and artists can start multiple projects on one bench ,they don't drop unfinished projet to stockpile or start duplicate project... I will try to reproduce it on a new fresh game but i don't know if i have the time today.


Here is a save/s before the problem occurs for me.

[attachment deleted due to age]


Here are the saves during the bug and after the bug.  (the worker is gathering resources for a second artwork, without completing the first). 

[attachment deleted due to age]


Here is what I believe happened that caused this bug for the art.
Incomplete art gets taken to storage.
For some reason, art worker doesn't realize he/she has an incomplete work in the art storage.
Starts new work.


Were these situations where the art creator had gone a long time (>3 days) without working on the art?
Tynan Sylvester - @TynanSylvester - Tynan's Blog


I don't remember (I wasn't paying attention to the time it sat waiting for him to come back) .... but I think so.


Just want to confirm this bug. Currently having my 1xCreate Sword spawn multiple half-finished swords. Same with sculptures. Didn't occur to me it was happening until I realized my plasteel was almost all gone, so can't say how much time had passed or what exactly my crafters/art people had been up to before it happened. Did watch one crafter work on a sword, go eat, sleep, wake up and then grab fresh materials to start another sword.
"Oh boy, I can finally have my colonists paint the outer wall with Raider blood and hang a sign by the main door that says: "Looking for Donations"
I'm sure that'll make the Raiders feel welcome. :3" ~TheXIIILightning


Bug still present in Build 657.   :-\

I have 2 unfinished shirts by the same worker.


Quote from: Ford_Prefect on December 15, 2014, 10:26:00 PM
Bug still present in Build 657.   :-\

I have 2 unfinished shirts by the same worker.

If anyone can provide actual steps to reproduce this, I'd be very appreciative.
Tynan Sylvester - @TynanSylvester - Tynan's Blog


Odd I never ran into it during testing, doing most of the same things with production as now. I'll try to get it to break reliably tonight. 

Fairly sure It's not how it's happened to me during normal play, but I think got it to happen.
spawned some materials and built a tailor, set 2 bills for infinite parkas, each with different materials.

started one person crafting on one bill, then sent em elsewhere
started a second person on the second bill, then sent em elsewhere
reduced count on one of them to 0.
turned it back to infinite.
the unfinished item is now in a stockpile and the only option i get if i right click it with it's creator selected is to try and haul it.

Seems it's bill is set to 'null'



I tried two new games but i can't reproduce the bug.
I'm updating the game in 0.8.657 and I start a new game and see what happen.


I got this bug too. Very anoying wasting all those resources...