Ludeon Forums

Ludeon Forums

  • November 26, 2022, 10:12:06 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 [2] 3

Author Topic: [W|0.8.651] Weird bug with the new crafting system  (Read 8828 times)

Dr. Z

  • Colonist
  • ***
  • Posts: 751
  • Disciple of the one beeing ment to rule the galaxy
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #15 on: December 13, 2014, 06:24:12 PM »

I run into a similar bug were I ordered a muffalo parka and a devilstand button-down shirt. Crafter starts on parka, the while he was busy with other things someone took it in storage, then the crafter made the shirt, and then he started a new parka (only ordered one).
Logged
Prasie the Squirrel!

Darth Fool

  • Colonist
  • ***
  • Posts: 312
  • Refugee
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #16 on: December 14, 2014, 07:27:52 AM »

In a perhaps related bug, I have had a crafter move an unfinished parka into a stockpile, at which point, the tailoring table was no longer usable.  I tried building another tailoring table and it would also allow me to add bills, but when right clicking on it would get no ability to assign someone to the task and no statement about why I couldn't.
Logged

Tynan

  • Developer
  • Administrator
  • Transcendent
  • *****
  • Posts: 12484
    • View Profile
    • Tynan's Blog
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #17 on: December 15, 2014, 02:19:50 AM »

Damn, this is not good.

Can someone please post a save+world where this bug is about to occur?

Or some repro steps that work consistently and can be carried out from a new game?

Because I tried to make this happen, and it didn't.
Logged
Tynan Sylvester - @TynanSylvester - Tynan's Blog

Madcat

  • Muffalo
  • *
  • Posts: 4
  • Refugee
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #18 on: December 15, 2014, 05:30:44 AM »

Thank for the reply.

I managed to avoid the bug with keeping one colonist doing only crafting and one only doing art.
So i continued my game (year two now) but i will try to reproduce it.
Do you want a save with a fresh game or this one (year two)?

EDIT : I can't reproduce it on my year two game, crafters and artists can start multiple projects on one bench ,they don't drop unfinished projet to stockpile or start duplicate project... I will try to reproduce it on a new fresh game but i don't know if i have the time today.
« Last Edit: December 15, 2014, 06:05:25 AM by Madcat »
Logged

Ford_Prefect

  • Drifter
  • **
  • Posts: 83
  • Refugee
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #19 on: December 15, 2014, 12:51:46 PM »

Here is a save/s before the problem occurs for me.

[attachment deleted due to age]
Logged

Ford_Prefect

  • Drifter
  • **
  • Posts: 83
  • Refugee
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #20 on: December 15, 2014, 12:52:45 PM »

Here are the saves during the bug and after the bug.  (the worker is gathering resources for a second artwork, without completing the first). 

[attachment deleted due to age]
Logged

Ford_Prefect

  • Drifter
  • **
  • Posts: 83
  • Refugee
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #21 on: December 15, 2014, 12:55:11 PM »

Here is what I believe happened that caused this bug for the art.
Incomplete art gets taken to storage.
For some reason, art worker doesn't realize he/she has an incomplete work in the art storage.
Starts new work.
Logged

Tynan

  • Developer
  • Administrator
  • Transcendent
  • *****
  • Posts: 12484
    • View Profile
    • Tynan's Blog
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #22 on: December 15, 2014, 12:56:13 PM »

Were these situations where the art creator had gone a long time (>3 days) without working on the art?
Logged
Tynan Sylvester - @TynanSylvester - Tynan's Blog

Ford_Prefect

  • Drifter
  • **
  • Posts: 83
  • Refugee
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #23 on: December 15, 2014, 01:26:31 PM »

I don't remember (I wasn't paying attention to the time it sat waiting for him to come back) .... but I think so.
Logged

ShootyFace

  • Drifter
  • **
  • Posts: 88
  • Refugee
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #24 on: December 15, 2014, 03:17:54 PM »

Just want to confirm this bug. Currently having my 1xCreate Sword spawn multiple half-finished swords. Same with sculptures. Didn't occur to me it was happening until I realized my plasteel was almost all gone, so can't say how much time had passed or what exactly my crafters/art people had been up to before it happened. Did watch one crafter work on a sword, go eat, sleep, wake up and then grab fresh materials to start another sword.
Logged
"Oh boy, I can finally have my colonists paint the outer wall with Raider blood and hang a sign by the main door that says: "Looking for Donations"
I'm sure that'll make the Raiders feel welcome. :3" ~TheXIIILightning

Ford_Prefect

  • Drifter
  • **
  • Posts: 83
  • Refugee
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #25 on: December 15, 2014, 10:26:00 PM »

Bug still present in Build 657.   :-\

I have 2 unfinished shirts by the same worker.
Logged

Tynan

  • Developer
  • Administrator
  • Transcendent
  • *****
  • Posts: 12484
    • View Profile
    • Tynan's Blog
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #26 on: December 15, 2014, 10:54:31 PM »

Bug still present in Build 657.   :-\

I have 2 unfinished shirts by the same worker.

If anyone can provide actual steps to reproduce this, I'd be very appreciative.
Logged
Tynan Sylvester - @TynanSylvester - Tynan's Blog

Drahkon

  • Colonist
  • ***
  • Posts: 207
  • Refugee
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #27 on: December 16, 2014, 02:36:58 AM »

Odd I never ran into it during testing, doing most of the same things with production as now. I'll try to get it to break reliably tonight. 


Edit:
Fairly sure It's not how it's happened to me during normal play, but I think got it to happen.
spawned some materials and built a tailor, set 2 bills for infinite parkas, each with different materials.

started one person crafting on one bill, then sent em elsewhere
started a second person on the second bill, then sent em elsewhere
reduced count on one of them to 0.
turned it back to infinite.
the unfinished item is now in a stockpile and the only option i get if i right click it with it's creator selected is to try and haul it.

Seems it's bill is set to 'null'

https://drive.google.com/folderview?id=0BzbMtxHC8p0sMGYzVVpiT3Q4N0E&usp=sharing
« Last Edit: December 16, 2014, 05:15:34 AM by Drahkon »
Logged

Madcat

  • Muffalo
  • *
  • Posts: 4
  • Refugee
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #28 on: December 16, 2014, 08:14:37 AM »

I tried two new games but i can't reproduce the bug.
I'm updating the game in 0.8.657 and I start a new game and see what happen.
Logged

rizay

  • Drifter
  • **
  • Posts: 23
  • Refugee
    • View Profile
Re: [W|0.8.651] Weird bug with the new crafting system
« Reply #29 on: December 16, 2014, 09:58:53 AM »

I got this bug too. Very anoying wasting all those resources...
Logged
Pages: 1 [2] 3