Confused about "How To" Mod

Started by Koda Cakes, December 30, 2014, 05:48:40 PM

Previous topic - Next topic

Koda Cakes

Before anyone posts a bunch of links to the tutorials... I have already been reading them. I've never done any programming but that part looks rather simple and upfront so that's not the problem I am having. The only Mod I have ever made was creating a character in Skyrim which I found very simple but of course I understand this is a completely different game and different way to mod. From everything I have been reading it seems people are saying this is about the easiest game you could hope to mod and that sounds excellent. I would like to consider myself smart, just new to the exact process. I learn best from watching/visuals as opposed to reading a wall of text, so maybe I'm just overlooking something or misinterpreting someone's guide as I am human and prone to error :P

So to catch you up to where I'm at, I shall let you know what I have read and downloaded and then I shall let you know where I am stuck at...

*I followed the directions in this post
   -Unity Assets Explorer (downloaded, runs fine)
   -GIMP (downloaded, runs fine)
      +I did install the plug-in and extracted the files to the plug-in folder, however I have no idea as to whether the plugin is actually successfully RUNNING within the program...
    -Now we are at step 1 of the post, I open the program, click "Open Assets-file" and go to the proper file designation, highlight "resources.assets" and click open. Everything opens just fine, nice big list of info. I make sure the "Convert TEX to DDS" box is checked and click "Extract All". It starts extracting but along the way I get an error that says " "is not a valid integer value". So there lies my FIRST issue.

*Next issue: I figured I would start at the very beginning of the modding guides that people took the time to post like an obedient little nerd so I started here: I'm sure some of you laughed at how easy making something called a SIMPLE BLOCK is hahaha ;)
   -Notepad++ (downloaded, runs fine)
   -Created my mod's root folder, followed all steps without issue from creating the XML files, creating the simple object, etc.
   -Now my problem comes with the step "Creating resources"
      +Created the folders just fine (Textures, Things, and Building
      +Now the issue is at the PNG images... When I try to open any images in GIMP, I can't. I downloaded the textures pack that Tynan was kind enough to post and update here and there but I can't open any of them. I know that they are not currently PNG images, they are all PSD files. I googled how to open PSD files in GIMP and everyone is saying how you can do it so it sounds like I'm the only one having magical opening issues? Do I need to download something else to convert the PSD files into PNG images to be able to open them in GIMP? Or could the problem be that I never truly installed the plugin properly for GIMP so it's biting me in the butt now?

I hope I didn't confuse you all or draw this out. I figured if I labeled my steps people would see where I went and hopefully see my error with the information given. Please let me know if you need to know anything else.

I feel like it would be very helpful to others that learn quickly through visuals if there were video tutorials. I tried scrounging around google, the forums, and youtube for someone SHOWING themselves making a mod let alone setting up everything to even be able to start making mods but alas, Rimworld is too young for that still.

Thank you to all who take the time to read this and help out a hopeful modder-in-the-making!

Koda Cakes

Koda Cakes

UPDATE: I continued reading about my issue... I've read many theories including that a possible issue is that GIMP can't read "new" versions of PSD files?

Regardless, I opted to try out a solution that I found on this lovely forum of downloading IrfanView and batch converted the textures to PNG. Tried re-opening with GIMP and still nothing...?  ??? The error message I get is "Opening 'C:\Program Files (x86)\Bed_back.png' failed: Unknown file type"

So then I decided to download since I've heard it's good for beginners anyways and requires no plug-ins for this stuff and SUCCESS! I can open the texture images in no problem. So does that mean I just didn't download the plug-in correctly to GIMP? Or is there still a further issue I am overlooking in my n00bness?  ;D


Hmm, Gimp 2.8.14 "just works" for me on PSD files (well, generally speaking), and PNGs. I also use Inkscape to create vector images, which exports well to PNG.

Can you try creating a new 64x64 transparent image in Gimp, draw some squiggles, and then Export As > *.png, and see how that opens in Internet Explorer for instance?

What I like to do with modding is start with the absolute bare minimum and iterate on that, so in this case I'd copy a known, working PNG from an existing mod or somewhere and use that in your XML until it behaves, then tweak the image.

Koda Cakes

Thank you for the quick response. For whatever reason I can't get GIMP to open PSD/PNG files so I don't know why I'm having issues with that...

Okay Unifex, I did a test per your parameters and everything is fine until I hit save, then I get this error message from GIMP "The given filename does not have any known file extension. Please enter a known file extension or select a file format from the file format list."

Like I said in my last post, I did get everything up and running on so I have already begun messing around with editing PNG images and it's so easy I had to laugh at myself about it >.< I thought I was going to have problems making art on a computer program but my pillows on the royal bed I'm changing look just lovely! ;D

I do have one more question... I started out batch converting the PSD files into PNG images for using IrfanView (version 4.38). The first batch worked just fine. Converted the bed texture folder (from the texture pack Tynan released) just fine. I have the converted images for editing. But when I try to convert any of the others in the exact same fashion that I just had success with... nothing happens. It isn't creating anything. Nothing ends up in the destination folder I created for them. On a side note, when I go look in Tynan's original files there are only the PSD Files BUT when I use the batch converter to open those files, there are duplicate files that have been transferred over to PNG... but they are not accessible and are invisible to me unless I am trying to open files for batch conversion... It's weird and I appreciate any help!

Thanks again!
Koda Cakes


Hmm maybe registry corruption or something like that. I'd try running the free version of and see if the registry clean operation reports any oddities with the png extension.

I'm not sure on the other app, I can recommend ImageMagick though for batch image operations (I haven't used it under Windows but it should work. Don't think it does PSD files though, or at least I haven't tried).