Game runs, but has Black Screen and unable to open.

Started by ppants, December 01, 2017, 05:29:11 PM

Previous topic - Next topic


Already tried the fixes in  this thread ( Don't know if it's a resolution issue, but whenever I start up the game, I get this black screen, I'm unable to open the game (but if I hover over the icon in the bottom tray, I can see the game). Also, I'm somehow able to get the Steam overlay when I hit Shift+Tab. Music plays but I can't really do anything with the game.

Running this on Windows 10, and have a NVIDIA GeForce GTX 860M.

[attachment deleted by admin: too old]


I'm having the exact same issue after the latest windows update. I've tried deleting all Rimworld files and reinstalling it, didn't work.


Same issue. Windows update 1709 installed and now the game refuses to start with
"Screen: could not switch resolution (1920x1080 fs=1 hz=0)"

On checking more installed games, Pillars of Eternity and War for the Overworld have the same error. Could it be a Unity thing?


This could be an issue between the way that Windows 10 handles "full screen" programs, and the Unity rendering system.
This could also be an issue regarding the "power saving" mode of certain graphics cards.
(NVIDIA GTX 8XX and 9XX series cards especially, and several ATI Radeon cards which would be around 2 to 3 years old now.)

First, try running the game in windowed mode.
(Should run in windowed mode if you append -windowed or -popupwindow to the end of the "target" line in the properties of a shortcut. You may need to manually edit the preferences file though, and I forget what to change in there.)

If the issue still occurs, try disabling all power-saving features, both via the Windows power management, (set it to "High Performance" or the like,) and via the NVIDIA or Catalyst control panel. (NVIDIA uses GeForce Experience as the control panel for Windows 10, IIRC. ATI Catalyst was re-branded to another name IIRC.)


After all the other suggestions failed to change anything, I eventually found a fix. The issue (in my case) appears to have been Windows 10 enforced scaling which changed with update 1709. This was further complicated by having a laptop with an integrated+dedicated graphics card, which means the hierarchy of what causes the error was confusing. The issue was not solved by any of the previous solutions, by compatibility or start options.

The problem was solved by disabling scaling in graphic card options. But, due to the so called "Optimus" system for most integrated+dedicated card laptops, the scaling had to be disabled the options for the Intel Graphics (even though the game runs on the nVidia card). Changing scaling options anywhere else had no effect whatsoever. Very counter-intuitive.

TLDR Solution:

  • Right-click the desktop
  • Select "Graphics Propreties". This should bring up the Intel Graphics Control Panel.
  • Select Display>General Settings>Scaling
  • Switch tickbox from "maintain scaling" to "maintain aspect ratio". Click Apply


Ah, thank you for posting the solution you came up with!
(Also, Optimus! That's the utility for the laptops! I forgot the name... Been a while.)