(1.2.2753) Dev tool spawn Anima tree sometimes unable to grow anima grass.

Started by khun_poo, October 07, 2020, 11:22:35 AM

Previous topic - Next topic


Spawning Anima tree via dev tool on the map for tribal to pray around it not growing any Anima grass. To fix it, you need to cut down the said tree
(yes, -6 mood :-\ ) and respawn it again.

To test this bug.

1. Start a Lost tribal scenario. No mod. Prefer starting spot is plain Temperate forest.
2. Roll any tribal but must have a 'natural' backstories.
3. After the game start. Spawn 5 Anima trees.
--- All Anima tree spawn on normal soil, no roof and not near any wall or mountain.
--- All Anima tree have an area to grow Anima grass
--- Place 1 Anima tree with 1 Meditating spot each every 12 empty space to make sure the meditating spot not overlap between the tree.
4. Set schedule to 24 hr meditate.

The result is that 1 out of 5 tree never progress Anima grass. Even if I switch the colonist between tree, the problem tree still not seem to grow the grass at all. To fix the bug is just cut the tree and dev tool it back.

From the experiment, I found that around 1-2 out of 10 times I dev tool the Anima tree will got the bug. The tree doesn't have specific sprite (I'm not sure is the collect word, I mean the tree model.) to get the bug. Even if I cut all Anima tree and left the bug tree around to pray, it's still not grow the grass.


Dev tools are tools for development and testing.  Bugs generated by the dev tools are not typically addressed, FYI.  The game is going to behave unexpectedly if you have 5 anima trees when the game expects you to have only 1.


Yes, there are a million ways to break the game with dev tools. They're not bugs, that's just what dev tools do - break rules.
Tynan Sylvester - @TynanSylvester - Tynan's Blog