Ludeon Forums

Ludeon Forums

  • April 18, 2021, 04:32:47 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Pawn's needs gone  (Read 136 times)


  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Pawn's needs gone
« on: February 20, 2021, 03:53:13 PM »

Hello! I'm running with a ton of mods which have worked fine till now. I started off with an identical problem to this one about giddy-up caravan:
Doing some more digging I found a somewhat similar problem that was being caused by save our ship 2, however this was apparently fixed. I tried removing it anyways, and now my pawn's need menu is basically gone. Pic:
I checked the debug logs and this seems to be the main thing that pops up when I click on the needs menu, it is the same for all my colonists:
Code: [Select]
Exception ticking Barbara (at (109, 0, 155)): System.NullReferenceException: Object reference not set to an instance of an object
  at RimWorld.Thought_Banished.get_ShouldDiscard () [0x00008] in <d72310b4d8f64d25aee502792b58549f>:0
  at RimWorld.MemoryThoughtHandler.RemoveExpiredMemories () [0x0001d] in <d72310b4d8f64d25aee502792b58549f>:0
  at RimWorld.MemoryThoughtHandler.MemoryThoughtInterval () [0x00027] in <d72310b4d8f64d25aee502792b58549f>:0
  at RimWorld.ThoughtHandler.ThoughtInterval () [0x0000b] in <d72310b4d8f64d25aee502792b58549f>:0
  at RimWorld.Need_Mood.NeedInterval () [0x00011] in <d72310b4d8f64d25aee502792b58549f>:0
  at RimWorld.Pawn_NeedsTracker.NeedsTrackerTick () [0x00022] in <d72310b4d8f64d25aee502792b58549f>:0
  at Verse.Pawn.Tick () [0x000f2] in <d72310b4d8f64d25aee502792b58549f>:0
  at Verse.TickList.Tick () [0x0015c] in <d72310b4d8f64d25aee502792b58549f>:0
Verse.Log:Error(String, Boolean)

This caused some other UI problems like tooltips not showing up as well. I checked and everything worked fine for random pawns that weren't my own colonists. Attempting to reenable save our ship 2 to fix the problem didn't work. The problem could also relate to the fact that my colonists were in the middle of mounting up and reforming caravan (while it was kinda broken) when I saved, so maybe it broke there and save our ship 2 has nothing to do with it.

Here's the whole output log:

Save too big to post unfortunately. Any help appreciated. Maybe some way to "reset" the needs? I just want to fix my save since right now it is not really playable. Thanks.
« Last Edit: February 20, 2021, 04:37:21 PM by Tesert »