[Tutorial] Monodevelop and .NET 3.5 on Debian based Linux (Eg: Ubuntu)

Started by rubenwardy, July 20, 2016, 07:57:55 PM

Previous topic - Next topic


After many many hours of research, here is a repost of a blog post I made explaining how to install Monodevelop in a way that allows you to compile to .NET 3.5 http://blog.rubenwardy.com/2016/07/20/rimworld-install-monodevelop-with-dot-net-3.5/
Computer science student, game developer, and open source contributor. Twitter


Forum moderator!  Please pin this!

@rubenwardy - Good job on seeking out and providing this information.  :)
(2*b)||!(2*b) - That is the question.
There are 10 kinds of people in this world - those that understand binary and those that don't.

Powered By


Skullywag modded to death.
I'd never met an iterator I liked....until Zhentar saved me.
Why Unity5, WHY do you forsake me?


I'm on Ubuntu 16.04 and i get this warning :
W: http://download.mono-project.com/repo/debian/dists/wheezy/snapshots/3.12.0/InRelease: Signature by key 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF uses weak digest algorithm (SHA1)

just after the :

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb http://download.mono-project.com/repo/debian wheezy/snapshots/3.12.0 main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list
sudo apt-get update

Anyone know how could i fix this ? plz  :'(


Computer science student, game developer, and open source contributor. Twitter


Following the tutorial I'm failing to install the snapshot for mono-complete. It's missing the correct dependencies because when I run the following, the 4.2.1 libmono libraries are installed. sudo apt-get install build-essential cli-common libgtk2.0-cil-dev libglade2.0-cil-dev libgnome2.0-cil-dev libgconf2.0-cil-dev

I'm using Ubuntu 16.04. I successfully removed my existing Mono installation using the following command. (The tutorial steps weren't removing Mono fully) sudo apt-get purge libmono* cli-common mono-runtime

Can anyone help me sort this out?


For whatever reason I could not install the snapshot using the "sudo apt-get install -t wheezy/snapshots/3.12.0 mono-complete" line in the OP. However I found a solution online that worked.

Edit your /etc/apt/sources.list.d/mono-xamarin.list to have only this line:
deb download.mono-project.com/repo/debian wheezy/snapshots/3.12.0/. main

Then you simply enter in the terminal "sudo apt-get install mono-complete" it will keep it held at 3.12.0.

Found here:


So I recently updated to 16.04, and had to reinstall mono. Had troubles, again. What a surprise.

I used aptitude to install mono 3.12.0, which resolved whatever issues apt-get was throwing at me.


What is the advantage of using MonoDevlop over something like Visual Studio?


Quote from: rogerbacon on February 09, 2017, 07:47:54 PM
What is the advantage of using MonoDevlop over something like Visual Studio?

Visual Studio only supports Windows
Computer science student, game developer, and open source contributor. Twitter


I am using Linux Mint 18 and cannot get this to run.

After adding the source, updating and reinstalling the packages, my mono version is still 4.2.*

So far the only useful discussion on this that I could find is this: https://www.reddit.com/r/linuxquestions/comments/5x1y0v/installing_mono_3120/

However, this does not seem to help me either. Did anyone try this recently?


What output do you get with the following commands?

apt-cache show mono-devel
apt-cache policy mono-devel
Computer science student, game developer, and open source contributor. Twitter


I had the same issues on a mac, with MonoDevelop not supporting .Net 3.5. I tried doing some of this but I instead virtualized Windows 10 to run Visual Studio. I set up a shared drive so I could use my Mac's development tools and then the build process and disassemble tools of Windows.

Here's what I ended up doing.

Hope it helps.


I'm using Linux Mint 18.1 and I kept having some issues.  Finally, I ended up having to explicitly list every required mono package and its dependency by version, but this seems to have worked.

sudo apt-get install mono-runtime=3.12.1-0xamarin1 mono-runtime-sgen=3.12.1-0xamarin1 mono-runtime-common=3.12.1-0xamarin1 mono-gac=3.12.1-0xamarin1 mono-4.0-gac=3.12.1-0xamarin1 libmono-corlib4.5-cil=3.12.1-0xamarin1 libmono-security4.0-cil=3.12.1-0xamarin1 libmono-system4.0-cil=3.12.1-0xamarin1 libmono-system-configuration4.0-cil=3.12.1-0xamarin1 libmono-system-xml4.0-cil=3.12.1-0xamarin1 libmono-system-security4.0-cil=3.12.1-0xamarin1

Edit: That wasn't 100% the solution, you may need this as well:

sudo apt-get install mono-gmcs=3.12.1-0xamarin1 mono-mcs=3.12.1-0xamarin1 libmono-system-core4.0-cil=3.12.1-0xamarin1 libmono-microsoft-csharp4.0-cil=3.12.1-0xamarin1 libmono-corlib4.5-cil=3.12.1-0xamarin1 libmono-csharp4.0c-cil=3.12.1-0xamarin1 libmono-system-core4.0-cil=3.12.1-0xamarin1 libmono-posix4.0-cil=3.12.1-0xamarin1


I got mono 3.12.1 installed, but I'm currently fumbling around in MonoDevelop trying to make anything at all appear. I have Assembly-CSharp.dll open, but I'm otherwise just looking at a blank screen. Am I missing something obvious here?

[attachment deleted by admin due to age]