Ludeon Forums

Ludeon Forums

  • January 27, 2020, 04:49:17 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 91 92 [93]

Author Topic: [1.0] A RimWorld of Magic  (Read 307637 times)

Berserk

  • Muffalo
  • *
  • Posts: 9
  • Refugee
    • View Profile
Re: [1.0] A RimWorld of Magic
« Reply #1380 on: January 26, 2020, 12:34:12 AM »

Hey I'm getting a pretty nasty bug, whenever I reload the game my pawns lose all their magic levels. I'm not sure if it's a conflict, and if it is I have no idea what could be doing this. Does anyone know?
Logged

Canute

  • Transcendent
  • *****
  • Posts: 8049
  • Refugee
    • View Profile
Re: [1.0] A RimWorld of Magic
« Reply #1381 on: January 26, 2020, 02:55:30 AM »

Pretty sure it is a conflict.
Do you have any error before safing or after loading a safegame ?
Does it happen right after a new colony too (dev. mode on, then you can start with the top right icon a quick test colony).
Logged

Berserk

  • Muffalo
  • *
  • Posts: 9
  • Refugee
    • View Profile
Re: [1.0] A RimWorld of Magic
« Reply #1382 on: January 26, 2020, 03:12:10 AM »

Pretty sure it is a conflict.
Do you have any error before safing or after loading a safegame ?
Does it happen right after a new colony too (dev. mode on, then you can start with the top right icon a quick test colony).

I tried a new colony through dev mode like you said, gave a class to one of the pawns and leveled it up, reloaded and all points invested were gone. I checked the log and there are yellow errors, mostly regarding Medieval Times apparel. Though there were these 3 red errors

Edit: I just noticed that this only happens to magic classes like the priest or warlock, the gladiator saves and loads just fine

Could not resolve cross refs: System.NullReferenceException: Object reference not set to an instance of an object
  at Verse.Thing.ExposeData () [0x00000] in <filename unknown>:0
  at Verse.ThingWithComps.ExposeData () [0x00000] in <filename unknown>:0
  at Verse.CrossRefHandler.ResolveAllCrossReferences () [0x00000] in <filename unknown>:0
Verse.Log:Error(String, Boolean)
Verse.CrossRefHandler:ResolveAllCrossReferences()
Verse.ScribeLoader:FinalizeLoading()
Verse.Game:LoadGame()
Verse.SavedGameLoaderNow:LoadGameFromSaveFileNow_Patch1(String)
Verse.Root_Play:<Start>m__0()
Verse.LongEventHandler:RunEventFromAnotherThread(Action)
Verse.LongEventHandler:<UpdateCurrentAsynchronousEvent>m__1()



Could not resolve cross refs: System.NullReferenceException: Object reference not set to an instance of an object
  at Verse.Thing.ExposeData () [0x00000] in <filename unknown>:0
  at Verse.ThingWithComps.ExposeData () [0x00000] in <filename unknown>:0
  at RimWorld.Apparel.ExposeData () [0x00000] in <filename unknown>:0
  at Verse.CrossRefHandler.ResolveAllCrossReferences () [0x00000] in <filename unknown>:0
Verse.Log:Error(String, Boolean)
Verse.CrossRefHandler:ResolveAllCrossReferences()
Verse.ScribeLoader:FinalizeLoading()
Verse.Game:LoadGame()
Verse.SavedGameLoaderNow:LoadGameFromSaveFileNow_Patch1(String)
Verse.Root_Play:<Start>m__0()
Verse.LongEventHandler:RunEventFromAnotherThread(Action)
Verse.LongEventHandler:<UpdateCurrentAsynchronousEvent>m__1()



Exception spawning loaded thing null: System.NullReferenceException: Object reference not set to an instance of an object
  at Verse.Map.FinalizeLoading () [0x00000] in <filename unknown>:0
Verse.Log:Error(String, Boolean)
Verse.Map:FinalizeLoading()
Verse.Game:LoadGame()
Verse.SavedGameLoaderNow:LoadGameFromSaveFileNow_Patch1(String)
Verse.Root_Play:<Start>m__0()
Verse.LongEventHandler:RunEventFromAnotherThread(Action)
Verse.LongEventHandler:<UpdateCurrentAsynchronousEvent>m__1()
« Last Edit: January 26, 2020, 03:24:30 AM by Berserk »
Logged

Canute

  • Transcendent
  • *****
  • Posts: 8049
  • Refugee
    • View Profile
Re: [1.0] A RimWorld of Magic
« Reply #1383 on: January 26, 2020, 04:15:32 AM »

Yellow text are warning not error, and can be ignored.

All 3 msg. got "SavedGameLoaderNow:LoadGameFromSaveFileNow_Patch1"
I just checked it with Core,hugslib,jecstools,Rim of Magic and didn't saw this patch at the patch list.
Take a look at yourside.
After you start Rimworld, press CTRL-F12, open in browser
You see at first your modlist, followed by the patchlist and then the regular logfile.
Search for "LoadGameFromSaveFileNow_Patch1" at the patchlist.

If you find it maybe you can recognize the mod which do that patch, and then you got the bad mod.
But if you don't find it,sorry maybe the 50% methode with deactivating mods and retry it with new colonies help you to identify the mod. Yes time consuming annoying methode ! :-(

« Last Edit: January 26, 2020, 04:17:10 AM by Canute »
Logged

Berserk

  • Muffalo
  • *
  • Posts: 9
  • Refugee
    • View Profile
Re: [1.0] A RimWorld of Magic
« Reply #1384 on: January 26, 2020, 04:32:42 AM »

Hey thank you for the help, I'll have to do it the time consuming way I think because even my hugslib logs are pretty vague. I don't see what could be doing this, thank you again though :)
Logged
Pages: 1 ... 91 92 [93]