Ludeon Forums

Ludeon Forums

  • December 02, 2022, 05:19:15 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: UI Bug with Intel UHD GPU  (Read 6116 times)

julitoole

  • Muffalo
  • *
  • Posts: 8
  • Refugee
    • View Profile
UI Bug with Intel UHD GPU
« on: January 26, 2021, 09:39:58 PM »

Hello fellow Rimworlders,
my GPU gave up on me these last days and I still wanna enjoy it with my integrated GPU which is a intel UHD 630 and it works fine. but there is a weird bug that some textures are just white it can be ignored in a lot of cricumstances while still being annoying but at the schedule Tab its getting to the point of being an issue, as all the colors of work, sleep, anything, meditation are just white.
As this hapens with every new save game and every previous I load with or without mods, I figure it has to be some kind of bug.
So if it wasnt clear this wasnt the case with my dedicated GPU still working.

The CPU in question is a I7-8770K with the newest driver installed which is 27.20.100.9168
Pls someone have some help for me just wanna enjoy some cozy rimworld as I dont go far with that integrated GPU

thanks in advance guys
PS: The logs dont show anything really
« Last Edit: January 26, 2021, 10:20:31 PM by julitoole »
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: UI Bug with Intel UHD GPU
« Reply #1 on: January 27, 2021, 03:02:40 AM »

Hi,
not every GPU works (anymore) with the current rimworld unity grafic engine.
There is nothing the Rimworld dev's could do.
Since the latest driver didn't help, the only way is to look at the intel support and ask there.

Pheanox

  • Global Moderator
  • Planetologist
  • ****
  • Posts: 1224
  • Refugee
    • View Profile
Re: UI Bug with Intel UHD GPU
« Reply #2 on: January 27, 2021, 12:01:20 PM »

Unfortunately with the Unity update that came with 1.1 some GPUs were indeed made obsolete.  I'll move this to the 'Support' forum just in case you can get better help there.
Logged

julitoole

  • Muffalo
  • *
  • Posts: 8
  • Refugee
    • View Profile
Re: UI Bug with Intel UHD GPU
« Reply #3 on: January 27, 2021, 08:24:53 PM »

Ok, thanks for moving it.
Sad that it cant be fixed easily...
Logged

brownbreadjupiter

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: UI Bug with Intel UHD GPU
« Reply #4 on: April 11, 2021, 12:36:29 PM »

This is still an issue on Intel driver v27.20.100.9316. (i5-1135g7, Xe graphics)

Any idea what specifically is causing this? Can it not be reported to Unity/Intel or at least workedaround in game.
If not the game should maybe have a warning on store page that it cannot be played properly on intel iGPUs.
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: UI Bug with Intel UHD GPU
« Reply #5 on: April 11, 2021, 12:40:12 PM »

It isn't the game or untiy (game engine) fault, when the developer of your videocard stop supporting things.

I've had this exact problem, you need to change your drivers to a previous version. Ill try to find which version.
EDIT:
If you have an intel graphics card, go to https://downloadcenter.intel.com/download/29988/Intel-Graphics-Windows-10-DCH-Drivers
It and download the exe version of the 27.20.100.8935 driver. It worked for me at least.
« Last Edit: April 11, 2021, 12:41:59 PM by Canute »
Logged

brownbreadjupiter

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: UI Bug with Intel UHD GPU
« Reply #6 on: April 12, 2021, 02:40:04 AM »

Regardless for a game like Rimworld I expect a large number of people will buy the game wanting to play on integrated graphics (Not to mention intel supposed dedicated gpu if it comes out). This effects not just old CPUs but the latest ones too.

If the game will not support intel iGPUs then the requirements on the store pages should really be updated to reflect this.
« Last Edit: April 12, 2021, 02:41:54 AM by brownbreadjupiter »
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: UI Bug with Intel UHD GPU
« Reply #7 on: April 12, 2021, 03:27:40 AM »

That your opinion.
I would say there is a bug at the iGPU video driver. Old driver works fine it is only the newer ones which cause the problem.

Ark

  • Colonist
  • ***
  • Posts: 330
  • Constitutional peasant
    • View Profile
Re: UI Bug with Intel UHD GPU
« Reply #8 on: May 12, 2021, 05:27:12 PM »

This bug is propably fixed in 27.20.100.9466. If not, let them know.
https://community.intel.com/t5/Graphics/RimWorld-Rendering-Regression-UHD620/td-p/1242494
Logged

julitoole

  • Muffalo
  • *
  • Posts: 8
  • Refugee
    • View Profile
Re: UI Bug with Intel UHD GPU
« Reply #9 on: July 22, 2021, 10:00:33 AM »

Hey I am so sorry guys I forgot my manners and didnt tell you that indeed with a update to the Intel Video driver the issue indeed was fixed to the full extend.
Which exactly I can not tell but the Number from ARK seemed familiar.

still thanks to anyone who made the effort to discuss further.
Logged