If the game won't start properly

Started by Tynan, July 16, 2014, 04:46:40 PM

Previous topic - Next topic


Thanks for the reply, unfortunately it seems that the problem is 1.3 has raised the specs of the game to the point where past a certain amount of mods the game simply can't run and crashes instead, as I've just tried out the same mod list on a more powerful machine and have had no problems.


What with this ??

Few days I save the game, the game has broken when saving. next time when I want play i got this errors.


I would say, to many bad mods.

Any mod that give you an error after activation/rimworld startup is a bad mod.
Maybe take a look at the 2.link from my signature.



Quote from: xtremebassface on June 22, 2021, 04:24:20 AMHello,
i wanted to start playing Rimworld again, i stopped playing when there apparently were big incombatibilities between Unity and certain Linux configurations a while back.
Now ive installed a fresh, unmodded/unsubscribed instance of Rimworld, started it up, but i only get the in-game mouse cursor, theme song, but no picture. Still seeing the Steam interface "through" the window, so its a graphical problem it seems.
Machine is a Lenovo X230 running Artix Linux, installed mesa drivers and everything. Trying to start the game with the included shell scripts produce the same result.
ive also tried to manually switch from fullscreen to windowed mode, in my experience that works rather often when theres a case like that. But when i try to edit .config/Unity3d/Ludeon Studios/prefs, it will immediately revert back to the default configuration (which seems to be fullscreen).

I'm having the same sort of issue. I'm running Arch Linux with a Tiling Window Manager, and the game loads perfectly except that the screen is black. I can even move around the menus and hear the button-sounds, indicating that the issue is grapical only.
My graphics card is a reasonably modern AMD card. I'm not getting any crash logs because the game isn't crashing, it's just unusable because it's a black screen.

I've worked through all the options Tynan suggested, even running with forced-software-rendering, to no avail. RimWorld ran fine on the same hardware before I switched to Arch, So I'm pretty sure it's not a hardware issue. I'm out of ideas on how to fix this, please help?


Hi everyone,

Until recently I was able to play Rimworld without any issues. I wanted to start completely fresh and with no mods so i turned off all of my mods in the in game mods manager and unsubbed from them all through steam, but since i did I have not been able to start the game. I've been trying to fix this issue for about 7 hours now and cant find a way to get it to work.

I have tried a fresh install of the game and deleting the config files, I have tried as many things as I could find that might work to help fix it. I play on an AMD laptop that can usually run a few hundred mods without lagging at all. This is my only PC for the moment and Rimworld is My favourite PC game. I run the game through Steam.

Any help would be appreciated.

Thank you in advance for any and all help.


Well hello there everyone um, so I know my computer is old and its a laptop and my graphics drivers last available updates are from a while ago but Rimworld used to run just fine. And I hadnt played in a while but now I try to play it and i get the unity error on startup that lasts a half second and then the game just never starts. I tried everything listed above, ive even rebooted my laptop, ive checked for programs that could potentially interfere with steam or rimworld, Ive done the windows memory diagnostic thingy and im running out of options =_=. I wanna be sure it's my hardware that just isnt compatible before i give up lol. Although as I said, It used to run just fine T.T.

Here's my sys info :

Device name    DESKTOP-J86PU6N
Processor    Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz  2.20 GHz
Installed RAM    8.00 GB

THere are two graphic cards :    AMD Radeon HD 6700M Series
                            :  Intel(R) HD Graphics 3000

As I said, I know they aint the best but it used to work and all the drivers are up to date :/ DirectX is as well. Here is the content of the crash file : 

player log
error log

Im tryna upload the crash dmp and im actually not sure how if you need it but anyways. Help lol


    Basically on Mac Ventura 13.6.4
    With Steam.

    Launching the game segfault (I guess).
    Nothing is shown from executable on command line

    I was using an external screen and at a certain point I was hitting Command+F (because it was a long time i did not play it - on win - and had some Mod for search not searching anymore).

    What happened is that on mac this will exit fullscren and go to a windowed version. Hitting again I noticed the resolution got fucked up. It became like 16:9. Command+F again repeteadly basically increased the resolution. I believe I fucked up my mac with some Brew install stuff on screen resolution earlier on. That's not the point though. I looked for a Config.xlm and found out a width of 133.000 something pixels. 133 screens worth.

    I changed back but I believe Steam cache stuff in some weird .db places.

    Anyway, I reinstalled through Steam. Still launching gives coredumps.

    While closing Steam altogether, I rm -fr * the Config from
    • Users/[username]/Library/Application Support/Ludeon Studios/RimWorld/Config
    Nothing. The other path, the one for Cache, provided by OP, is not there in mac. There's a com.valve.etcetect but can't see anything from there too.I grep the whole folder for screeWidth ... nothingI can't investigate on the Config folder because according to the suggeston I deleted the content. it's now empty and obviously not repopulating it :'(

edit: the log tells me things to do with screen resolutions indeed but I don't know the code, and after all this is a game not a job :D
You cannot view this attachment.

- Not even Step3 (i.e. deleting from terminal the game and workshop, with the actual correct paths for Mac) and reintalling works

- Clearing the download cache with Steam->Preferences->Download->Clear Download Cache will also not work.

I will not try to see if it's the Mod, but if this forum would be as dead as it seem, someone from the company could tell me what the code on my log is referring to... or where to look. Luckily I haven't bought all the DLC, that would be major sucking to have 100euro wasted this way.