If the game won't start properly

Started by Tynan, July 16, 2014, 04:46:40 PM

Previous topic - Next topic


Have a Intergrated Intel Card (G45/G43 - OpenGL 2.1) had to use "MESA_GLSL_VERSION_OVERRIDE=150 MESA_GL_VERSION_OVERRIDE=3.2 ./start_RimWorld_openglfix.sh" in terminal (cd to game directory) to get the game running. I don't suppose anyone knows how to translate that to be used in steam's launcher options for the game? Tried entering it as is and with the full path to the sh file. Also tried putting the "MESA_GLSL_VERSION_OVERRIDE=150 MESA_GL_VERSION_OVERRIDE=3.2" part after them as well and still no luck. :/


Good afternoon!
Achtung!!! Sorry for my mistakes in the text.
I don't know English very well and I can confuse times or Google Translate could not understand me correctly.

I have a licensed version of the game in Steam and I and have a problem. After the purchase Royalty
and its installation, I began to see this:

Without Royalty everything works fine.
I deleted the game and downloaded again.
The steam says the files are not damaged.

I will be very grateful if someone helps me.


i think you got old remain files at your installation.
Take a look into the Mods folder of your rimworld installation.
When you see a Core folder delete it.
If there isn't a Core folder, go back and delete the Data (not the ...._data) folder and let steam repair/reinstall it.


if I understand you correctly it should be like this:

but I have so:RimWorld/Mods/notebook

when I delete ''Mods'' or  ''Data''  the game does not work.
Maybe I misunderstood you?


There is sometimes a problem with the steam updater, he didn't delete all old installation files. So uninstall wouldn't fix the problems since the folders/files are still there.
Thats why you need to manualy delete them.

It should looks like
------Royalty (if you got that DLC)

------Core (if you see Core in the Mods folder delete it)
------(and what ever mods you have installed)

When you got the Core folder under Mods, thats the main problem, delete it and start Rimworld.

If you still got errors, then just manualy delete the whole installation (not uninstall) and let steam reinstall/repair it.


The Mac version 1.1.2654 rev668 has no executable in the .app
Downloaded DRM free from sendowl.


I don't know if this is precisely the correct place for this. I can start the base game, but I bought Royalty recently and the DLC refuses to load. I can start the base game just fine and when I open the mod list, Royalty is there but deactivated. When I reactive it, of course Rimworld notices a new mod and tried to restart. When it comes back up, Royalty is disable again.

Help! I've tried turning off all my mods but this is still happening. I feel like I can't even play the base game because once this is fixed, I'm going to want to start something new with Royalty!


be sure base game and DLC got the same version number.


The current DRM-free version for MacOS (1.2.2753 rev705) is missing executable permissions. Also, the developer credentials are missing/incorrect.
1. Open Terminal.app and enter "cd /Applications/RimWorldMac.app; chmod -R +x *"
2. Launch (only the first time) with Alt+right-click, "open", and click the "open" button when prompted.

I know this is an easy fix for you, but it's also an easy mistake to make. So will you consider distributing the DRM-free version on itch.io?? The Royalty add-on could simply be one of the download options, or another product page altogether.
Some of us do not like Steam and others wouldn't know how to fix this.  Mods do not work on Steam without an internet connection (or manual install), and the manual installation of mods on a DRM-free version is what lead me here.


Hi. How do I turn off color blindness mode? Radeon vega 11 graphic, win10.


Hey guys, got issue with game it wont start no error popup after visiting event viewer I saw problem

Faulting application name: RimWorldWin64.exe, version: 2019.2.17.24627, time stamp: 0x5df1e6e4
Faulting module name: mono-2.0-bdwgc.dll, version:, time stamp: 0x5dc03abb
Exception code: 0xc0000409
Fault offset: 0x0000000000337e64
Faulting process id: 0x520
Faulting application start time: 0x01d6fca3078f9883

After googling a few minutes I didn't found solution.
I have:
Nvidia 3070 newest drivers
Ryzen 5600X
Month old Windows
I bought it on GOG


could you maybe add the logfile to your answer, it is located
%userprofile%\AppData\LocalLow\Ludeon Studios\RimWorld by Ludeon Studios\Player.log
You need to use reply before you can see file attachment options.

I never encounter "Faulting module name: mono-2.0-bdwgc.dll", so i don't have any big ideas. And since your windows is just a month old i think you have no old rimworld version or old video driver.
Maybe the logfile show more.


i wanted to start playing Rimworld again, i stopped playing when there apparently were big incombatibilities between Unity and certain Linux configurations a while back.
Now ive installed a fresh, unmodded/unsubscribed instance of Rimworld, started it up, but i only get the in-game mouse cursor, theme song, but no picture. Still seeing the Steam interface "through" the window, so its a graphical problem it seems.
Machine is a Lenovo X230 running Artix Linux, installed mesa drivers and everything. Trying to start the game with the included shell scripts produce the same result.
ive also tried to manually switch from fullscreen to windowed mode, in my experience that works rather often when theres a case like that. But when i try to edit .config/Unity3d/Ludeon Studios/prefs, it will immediately revert back to the default configuration (which seems to be fullscreen).


with the newer version there came an upgrade to the unity engine too, which require a better videocard then before.
I think you Lenovo X230 isn't longer capable to run Rimworld.
You should try to update the video driver if that maybe change anything, but beside that i don't think you can do anything.


wtf. so even though RW isnt the most graphics intensive game there is (i can play stellaris and skyrim on low settings on this machine still) it's Unity which just doesnt bother with backwards combatibility anymore? well, it is what it is then. thanks though.