Ludeon Forums

Ludeon Forums

  • April 18, 2021, 05:13:57 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Save-breaking bug with no determinate cause  (Read 231 times)

birbules

  • Muffalo
  • *
  • Posts: 1
  • Refugee
    • View Profile
Save-breaking bug with no determinate cause
« on: January 25, 2021, 06:27:35 AM »

Hello!

I've been playing a fairly heavily modded Rimworld game for a while now and only just recently, I've run into a severe issue that causes my current colonies' map to generate completely grey, as so:



I have an autosave that luckily is devoid of this bug, but it always, no matter what I've tried, eventually ends up like the image above. I think I've managed to narrow it down to one specific error in the debug log:

Code: [Select]
Root level exception in Update(): System.InvalidCastException: Specified cast is not valid.
  at RimWorld.PowerConnectionMaker+<PotentialConnectorsForTransmitter>d__5.MoveNext () [0x00119] in <d72310b4d8f64d25aee502792b58549f>:0
  at System.Linq.Enumerable.Count[TSource] (System.Collections.Generic.IEnumerable`1[T] source) [0x00052] in <351e49e2a5bf4fd6beabb458ce2255f3>:0
  at VFEMech.PotentialConnectorsForTransmitter_Patch.Postfix (System.Collections.Generic.IEnumerable`1[RimWorld.CompPower]& __result, RimWorld.CompPower b) [0x00001] in <38822466d329429fa844bf0eb6a57d01>:0
  at (wrapper dynamic-method) RimWorld.PowerConnectionMaker.RimWorld.PowerConnectionMaker.PotentialConnectorsForTransmitter_Patch1(RimWorld.CompPower)
  at RimWorld.PowerConnectionMaker.ConnectAllConnectorsToTransmitter (RimWorld.CompPower newTransmitter) [0x00000] in <d72310b4d8f64d25aee502792b58549f>:0
  at RimWorld.PowerNetManager.TryCreateNetAt (Verse.IntVec3 cell) [0x00058] in <d72310b4d8f64d25aee502792b58549f>:0
  at RimWorld.PowerNetManager.UpdatePowerNetsAndConnections_First () [0x001cb] in <d72310b4d8f64d25aee502792b58549f>:0
  at (wrapper dynamic-method) Verse.Map.Verse.Map.MapUpdate_Patch2(Verse.Map)
  at (wrapper dynamic-method) Verse.Game.Verse.Game.UpdatePlay_Patch2(Verse.Game)
  at (wrapper dynamic-method) Verse.Root_Play.Verse.Root_Play.Update_Patch1(Verse.Root_Play)
Verse.Log:Error(String, Boolean)
Verse.Root_Play:Verse.Root_Play.Update_Patch1(Root_Play)

It seems to have something to do with my power grid and a structure that is trying to make a connection, but I wouldn't have a clue which it would be and why.  As far as I know, I see no way to properly resolve this issue without having to completely abandon my save which, you know, would kind of suck :(

Here is my log and modlist for reference:

https://gist.github.com/HugsLibRecordKeeper/50525b9fa5da12cc015d8e1784282433

Any help would be greatly appreciated, thanks in advance!
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9906
  • Refugee
    • View Profile
Re: Save-breaking bug with no determinate cause
« Reply #1 on: January 25, 2021, 08:45:30 AM »

Hi,
since the error is about power/powerconnection i would ask at first place the author of
Underground Power Conduits
and/or
Vanilla Furniture Expanded - Power

tuk0z

  • Muffalo
  • *
  • Posts: 4
  • Refugee
    • View Profile
Re: Save-breaking bug with no determinate cause
« Reply #2 on: February 03, 2021, 05:37:30 PM »

Have the same issue, at least exact same error (minus a few lines named after mods I don't use) than birbules. I use neither Underground Power Conduits nor Vanilla Furniture Expanded - Power but Murmur's Subsurface Conduit, and just reported to this dev on the Steam workshop mod page
Logged