Ludeon Forums

Ludeon Forums

  • July 02, 2022, 04:40:07 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: [1.3.3066(64 Bit)Win] My pawn's are invisible  (Read 2386 times)

zZz_Goblin_zZz

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
[1.3.3066(64 Bit)Win] My pawn's are invisible
« on: July 20, 2021, 11:47:07 PM »

I start a new game on 1.3.3066, without mods. And since the pawn selection, they are invisible, and when I start the game the characters are invisible including the animals. When I go back to version 1.2 the pawns are generated normally.
 
 
Save: https://drive.google.com/file/d/1hdHzARBT4GNP6EvaVOFI00VWbNC8vbYr/view?usp=sharing




« Last Edit: July 22, 2021, 10:08:18 PM by zZz_Goblin_zZz »
Logged

Ark

  • Colonist
  • ***
  • Posts: 316
  • Constitutional peasant
    • View Profile
Re: [1.3.3066(64 Bit)] My pawn's are invisible
« Reply #1 on: July 21, 2021, 12:06:36 PM »

Windows/Linux/Mac? Player.log? https://ludeon.com/forums/index.php?topic=513.0
Try to change the resolution and windowed/fullscreen. Try wearing/dropping clothes.
Logged

zZz_Goblin_zZz

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.3.3066(64 Bit)Win] My pawn's are invisible
« Reply #2 on: July 22, 2021, 10:11:23 PM »

I tried but the bug continues. (btw how to upload images on post?)

LOG:
RimWorld 1.3.3067 rev1397
UnityEngine.StackTraceUtility:ExtractStackTrace ()
Verse.Log:Message (string)
RimWorld.VersionControl:LogVersionNumber ()
Verse.Root:CheckGlobalInit ()
Verse.Root:Start ()
Verse.Root_Entry:Start ()

Loading game from file New Arrivals1 with mods:
  - Ludeon.RimWorld
  - Ludeon.RimWorld.Ideology
  - Ludeon.RimWorld.Royalty
UnityEngine.StackTraceUtility:ExtractStackTrace ()
Verse.Log:Message (string)
Verse.SavedGameLoaderNow:LoadGameFromSaveFileNow (string)
Verse.Root_Play/<>c:<Start>b__1_1 ()
Verse.LongEventHandler:RunEventFromAnotherThread (System.Action)
Verse.LongEventHandler/<>c:<UpdateCurrentAsynchronousEvent>b__27_0 ()
System.Threading.ThreadHelper:ThreadStart_Context (object)
System.Threading.ExecutionContext:RunInternal (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool)
System.Threading.ExecutionContext:Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool)
System.Threading.ExecutionContext:Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object)
System.Threading.ThreadHelper:ThreadStart ()
« Last Edit: July 22, 2021, 10:21:45 PM by zZz_Goblin_zZz »
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: [1.3.3066(64 Bit)Win] My pawn's are invisible
« Reply #3 on: July 23, 2021, 03:10:34 AM »

Quote
I tried but the bug continues. (btw how to upload images on post?)
You need to use the Reply button, then you see file attachment options.
Or you upload your pic's somewhere else and post the links.
And it would help to read "How to report a bug" then you would locate the logfile better, or play with button and notice the "Files" button at the log window would let you open the logfile too.

But currently i don't see a fix for you, you are the first one who got the problem at windows, but serveral other got the problem at linux.
Did you try to update the videodriver yet ?

Gecco66

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.3.3066(64 Bit)Win] My pawn's are invisible
« Reply #4 on: July 23, 2021, 03:57:06 AM »

Same problem here.

I have 1.3.3067 and pawns are still invisible.

I attached player.log and a printscreen in the ZIP file.
Logged

Tartan_Wolf

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.3.3066(64 Bit)Win] My pawn's are invisible
« Reply #5 on: July 23, 2021, 04:21:32 AM »

Same problem here. Anyone got any ideas on a fix?
Logged

Gecco66

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.3.3066(64 Bit)Win] My pawn's are invisible
« Reply #6 on: July 23, 2021, 08:51:19 AM »

According to other forum this problem already occured in 2019, but then the cause was the mods.
https://steamcommunity.com/app/294100/discussions/0/1644295067072795814/


If you are using a lot of mods that add races or replaces vanilla body textures then equipping things that aren't compatible with the new body textures will cause either the Pawn's body to turn into a pink X symbol inside a pink box or will make their bodies disappear and they will just be floating heads.

Whenever the bug occurs, in the real-time Dev logs. It lists [pawn name] as missing a body type. I would spawn pirates in to test and it would happen if say, for 1 in every 10 or 20 pirates. This is especially more annoying since I don't personally use any kind of body mods.
Logged

Nikki128

  • Muffalo
  • *
  • Posts: 2
  • Refugee
    • View Profile
Re: [1.3.3066(64 Bit)Win] My pawn's are invisible
« Reply #7 on: July 23, 2021, 10:01:21 AM »

im on windows and i have the same problem. my pawns are still invisible even with no mods whatsoever. Anybody know how to fix yet?
Logged

Gecco66

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.3.3066(64 Bit)Win] My pawn's are invisible
« Reply #8 on: July 23, 2021, 01:05:55 PM »

in this topic you can find solution to invisible pawns.

https://ludeon.com/forums/index.php?topic=50142.0

haha, I actually solved the problem a short while after posting after days of trying to figure out what was wrong. It turns out my rgba code for color generation wasn't in the correct format, which I didnt even consider since the log wasnt throwing out any errors but makes sense in hindsight.
Logged

zZz_Goblin_zZz

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.3.3066(64 Bit)Win] My pawn's are invisible
« Reply #9 on: July 23, 2021, 01:16:59 PM »

im not using any mod...

(I can't put images because the file is too big)
 LOG:
« Last Edit: July 23, 2021, 01:25:42 PM by zZz_Goblin_zZz »
Logged

Tartan_Wolf

  • Muffalo
  • *
  • Posts: 3
  • Refugee
    • View Profile
Re: [1.3.3066(64 Bit)Win] My pawn's are invisible
« Reply #10 on: July 23, 2021, 01:52:27 PM »

Ok just as people seem to be missing the point. The invisible pawn/creature problem is happening to players who are not using mods so solutions of remove insert mod name here will not work. Any help/fix is appreciated.
Logged

Canute

  • Transcendent
  • *****
  • Posts: 9999
  • Refugee
    • View Profile
Re: [1.3.3066(64 Bit)Win] My pawn's are invisible
« Reply #11 on: July 25, 2021, 04:32:21 PM »

I think i found the reason for the problem.
Looks like all use a Intel(R) G41 Express Chipset (another one confirmed the same videocard at the generel discussion)
https://ludeon.com/forums/index.php?topic=54812.0

I would call it a video driver issue, similar to the white instead coloured things.
https://ludeon.com/forums/index.php?topic=53771.0

If you like you can try to report it to the Intel support and hope for new video drivers, or try older video driver maybe these work (i have no idea).

Moderator Note:
Thanks Canute for the research.
« Last Edit: August 20, 2021, 06:24:29 PM by Pheanox »
Logged